Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Reply
Thread Tools Search this Thread Display Modes
Old 4th July 2005, 23:00   #241
ccsnet
Junior Member
 
Join Date: Jul 2005
Posts: 2
Congrats and a question

Quote:
Originally posted by DrO
Playlist Loader v0.9.9.7b (formerly known as B4S Playlist Loader)
  • Fixed a nasty temp download issue when doing a link drag and drop onto winamp where full file links such as http://blah/blah.mp3 would be attempted to be downloaded when they shouldn't be)
get v0.9.9.7b

I hate bugs

-daz
Hi, this is my first post here and although I have used Winamp in a cut down form for many years I've never used it in anger as such - so if its a silly question I ask - please dont shoot me....

That been said - what a fantasic plugin - ideal... and another nail in the cofin of WMP.

Right that been said... I have just done a clean install of Winamp on my desktop and tried to launch the radio feed from www.manxradio.com - it straight away asks me for a m3u file... which I assumed it wanted to use as a temp play list so I saved it....

Just to test I restarted it again... and the same happerned ( btw tried clicking on the link on the site and double clicking a locally saved ( and drag and copy ) copy of the asx file... but no it still wanted the m3u file.

Next step was to save one.. no it would only let me over wright an existing one so I tried starting via double click on that file... no luck there...

So my question is.... is there any way to stop it asking for this file and just start the feed be it setting a default or some thing else.

Thanks

BTW... this thred ( http://www.mp3car.com/vbulletin/show...3&postcount=38 ) may explaine where I am coming from

Thanks in advance - once again if this is a Winamp thing and its user error thanks for taking the time to read

Terran
ccsnet is offline   Reply With Quote
Old 4th July 2005, 23:15   #242
billyvnilly
Forum King, M.D.
 
billyvnilly's Avatar
 
Join Date: Mar 2004
Location: Detroit burbs
Posts: 3,379
Send a message via ICQ to billyvnilly Send a message via AIM to billyvnilly
i can get it to play directly from the browser (clicked "FM" > asked me what i wanted to do with the .asx > automatically went into winamp playlist.) the odd thing about it, is that i already have the default set for .asx in firefox, yet it treats this link as an unknown file. I dont really understand why it (being winamp?) would ask for m3u.


what browser are you using and what is your default for .asx files?

clicking: http://62.25.96.7/manxradio

results in: http://62.25.96.7/manxradio?MSWMExt=.asf/.wma

read this info
billyvnilly is offline   Reply With Quote
Old 4th July 2005, 23:25   #243
ccsnet
Junior Member
 
Join Date: Jul 2005
Posts: 2
Hi,

IE with all the fixes... hope the attached is of some use...

BTW - re tried the above links... still failed...

Terran

PS Sorry for the poor quality - the form would not allow me to attach a bigger file....

EDIT One thought... I have never played any thing but the default file... could that be some thing to do with this ? RE-EDIT - Nope lol.
Attached Images
File Type: gif winampprob.gif (97.8 KB, 272 views)
ccsnet is offline   Reply With Quote
Old 4th July 2005, 23:41   #244
billyvnilly
Forum King, M.D.
 
billyvnilly's Avatar
 
Join Date: Mar 2004
Location: Detroit burbs
Posts: 3,379
Send a message via ICQ to billyvnilly Send a message via AIM to billyvnilly
yeah i cannot get that link to play in winamp from IE, it loads directly into WMP. i can however save target as... save to my desktop and drag+drop to winamp. have you ever tried firefox? j/k


yes your attachment is all in order... goto the link above and read about extensionless streams.
billyvnilly is offline   Reply With Quote
Old 4th July 2005, 23:44   #245
DrO
 
Join Date: Sep 2003
Posts: 27,873
if you click on the link in IE and drag it onto Winamp then the plugin will load the playlist fine. i'm not sure why clicking doesn't work but WMP seems to have some extra handling implemented somewhere which allows it to correctly work (damn MS)

-daz
DrO is offline   Reply With Quote
Old 4th July 2005, 23:47   #246
billyvnilly
Forum King, M.D.
 
billyvnilly's Avatar
 
Join Date: Mar 2004
Location: Detroit burbs
Posts: 3,379
Send a message via ICQ to billyvnilly Send a message via AIM to billyvnilly
its weird, firefox, treats that link as an unknown file... even though it is .asx


damn WMP
billyvnilly is offline   Reply With Quote
Old 5th July 2005, 00:16   #247
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
It's not a playlist file, it's a direct link to the stream
WMP = http://62.25.96.7/manxradio
Winamp = http://62.25.96.7/manxradio/.wma (Playlist > Add > url)
DJ Egg is offline   Reply With Quote
Old 5th July 2005, 14:47   #248
DrO
 
Join Date: Sep 2003
Posts: 27,873
Playlist Loader v0.9.9.8 RC5 (formerly known as B4S Playlist Loader)
  • Added in extra handling for http:// links to attempt to parse them for potential playlists (since the evil people who make the download links make this a possibility)
    (If you do attempt to add in wierd extensionless http:// links into Winamp then there can be a few second delay whilst the plugin checks for it being a supported playlist type)
  • Added in initial removal of un-supported features from the plugin when Winamp does not have in_wm.dll present (still alpha)
  • Made sure that all variables are correctly initialised to remove any potential conflicts in the code
get v0.9.9.8 RC5

This one needs to be tested a fair bit since i don't think i've broken anything with the extra http:// parsing of extensionless urls (ie not definitely *.asx for example). This has been internally in use by a few people in a slightly older version of this build for at least a month without any apparent issues but nothing beats getting others to check things as well

-daz
DrO is offline   Reply With Quote
Old 16th July 2005, 11:58   #249
fisher819
Senior Member
 
fisher819's Avatar
 
Join Date: Sep 2004
Location: Lebanon
Posts: 225
Send a message via Yahoo to fisher819
found something, but i don't know if it's completly related to this plugin.

when I open the about in any nero application, and click on the nero link winamp opens the link instead of firefox.

help us count :Click here
fisher819 is offline   Reply With Quote
Old 25th July 2005, 12:10   #250
Chris2712
Junior Member
 
Join Date: Jul 2005
Posts: 2
HELP!

Dear all,

sorry- am entirely new to this, and haven't a clue what I'm doing. I've been surfing all related forums and not found an answer to my prob - at least not one that I understood

Basically, I am trying to listen to a radio station from the UK, found at http://www.classicfm.com/index.cfm?nodeId=315&sw=1024

(Click the "Listen Now" Button). - Even after installing all relevant plugins, my Winamp (Pro, 5.094) doesn't play the relevant file - it works fine under WMP, telling me the final URL is http://audio.musicradio.com/playlist.asx?show=5

Incidentally, putting this directly into Winamps "Open URL" doesn't appear to work either..., my Winamp then proceeds to tell me

347929B2d01 - whatever that means...

There is probably sth obvious I'm missing, but as I am small and thick, please please help!

Thanx!
Chris2712 is offline   Reply With Quote
Old 25th July 2005, 12:18   #251
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
When I click the "Listen Now" link, the stream opens directly in Winamp and plays perfectly ok.

mms://audio1.musicradio.com/classicfm/.wma

Requires Winamp Full/Pro with the WMA Input plugin present (in_wm.dll), Playlist Loader plugin installed, and ASX and mms:// selected in Winamp > Prefs > File Types (to make Winamp the default asx handler)... though the stream will play ok by just manually adding that url.


Also note that the url you provided is wrong, it's an .asp (active server page) link, not an .asx playlist link:
http://audio.musicradio.com/Player.asp?show=5

Clicking this link then opens a playlist.asx file which contains the direct mms:// stream links...
DJ Egg is offline   Reply With Quote
Old 25th July 2005, 12:25   #252
Chris2712
Junior Member
 
Join Date: Jul 2005
Posts: 2
well - have manually added it now, and it works fine! Have absolutely no idea what was going on before - but thanx a million for your help!

C.
Chris2712 is offline   Reply With Quote
Old 4th August 2005, 19:45   #253
jmatthews112
Major Dude
 
Join Date: Jun 2003
Posts: 1,661
Send a message via AIM to jmatthews112 Send a message via Yahoo to jmatthews112
In daz's trademark style, since he seems to have overlooked pimping his own updates:

Playlist Loader v0.9.9.8 RC6 (formerly known as B4S Playlist Loader)
  • Fixed handling of the Add/Open URL dialogs to now work correctly when dealing with exentensionless urls like http://blah:1337
  • Fixed handling of urls ending with \ or / when making a temporary download for the testing of urls being asx based playlists
get v0.9.9.8 RC6

Let's see if he chooses to fill us in on anymore.

jmat
jmatthews112 is offline   Reply With Quote
Old 4th August 2005, 19:51   #254
DrO
 
Join Date: Sep 2003
Posts: 27,873
not forgotten, just i uploaded that right before sleep and worked straight through 8am to 7pm today so i didn't have a lunch break to properly sit down and make the relevant updates about this

i've still got a few minor tweaks to this to improve certain situations such as when there's no wma support since all of the extra asx/wpl handling in those cases needs to be controlled more tightly. and there's something else i'm considering putting in before 1.0...

-daz
DrO is offline   Reply With Quote
Old 14th August 2005, 12:59   #255
elem
Junior Member
 
Join Date: Aug 2004
Posts: 10
Send a message via Yahoo to elem
Ok...I can't open WPL file with winamp eaven when installed this plugin. No wpl in winamp preferences and file types association... Can anyone plz tell me how can i get this plugin to work?

I installed PluginPack (on Winamp 5.04) and nothing....none of the extension works;/
PLZ

Last edited by elem; 14th August 2005 at 13:46.
elem is offline   Reply With Quote
Old 14th August 2005, 17:50   #256
billyvnilly
Forum King, M.D.
 
billyvnilly's Avatar
 
Join Date: Mar 2004
Location: Detroit burbs
Posts: 3,379
Send a message via ICQ to billyvnilly Send a message via AIM to billyvnilly
are you sure you installed the latest version 0.9.9.8 RC6? because wpl is in the filetypes under preferences > file types (second from bottom)


[edit] just tested with a wpl i just made (bc i never use wmp) and it worked just fine.
billyvnilly is offline   Reply With Quote
Old 14th August 2005, 19:59   #257
elem
Junior Member
 
Join Date: Aug 2004
Posts: 10
Send a message via Yahoo to elem
Yes i install this from your link now....
and nothing no wpl;(...drag and drop function nt working too...I downloaded iPod plugin an installed it..and it works fine;(
elem is offline   Reply With Quote
Old 14th August 2005, 22:28   #258
DrO
 
Join Date: Sep 2003
Posts: 27,873
so once you installed a different plugin the options appeared? can you confirm you have the full version of winamp installed including wma support (ie in_wm.dll) since with the very latest build if there's no in_wm present then any unrelated options like asx/wpl loading are effectively hidden. also does it even show in the the general purpose page of the preferences?

-daz
DrO is offline   Reply With Quote
Old 15th August 2005, 11:14   #259
elem
Junior Member
 
Join Date: Aug 2004
Posts: 10
Send a message via Yahoo to elem
so once you installed a different plugin the options appeared?

Yes...I ried 3or four plugins not yours and works...from your page all are not working;/

can you confirm you have the full version of winamp

Yes (Winamp 5.094 Pro)

installed including wma support (ie in_wm.dll) since with the very latest build if there's no in_wm present then any unrelated options like asx/wpl loading are effectively hidden.

Yes "in_wm.dll" it is in plugins folder.

Also does it even show in the the general purpose page of the preferences?

No....none of plugins fron Pluginpack and separate from Playlist Loader are not present in winamp (Options\Plugins\General\)

And in preferences (file types) it isn't shown too;/ no wpl and asx

Last edited by elem; 15th August 2005 at 11:46.
elem is offline   Reply With Quote
Old 15th August 2005, 12:06   #260
DrO
 
Join Date: Sep 2003
Posts: 27,873
do you have XP's DEP setting enabled for all programs since that was known to prevent further plugins loaded after the jump to file extra plugin but if you're using 5.094 then that shouldn't be an issue anymore)

can you confirm that a gen_b4s2m3u.dll (or something very similar to that name) exists in the plugin's directory since i can't think of anyother reason for the plugin to fail to load since it doesn't have any weird dll dependancies which could cause a fail to load that i'm aware of (since it's designed to work even on a fresh win95 install)

-daz
DrO is offline   Reply With Quote
Old 15th August 2005, 19:58   #261
elem
Junior Member
 
Join Date: Aug 2004
Posts: 10
Send a message via Yahoo to elem
Thanx DrO now it works... stupid DEP Got 64 bit processor so Dep is enabled for all...are you planning to fix your program to work with DEP?

THANX ONCE AGAIN
elem is offline   Reply With Quote
Old 15th August 2005, 20:01   #262
DrO
 
Join Date: Sep 2003
Posts: 27,873
the only plugin which was known to not correctly work with DEP enabled is the jump to file extra plugin and a fixed version of that is shipped in 5.094 or you can use one of the latest dev builds of the plugin instead. or if you don't use any of the queue/jump to file features then you can remove gen_jumpex (since on re-reading i notice you're using 5.04 and probably should be using 5.094 )

-daz
DrO is offline   Reply With Quote
Old 15th August 2005, 20:11   #263
elem
Junior Member
 
Join Date: Aug 2004
Posts: 10
Send a message via Yahoo to elem
Hmmm... unfortunetly when i installed all your plugins pack all of them were not shown...it was caused be one plugin?

Playlist Loader wasn't offered too after install (without plugin pack) of course when Dep was enabled but Winamp wasn't on list.

HHEHE...you r righ..to many builds of Winamp
Thanx once more
elem is offline   Reply With Quote
Old 11th September 2005, 01:05   #264
DrO
 
Join Date: Sep 2003
Posts: 27,873
Playlist Loader v0.9.9.8 RC7 (formerly known as B4S Playlist Loader)
  • Fixed an issue with folder location handling for newer versions of Winamp
  • Added support to the Add/Open Folder dialogs to now handle b4s and wpl playlist files (asx based ones are not currently scanned for since the processing on them slows Winamp down)
  • Fixed a small potential pointer crash
get v0.9.9.8 RC7

The main question is.. should asx playlists be enumerated when using the add/open folder dialog? The reason for this is that they require proper processing (which can include some internet downloading) which will slow the adding process down. The options i can think of are some form of messagebox prompt, a on/off setting or just leave it as is since asx formats should only be used for streams/online media really. So what's people's views on it?

-daz
DrO is offline   Reply With Quote
Old 11th September 2005, 22:16   #265
Mouser X
Member
 
Join Date: Feb 2004
Posts: 79
I say leave it out by default. However, to please those who might want it, I'd add it as a selectable choice in the configureation of the plugin. I know I'd never turn it on personaly, mainly because I avoid downloading streaming video (my net connection could use a lot of improvement). However, there will most likely be those who complain because they can't see them when they try to load them from the loading box (not that I ever use that either, actually...). Anyway, there's my 2 cents. Mouser X over and out.
Mouser X is offline   Reply With Quote
Old 26th September 2005, 21:33   #266
SkaFreak
Senior Member
 
Join Date: May 2003
Location: St. Louis MO
Posts: 256
Send a message via AIM to SkaFreak
This isn't working for me.

I have indtalled Winamp 5.1 Pro the latest version of the playlist loader and the WMA Input plugin.

I try to play my WMA stream by clicking the online link, doing play URL, and saving the file and trying to load it as a file, and no way works.

The link is at http://www.skafreaks.com on the right side in the Radio box
The link is
http://xgen.vitalstream.com/mcasx.as...ackage=1834819

Thanks for any help
SkaFreak

Ska Rules!!!
SkaFreak is offline   Reply With Quote
Old 26th September 2005, 22:25   #267
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
Hmm... weird

mms://media.vitalstream.com/12592_live_club10692.asf?media=1891037&package=1834819&event=0&=.wma

That plays fine when added manually via: winamp > playlist > add > url

and if you right click your link and select "save target/link as", the saved .asx gets parsed correctly when loaded locally.

Over to DrO...
DJ Egg is offline   Reply With Quote
Old 26th September 2005, 23:14   #268
SkaFreak
Senior Member
 
Join Date: May 2003
Location: St. Louis MO
Posts: 256
Send a message via AIM to SkaFreak
Just uninstalled Winamp, then Reinstalled it Installed the latest version of the Playlist Loader and it works now.

Ska Rules!!!
SkaFreak is offline   Reply With Quote
Old 26th September 2005, 23:20   #269
DrO
 
Join Date: Sep 2003
Posts: 27,873
weird.

for me if i click on the direct link i don't have the asx added into the playlist (and then expanded). if i save it locally and then add it then it works fine. if i add the direct url via the add url dialog then it just passes the url through (which it shouldn't be doing )

i'm going to have to look into these issues a bit more (since i need to see how i can fix things to make asx files go to winamp correctly when wmp will handle them fine in all cases, i think there's some download handler i need to patch/implement..)

-daz
DrO is offline   Reply With Quote
Old 6th October 2005, 19:02   #270
DLNipper
Junior Member
 
Join Date: May 2001
Posts: 4
Don't know if additional issues belong in this thread, but here it goes.

Stumbled upon a pretty neat site:
http://cdzinc.com

Trying to get winamp 5.1 pro to stream the links found there.
For example, if I click on a "play" link on this page:
http://cdzinc.com/K/32/rock/C_D/devo.html
winamp starts and queues a seemingly random file name (not the web address) and doesn't play.
I can right click on the play link, copy location and Add url to the Playlist with joy. An example would be:
http://a425.v8384d.c8384.g.vm.akamai...158_1_6_05.asf

Currently using winXP pro, firefox 1.5 beta 1, Playlist Loader
0.9.9.8 RC7. Have tried toggling ASF in the "ASX based playlists" panel, but that makes clicking on the "play" link open winamp with an open file dialogue.
I've associated .ASF and .ASX with winamp in Windows.
I've removed .ASF and .ASX browser associations from Firefox (funny how it never asks me to add them again when I click on a link, is this the issue? And I can't seem to add them manually.)

Hoping someone can give me some input on this.

Thanks.
DLN
DLNipper is offline   Reply With Quote
Old 6th October 2005, 20:05   #271
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
ASF isn't a playlist format and therefore isn't even handled by Playlist Loader. ASF streams are handled directly by the DirectShow Decoder (in_dshow.dll), no Playlist Loader plugin required (ie. you've posted in the wrong thread, heh).

If you're having problems when clicking those links in firefox, then try just drag+dropping the asf urls directly into the Winamp playlist. Works fine for me.
DJ Egg is offline   Reply With Quote
Old 6th October 2005, 20:52   #272
DLNipper
Junior Member
 
Join Date: May 2001
Posts: 4
D'oh! (...and I was trying to be all smart and stuff.)

Thanks for your reply.

The drag and drop does work. Thank you.

I know I'm fixating now, but do you have any idea why Firefox wouldn't open it up directly?

DLN
DLNipper is offline   Reply With Quote
Old 10th October 2005, 13:22   #273
DrO
 
Join Date: Sep 2003
Posts: 27,873
general update on this plugin and the add/open url dialog handling seems to be broken (not sure if it's down to changes in newer winamp versions or what) so i'm looking to try to get a new fixed build out in the next few days (plus i need to keep Egg happy since he's had 'issues' with this a few times recently ) may be able to get this working sooner once i get my work machine setup for some lunch time dev capabilities...

-daz
DrO is offline   Reply With Quote
Old 23rd October 2005, 01:33   #274
DrO
 
Join Date: Sep 2003
Posts: 27,873
Playlist Loader v0.9.9.8 (formerly known as B4S Playlist Loader)
  • Fixed the handling of urls that are tested for being asx files but aren't and were not being added to the playlist as they were
  • Improved the file downloader to hopefully abort asap if it accidentally is passed a shoutcast based url (should improve handling of incorrect hits)
  • Upgraded status to a final release (there are a few things to be tweaked/implemented otherwise it's nearly 1.0 time!)
get v0.9.9.8

Finalised build of the 0.9.9.8 series now I need to sort out file extension control, some minor tweaks such as with sc url detection to improve the non-handling of them and a few other things that i need possibly for some other plugins (nothing major for general usage normally )

-daz
DrO is offline   Reply With Quote
Old 24th October 2005, 21:47   #275
AntiFM
Member
 
Join Date: Jun 2005
Posts: 99
Send a message via AIM to AntiFM
ok im alittle lost here
what exactly does this tool do?
whats it for?
AntiFM is offline   Reply With Quote
Old 24th October 2005, 22:03   #276
JonnyMac
Moderator
 
JonnyMac's Avatar
 
Join Date: Dec 2000
Posts: 14,385
Winamp can not natively handle Microsoft's proprietary playlist format, commonly referred as ASX playlists and are usually used for streaming media files on the internet.
DrO's Playlist Loader is a "listener side" (not for SHOUTcasting/broadcasting) plug-in allows Winamp to use ASX fromat playlists. More info...

Playlist Loader

Please do not PM me for tech support. Any request for tech support through PM will be ignored.
Read the Stickies
---> | | | | <--- Knowledge is power
JonnyMac is offline   Reply With Quote
Old 23rd November 2005, 01:45   #277
DrO
 
Join Date: Sep 2003
Posts: 27,873
Playlist Loader v0.9.9.8c (formerly known as B4S Playlist Loader)
  • Fixed the ASX exclusion list to keep all filetypes selected if that was set instead of incorrectly returning back to default after restarting Winamp
  • Fixed a bug where pressing the 'default' button to reset the exclusion list required 2 clicks if all file types were selected
  • Added the ability for the 'Extra Options' preferences page entry to remember if it was collapsed or not (dead useful for tidying up your prefs tree!)
get v0.9.9.8c

And so the mini builds on the way to 1.0 begin. This is mainly a minor bug fix build of a preferences issues that Egg had (which he's been pestering me to fix for a while) and at the same time i got the collapse/expand state of the 'Extra Options' prefs entry to work correctly as well (worth the upgrade alone imho to keep the preferences tree a bit tidier as needed )

-daz
DrO is offline   Reply With Quote
Old 4th December 2005, 18:06   #278
Shakey803
Junior Member
 
Join Date: Dec 2005
Location: UK
Posts: 12
AX in Winamp

DrO/ujay,

It's with great interest that I've been reading this forum in that I have the same problem as Walter66. I'm trying to get Winamp to play http://196.35.64.36/clients/5fm/5fm_22.asx so that I can get my MP101 to play it. I tried the suggestion above whereby you run Winamp, then <L> to open the above 'file'. Winamp then hangs completely.
If I try and run the link itself (having installed the asx file types plug-in), I get the "error syncing to mpeg" message.
Would you possibly try the above and let me know if it'd possible to play in winamp please?
Would much appreciate any advice on this.
Kind regards,
Shakey.
Shakey803 is offline   Reply With Quote
Old 4th December 2005, 18:50   #279
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
Dead link :/
DJ Egg is offline   Reply With Quote
Old 4th December 2005, 19:01   #280
Shakey803
Junior Member
 
Join Date: Dec 2005
Location: UK
Posts: 12
Sorry, should be http://www.antfarm.co.za/clients/5fm/5fm_22.asx
Shakey803 is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump