Old 9th March 2006, 17:51   #161
VPR5703
Banned
 
Join Date: Mar 2006
Posts: 1
yeah. Winamp 5.2 and the new iPod plugin messed up the iTunes database on my iPod. I have a 2G 4GB Mini, and after I transferred songs from my library onto the iPod, it stopped being recongnized by Winamp. No problem on Explorer though. my theory is that the plugin erase or damaged the iTuns onboard database, therefore making the device forget what songs are where. My applause to Will, for releasing what should still be a beta release in a public final. Congratulations for giving Winamp a bad reputation, and causing us iPod users such a hard time. Now I wait as I transfer the 4GB of songs I had on there back, and switch, although regretablly, BACK to iTunes.
VPR5703 is offline   Reply With Quote
Old 9th March 2006, 18:12   #162
jbond23
Junior Member
 
Join Date: Jan 2006
Location: London, UK
Posts: 32
Just a thought. If you take v5.2, uninstall ml_pmp.dll from C:\Program Files\Winamp\Plugins and install the old ml_ipod does it work?
jbond23 is offline   Reply With Quote
Old 10th March 2006, 09:55   #163
will
Nullsoft Newbie (Moderator)
 
will's Avatar
 
Join Date: Mar 2001
Location: Sheffield, England
Posts: 5,569
VPR5703: You forget that I am an iPod user (I own and use 3 iPods) and don't use anything except winamp 5.2.

Welcome to banned-land.

DO NOT PM ME WITH TECH SUPPORT QUESTIONS
will is offline   Reply With Quote
Old 10th March 2006, 13:08   #164
darkus
Junior Member
 
Join Date: May 2005
Posts: 7
Don't ban him for badmouthing your programming. The overwhelming majority appreciate what you are doing for us will (myself included). But any good product needs the critics to help make it even better, the old saying I think is true, competition/critics make improves the product. Anyways, please don't ban me I do love the new plugin and can't wait for video ipod support!
darkus is offline   Reply With Quote
Old 10th March 2006, 14:36   #165
bunklung
Junior Member
 
Join Date: Feb 2006
Posts: 14
Quote:
Originally posted by darkus
Don't ban him for badmouthing your programming. The overwhelming majority appreciate what you are doing for us will (myself included). But any good product needs the critics to help make it even better, the old saying I think is true, competition/critics make improves the product. Anyways, please don't ban me I do love the new plugin and can't wait for video ipod support!
The way I understood the problem(s) with the new plugin for IPOD users is that the OLD plugin never is uninstalled when you install 5.2 which has the NEW plugin.
My friend's 40G ipod got SUPER hosed because of this. I can see where tempers would flare when your entire collection gets hosed from an application delivery problem, if intended at all.
Back in the day I always uninstalled old apps before installing the new ones. Now I just install over them. Most new installers remove the older versions and I assume at this point that the vendor would include this feature if they felt it was nessasary.
bunklung is offline   Reply With Quote
Old 10th March 2006, 19:09   #166
will
Nullsoft Newbie (Moderator)
 
will's Avatar
 
Join Date: Mar 2001
Location: Sheffield, England
Posts: 5,569
Quote:
Originally posted by darkus
Don't ban him for badmouthing your programming. The overwhelming majority appreciate what you are doing for us will (myself included). But any good product needs the critics to help make it even better, the old saying I think is true, competition/critics make improves the product. Anyways, please don't ban me I do love the new plugin and can't wait for video ipod support!
I banned him for personal insults. Constructive criticism is fine.

The problem here is that mlipod is a 3rd party plugin not supported by nullsoft. 5.21 should fix the issue.

DO NOT PM ME WITH TECH SUPPORT QUESTIONS
will is offline   Reply With Quote
Old 10th March 2006, 20:04   #167
shakey_snake
Forum Domo
 
shakey_snake's Avatar
 
Join Date: Jan 2004
Location: Everyone, get over here for the picture!
Posts: 4,313
Quote:
5.21 should fix the issue.

No reason you couldn't leak the updated plug right?
DrO gives us between-release versions of JTFE...


elevatorladyelevatorladyelevatorladyelevatorladyelevatorladylevitateme
shakey_snake is offline   Reply With Quote
Old 10th March 2006, 20:19   #168
CraigF
Passionately Apathetic
Administrator
 
CraigF's Avatar
 
Join Date: May 2000
Location: Hell
Posts: 5,435
5.21 is out.

CraigF is offline   Reply With Quote
Old 11th March 2006, 14:36   #169
blankoboy
Junior Member
 
Join Date: Feb 2006
Location: Tokyo, Japan
Posts: 10
Yay, ver 5.21 is out! ...but still no Muvo 4GB lovin' support
blankoboy is offline   Reply With Quote
Old 11th March 2006, 23:38   #170
MasterViVi
Senior Member
 
MasterViVi's Avatar
 
Join Date: Nov 2003
Posts: 290
Small question: are G1 iPods supported?
MasterViVi is offline   Reply With Quote
Old 12th March 2006, 02:47   #171
shaneh
Major Dude
 
Join Date: Jan 2004
Location: Brisbane, Australia
Posts: 1,193
http://forums.winamp.com/showthread....72#post1867072

Leaving an ipod plugged in when shutting down winamp causes a silent crash and all meta data to be lost (ie playcounts, ratings etc). Could this issue at least be acknowledged?

http://forums.winamp.com/showthread....27#post1867427
Quote:
Anyhow, I hope that you got the bug report ok this time. It would be good if we knew when a ticket was raised for an issue or not, or used bugzilla or something, instead of just wading through noise in a forum thread, or getting accused of being a broken record. I still dont know whether drag drop support is broken or just not implemented yet.
shaneh is offline   Reply With Quote
Old 12th March 2006, 05:30   #172
inspectorgadget
Junior Member
 
Join Date: Apr 2005
Posts: 5
Quote:
Originally posted by will
Just because I don't respond it doesn't mean I've ignored it. I have noted the existance of this problem and will look into a fix.
Yo, was just making sure . I love winamp, not giving up on it anytime soon... Thanks man.
inspectorgadget is offline   Reply With Quote
Old 13th March 2006, 04:53   #173
skywalker6705
Junior Member
 
skywalker6705's Avatar
 
Join Date: Oct 2002
Posts: 35
Send a message via AIM to skywalker6705 Send a message via Yahoo to skywalker6705
update wait

I just wanna follow up my previous post that I do really appreciate the integration into winamp. I think adding a auto uninstall/backup of ml_iPod is definately in order, and I'm looking foreward to the point when ml_pmp offers all the features I appreciated from ml_iPod. Also, I sincerly hope that it does not scrap the Copy to Hard Drive feature in order to try and be more mainstream like iTunes. I haven't been able to upgrade my winamp in months now because of all these new feature rollouts. Something between versions 5.09 and 5.2 broke my video playback, but that's been resolved, but this is coupled with it. I'm going to wait for a few more revisions on this plugin before retrying it, as refilling my iPod, and recovering my Media Library Playlists (which thank GOD I backed up) was quite a long process. Keep up the good work man, I'll keep a hopeful eye open.
skywalker6705 is offline   Reply With Quote
Old 17th March 2006, 04:11   #174
Digital Alchemy
Junior Member
 
Join Date: Jun 2005
Location: B-More
Posts: 8
Send a message via ICQ to Digital Alchemy Send a message via AIM to Digital Alchemy Send a message via Yahoo to Digital Alchemy
no playlists...no problem

if all you want to do is load you music in one big bang without a playlist, then ive found a workaround.
create a playlist in winamp and load it to the media library. if you try to send the playlist it will say that the feature is not there (fine). click on the 'sel' button at the bottom and Select All (Ctrl+A). now right click on one of the files and send to the ipod. it wont create a playlist, but you can load a whole ipod worth of music in one shot. it took about 5 minutes for my computer to load the music before it started sending it to the ipod and that was 2272 files across my home network. enjoy
Digital Alchemy is offline   Reply With Quote
Old 20th March 2006, 05:01   #175
krustwell
Junior Member
 
Join Date: Mar 2006
Posts: 1
apologies if this has been covered: my C:\ is showing up under "Portables". it has no name, but if i click on it (whether there's an iPod connected or not), it crashes Winamp instantly. can't "eject" the C:\ as a portable b/c it says "Failed to Eject iPod. Is something else using it?".

i still don't have good functionality with v5.2 and my iPod, but i'm not giving up. i hate iTunes and love Winamp and just purchased the full version after years of freeloading. i hope my $20 goes to good use.
krustwell is offline   Reply With Quote
Old 23rd March 2006, 13:31   #176
Mistacal
Junior Member
 
Join Date: Mar 2006
Posts: 1
Hey People

Q: I have a Creative Zen Extra 60GB with PlayForSure Firmware 2.10.03. Also is the driver installed on my pc. When I connect the Zen I get the popup window. There I choose for "play with winamp" and nothing happends. Then I start winamp manualy and click on "portable devices" then the zen is being read (takes I while with 40GB of music). All the songs on the Zen are displayed. But now comes the problem. It gives A message that the device not support direct playback. But when I play songs with the Creative Explorer direct play option is does. So whats the problem with winamp? Does it need an extra plug-in?

Thanks in advance
Mistacal is offline   Reply With Quote
Old 23rd March 2006, 13:36   #177
jimisola
Junior Member
 
Join Date: Jul 2005
Posts: 17
Quote:
Originally posted by will
5.21 should fix the issue.
Will, just wondering if "should fix" equals "fixed" now that 5.21 is out?

Hence, is it safe to use 5.21 for G5 iPod (I had the problems with duplicates etc)?

Regards,
Jimisola
jimisola is offline   Reply With Quote
Old 23rd March 2006, 14:45   #178
will
Nullsoft Newbie (Moderator)
 
will's Avatar
 
Join Date: Mar 2001
Location: Sheffield, England
Posts: 5,569
Yes.

DO NOT PM ME WITH TECH SUPPORT QUESTIONS
will is offline   Reply With Quote
Old 25th March 2006, 06:22   #179
DrthVdr1219
Junior Member
 
Join Date: Mar 2006
Location: PA
Posts: 1
Rio Carbon problems

I have a Rio Carbon with firmware 1.95, so it functions as an MTP device. It is PlaysForSure compatible. However, not only does it not show up in the Winamp device list, but it also crashes Winamp after a short period regardless of whether or not I try to do anything with it. This is very annoying, because not only can't I use Winamp to update my player, but I can't have Winamp running in the background when I plug the player in or it will crash. Any fixes regarding this would be greatly appreciated as I really don't like the Rio software very much.
DrthVdr1219 is offline   Reply With Quote
Old 25th March 2006, 14:33   #180
jimisola
Junior Member
 
Join Date: Jul 2005
Posts: 17
Quote:
Originally posted by will
Yes.
Sad to say no. Cause it does not!

After you convinced me I gave it a 2nd shot...

After less than one minute of use I had already experienced the following:

1) still get duplicates when syncing
2) complete OS freeze and then a reboot (not sure if there was a blue screen for a blink of an eye) when I tried to remove duplicates by using "Remove from device" on my whole device

I am, sadly, going back to 5.1 and ml_ipod.

Later edit:

FYI, no problems at all with WinAmp 5.12 and ml_ipod 1.31.

Jimisola

Last edited by jimisola; 25th March 2006 at 14:58.
jimisola is offline   Reply With Quote
Old 26th March 2006, 19:43   #181
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
In latest iTunes, it is possible for any file to mark it as "remember playback position" and "skip when shuffling" in "Options". This is absolutely necessary stuff for audio books in MP3 format.

Do you support this (or plan to) with pmp_ipod?

Or even better, we could be a step ahead of iTunes: A possibility to mark a track as "audiobook", so that i shows up in the iPod audiobooks section, AND does automatically have the above two things (playback position...) (Usuallay this is done by using AAC files with an *.m4b extension, but it should be possible for MP3, too)

As long as this is not possible, I'll have to stick with iTunes (which I hate).
-Achim

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline   Reply With Quote
Old 27th March 2006, 22:50   #182
Wildbeliefs
Junior Member
 
Join Date: Mar 2006
Posts: 1
Quote:
Originally posted by jimisola
Sad to say no. Cause it does not!

...
5.21 does not fix the issue for me neither. I unsuspectingly installed v5.21 of winamp without reading the forums, and now I can't access the 60 gigs of music on my iPod.

I have backups of it, so it's not the end of the world, but it's incredibly annoying because I only have usb1 at home and therefore it's going to take me a good 24 hours to format and transfer everything back.

Couldn't there at the very least be a big red warning somewhere on the download page so that users don't upgrade to something broken? It's great and all that it's on the forum, but a common winamp user doesn't read the forums before installing an update.
Wildbeliefs is offline   Reply With Quote
Old 29th March 2006, 02:39   #183
sadohert
Junior Member
 
Join Date: Feb 2006
Posts: 3
Quote:
Originally posted by omarello
the new beta seems to work without throwing that error and
also on the ipod is there a way to get my podcasts to show in the podcast section after the music menu... i can access them from the Music/Genre/Podcast area, but the Music/Pocast area is now empty..

thanks a lot u guys...
I'm having this exact same problem. I actually hadn't tried navigating any other way *but* Music/Podcast... I'll go try that.

Great job on this plugin Will. YOu *just* learned C++ for writing the first version?!?! Good job man. Do you work for Nullsoft now because of that.

Stu

As an aside. I just flipped over to iTunes while I have Winamp playing music off the ipod and the listing of tracks was all jumbled. Kinda like different lists were printed over the same part of the screen multiple times. Anyway, just in case that helps.
sadohert is offline   Reply With Quote
Old 30th March 2006, 16:51   #184
Unwashed
Junior Member
 
Join Date: Jan 2005
Posts: 5
eventually got it working - with an effort

Hello all

Just to report that I eventually got the portable device support working in v5.21 and my 20GB ipod - but not without a fight.

I rather stupidly upgraded this morning and found that firstly my old ml ipod plugin clashed with the new portable device plugin, and when I got rid of the older plugin the ipod couldn't be read (but could be seen) at all. Eventually I downgraded, installed the old plugin, copied as much of my ipod to my work laptop. Then I upgraded the ipod firmware to v3.1.1 and restored the ipod to default settings. I removed the old ipod plugin from winamp, closed it, and re-upgraded to v5.21. It only then saw this empty device, and only then could I repopulate it.

What the new plugin does it does smoothly, but I did immediately miss the extra functionality of the old plugin which was just so brilliant.

Incidentally in the process of all of this I tried out iTunes again and reminded myself why I use Winamp, so thanks for that 'opportunity'.

I am slightly surprised that such a buggy plugin was allowed in a final release.
Unwashed is offline   Reply With Quote
Old 30th March 2006, 17:20   #185
will
Nullsoft Newbie (Moderator)
 
will's Avatar
 
Join Date: Mar 2001
Location: Sheffield, England
Posts: 5,569
Those problems are to do with mlipod, NOT the new stuff. The new stuff is much less buggy than mlipod.

DO NOT PM ME WITH TECH SUPPORT QUESTIONS
will is offline   Reply With Quote
Old 30th March 2006, 18:45   #186
Unwashed
Junior Member
 
Join Date: Jan 2005
Posts: 5
Will,

I take it then this is the nub of the problem - the mlipod plugin worked reasonably well in itself, but had its own way of handling the ipod which does not work so well with the new plugin. Gotchya. So there may well be a period of slightly painful transition while everyone shifts over to the new plugin.

Thanks again

Baz
Unwashed is offline   Reply With Quote
Old 30th March 2006, 20:44   #187
will
Nullsoft Newbie (Moderator)
 
will's Avatar
 
Join Date: Mar 2001
Location: Sheffield, England
Posts: 5,569
actually, i believe that its changes made to the media library in winamp 5.2 that make mlipod incompatable, this makes it screw up.

DO NOT PM ME WITH TECH SUPPORT QUESTIONS
will is offline   Reply With Quote
Old 31st March 2006, 01:24   #188
Thunder Pussy
Feed me a stray dog
(Major Dude)
 
Join Date: Oct 2004
Posts: 1,122
I'm so slow to try new things...

Pro: pmp feels a lot more solid than ml_ipod ever did. Having a working alarm clock is worth giving up some functionality for the time being. The transfer queue is nice too, and I like the icons. It'll probably take a few users (like me) a bit of adjustment to use the transfer queue instead of sync confirmation box.


Things that are notably missing, highest to lowest in importance to me:
new smart playlist
global hotkeys to sync & eject
smartshuffle
queries
search field remembers query
search playlist

Pretty solid though, and it looks good. As you say, will, pmp is much less buggy. No issues to report.

Thanks will.
Thunder Pussy is offline   Reply With Quote
Old 31st March 2006, 10:45   #189
will
Nullsoft Newbie (Moderator)
 
will's Avatar
 
Join Date: Mar 2001
Location: Sheffield, England
Posts: 5,569
Interesting, some of those could be done very easily. I'll look into as many as I can. Thanks man!

DO NOT PM ME WITH TECH SUPPORT QUESTIONS
will is offline   Reply With Quote
Old 31st March 2006, 12:04   #190
will
Nullsoft Newbie (Moderator)
 
will's Avatar
 
Join Date: Mar 2001
Location: Sheffield, England
Posts: 5,569
ok, as of the next version you will have hotkeys and, in playlists be able to hit Ctrl+F to find tracks.

DO NOT PM ME WITH TECH SUPPORT QUESTIONS
will is offline   Reply With Quote
Old 31st March 2006, 16:49   #191
shakey_snake
Forum Domo
 
shakey_snake's Avatar
 
Join Date: Jan 2004
Location: Everyone, get over here for the picture!
Posts: 4,313
Will, I just Mp3gained my collection, but I still have the ungained files on my iPod.
Is there an easy way to "resync"?


elevatorladyelevatorladyelevatorladyelevatorladyelevatorladylevitateme
shakey_snake is offline   Reply With Quote
Old 31st March 2006, 17:06   #192
will
Nullsoft Newbie (Moderator)
 
will's Avatar
 
Join Date: Mar 2001
Location: Sheffield, England
Posts: 5,569
Just delete them all and hit the "Sync" button again I guess.

DO NOT PM ME WITH TECH SUPPORT QUESTIONS
will is offline   Reply With Quote
Old 31st March 2006, 17:09   #193
shakey_snake
Forum Domo
 
shakey_snake's Avatar
 
Join Date: Jan 2004
Location: Everyone, get over here for the picture!
Posts: 4,313
yeah, but I've got more music on my comp than 30gig's...

Yeah, I guess I'll just have to "brute" it.


[edit]Any progress on a "Compilation" checkbox? (new to nano's and 5gens)


elevatorladyelevatorladyelevatorladyelevatorladyelevatorladylevitateme
shakey_snake is offline   Reply With Quote
Old 31st March 2006, 17:38   #194
gibson042
Junior Member
 
Join Date: Mar 2006
Posts: 1
will, what about plain old USB Mass Storage MP3 players? What's the word on support for them?
gibson042 is offline   Reply With Quote
Old 31st March 2006, 21:05   #195
CraigF
Passionately Apathetic
Administrator
 
CraigF's Avatar
 
Join Date: May 2000
Location: Hell
Posts: 5,435
Work was started on it, but Will took a break from it to complete more pressing matters in his private life. Thats the last I heard.

CraigF is offline   Reply With Quote
Old 7th April 2006, 15:06   #196
psiphic
Junior Member
 
Join Date: Apr 2006
Posts: 1
Quote:
Originally posted by jbond23
Does the Plugin support direct playback with Creative NJB devices? There's a report on the Creative forums that a Zen Touch with the old NJB firmware gives the same "device doesn't support direct playback" message.
I can confirm that direct playback doesn't work with the old NJB firmware either. (The same here..)

I'd also like having direct playback..
for me it's the very last feature missing in winamp.. i don't want to install creative's crappy software no more..

Is there any advantage/disadvantage in upgrading to PFS firmware at all? Ok, possibly native WMP support, but anything else? (As i don't want this thread to become too OT, i'd prefer answers via pm, thanks )
psiphic is offline   Reply With Quote
Old 7th April 2006, 23:30   #197
will
Nullsoft Newbie (Moderator)
 
will's Avatar
 
Join Date: Mar 2001
Location: Sheffield, England
Posts: 5,569
Nothing else. If you're happy with the old firmware, there is no point upgrading.

DO NOT PM ME WITH TECH SUPPORT QUESTIONS
will is offline   Reply With Quote
Old 10th April 2006, 10:10   #198
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
no drag/drop with ml_pmp?

Dragging files from the ML file list to the iPod does not work at all? I've read that playlist transfer will be in 5.22, but no drag'n drop at all in 5.21? I'm not sure if my installation is screwed up - or is this really intended? Only "Send to" menu works to transfer files to iPod.

I was so used to this with ml_ipod. Is it possible that such a basic thing is missing? Or am I missing some point here?
I would expect to be able to drag a file to the iPod icon or even to one of the playlists on the iPod, which all show up in the tree on the left. But the cursor does not change to the "+" sign, as it does when dragging files to local playlists...

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline   Reply With Quote
Old 10th April 2006, 19:25   #199
Infin8cyn
Junior Member
 
Join Date: Nov 2005
Posts: 4
Re: no drag/drop with ml_pmp?

Quote:
Originally posted by abu
Dragging files from the ML file list to the iPod does not work at all? I've read that playlist transfer will be in 5.22, but no drag'n drop at all in 5.21?
Drag&Drop hasn't worked on any of my 5.21 Installs w/my 4th Gen. 60GB iPod.
Infin8cyn is offline   Reply With Quote
Old 11th April 2006, 12:24   #200
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Re: Re: no drag/drop with ml_pmp?

Quote:
Originally posted by Infin8cyn
Drag&Drop hasn't worked on any of my 5.21 Installs w/my 4th Gen. 60GB iPod.
Ok, so it's not my fault, at least

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump