Old 14th August 2006, 05:31   #321
alexjoey
Junior Member
 
alexjoey's Avatar
 
Join Date: Aug 2006
Location: France
Posts: 36
Quote:
Originally posted by DJ Egg
@BugMaster
Thanks. Fixed :-)
I'm thanking you too, because me too with Ccleaner since a long time I always witness that, without beleiving that fixing was possible.

And about my GENRE of id3tags something else to say ?

Good day.

[Edit --> DJ Egg]
Yes, the genre drop-down has also been fixed.

Last edited by alexjoey; 14th August 2006 at 08:00.
alexjoey is offline  
Old 14th August 2006, 08:14   #322
kearnemj
Guest
 
Posts: n/a
top borderline of track field box in .mp3 id3v1&2 window isnt displaying correctly. minor bug.
winamp build 812, no third party plugins. happens to all my mp3s
 
Old 14th August 2006, 09:51   #323
Bubba Smith
Major Dude
 
Bubba Smith's Avatar
 
Join Date: Apr 2006
Location: Bubbaville, USA
Posts: 599
Quote:
Originally posted by kearnemj
top borderline of track field box in .mp3 id3v1&2 window isnt displaying correctly. minor bug.
winamp build 812, no third party plugins. happens to all my mp3s
I'm using build 812 and no such problem.
Screenshot...



Track fields are fine, as you can see. Same with every MP3. No variance.
Bubba Smith is offline  
Old 14th August 2006, 10:27   #324
menno
Junior Member
 
Join Date: Oct 2003
Posts: 16
I see you made some elaboration on the MP4 HE AAC settings page about the "accurate" and "backward compatible" information. It says "backwards compatible" will show as LC AAC in the info box, that is just a failure of your info box. Make it read the extended backwards compatible audio specific config correctly, I think what you actually mean is that it will show LC AAC as HE AAC? You can use the backwards compatible info to explicitly turn off SBR using the sbr_present_flag, if it's 0 just say LC AAC if it is 1 say HE AAC. Doing that removes all disadvantages of using backwards compatible info and makes "accurate" (not more accurate at all) info completely useless.

PS. If I select the high bitrate encoder it starts some BS about buying MP3.
menno is offline  
Old 14th August 2006, 16:01   #325
Juanus
Major Dude
 
Juanus's Avatar
 
Join Date: Oct 2004
Location: Santa Monica, CA
Posts: 740
Send a message via AIM to Juanus
Hey Guys, About the preferences lock up reported in the threads listed below. I thought that I had uploaded the crash logs in my previous post and I appologize. The file was too big to be attached and I did not check.

http://forums.winamp.com/showthread....72#post2008572
http://forums.winamp.com/showthread....66#post2009266
http://forums.winamp.com/showthread....93#post2009293

crash logs attached.
Attached Files
File Type: zip crash(2).zip (40.0 KB, 555 views)
Juanus is offline  
Old 14th August 2006, 22:51   #326
Winner2
Member
 
Join Date: Jul 2002
Posts: 62
Quote:
Originally posted by Koopatrooper
Just noticed another issue with 24Bit playback.

The Signal Processing Studio plugin (dsp_sps) seems to have problems with 24Bit.

When I use e.g. the preset "justin - reverseness.sps" my left speakers just make noise. Reproduced with .ogg and .acc (in MP4 container) files.

When I uncheck "Allow 24 bit" everything is fine, the plugin works as expected.

Using Audigy 2, latest drivers, no EAX enabled, speakers setup 5.1.
I can confirm the same "reverseness" problem reported by Koopatrooper, with a similar setup, only using a 2/2.1 speaker configuration with my SoundBlaster Audigy 2ZS. There seems to be sound output trouble with other studio plugin modules as well.
Winner2 is offline  
Old 14th August 2006, 23:01   #327
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
Re: dsp plugins & 24bit

maybe this will explain it best...
Attached Images
File Type: png 24bit_warning.png (8.7 KB, 700 views)
DJ Egg is offline  
Old 14th August 2006, 23:05   #328
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,341
Funny enough, that it was my idea to add this information dialog.

But from the changelog of Winamp 5.02:

Quote:
* made SPS support 24 bit samples
So I would call it a bug, not a limitation, or am I wrong?

We don't talk about any third party DSP plug-in, it's the dsp_sps plug-in, which is bundled with Winamp 5.x.

Nevertheless, I will install 5.24 and check if I can reproduce the 24Bit problem, then I can say, if this is related to 5.25 beta.
Koopa is offline  
Old 14th August 2006, 23:13   #329
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
Yeah, that's input, not output.

Apparently izotope ozone plugin works with 24bit output, so it probably means that those which don't will all need some kind of update (sorry, I'm not sure of the exact details, heh).
DJ Egg is offline  
Old 14th August 2006, 23:17   #330
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,341
Quote:
Yeah, that's input, not output.
Then sorry, I misunderstood the changelog. Thanks for pointing this out.
Quote:
so it probably means that those which don't will all need some kind of update
Yeah, the information dialog when you enable 24Bit is ok, but the bundled dsp plugin should be updated and work with 24Bit too, if possible.
Koopa is offline  
Old 14th August 2006, 23:20   #331
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
Agreed, heh.
DJ Egg is offline  
Old 14th August 2006, 23:57   #332
amano
Major Dude
 
amano's Avatar
 
Join Date: Apr 2003
Location: where the llamas come from!
Posts: 952
In this thread Josh Coalson promised to sort out the license stuff for the next flac release: http://www.hydrogenaudio.org/forums/...ic=46898&st=25

eeeee eeeeeee eeeee eeeee eeeee
8 8 8 8 8 8 8 8 8 8 88
8eee8 8e 8 8 8eee8 8e 8 8 8
88 8 88 8 8 88 8 88 8 8 8
88 8 88 8 8 88 8 88 8 8eee8
amano is offline  
Old 14th August 2006, 23:59   #333
Benski
Ben Allison
Former Winamp Developer
 
Benski's Avatar
 
Join Date: Jan 2005
Location: Brooklyn, NY
Posts: 1,057
Quote:
Originally posted by Koopatrooper
Funny enough, that it was my idea to add this information dialog.

But from the changelog of Winamp 5.02:



So I would call it a bug, not a limitation, or am I wrong?

We don't talk about any third party DSP plug-in, it's the dsp_sps plug-in, which is bundled with Winamp 5.x.

Nevertheless, I will install 5.24 and check if I can reproduce the 24Bit problem, then I can say, if this is related to 5.25 beta.
Yes, the 24bit mode of dsp_sps was broken. I just fixed it *yay*
Benski is offline  
Old 15th August 2006, 00:02   #334
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
w00t :-)

[edit] confirmed dsp_sps now works with 24bit [/edit]
DJ Egg is offline  
Old 15th August 2006, 00:03   #335
Juanus
Major Dude
 
Juanus's Avatar
 
Join Date: Oct 2004
Location: Santa Monica, CA
Posts: 740
Send a message via AIM to Juanus
Any luck with the Preferences Lock Up problem that I reported? did the crash logs help?
Juanus is offline  
Old 15th August 2006, 00:12   #336
Benski
Ben Allison
Former Winamp Developer
 
Benski's Avatar
 
Join Date: Jan 2005
Location: Brooklyn, NY
Posts: 1,057
Quote:
Originally posted by Juanus
Any luck with the Preferences Lock Up problem that I reported? did the crash logs help?
Unfortunately, I havn't been able to reproduce it yet. Does it happen with earlier betas (787 and 801 are still available from the download site), or with 5.24? If it's ok with 801, it might be because of the Windows XP theming bug in 812.
The crashlog shows that it locked up somewhere inside of Windows and seemed to indicate it was a system problem - however, it's impossible to tell.
Benski is offline  
Old 15th August 2006, 00:15   #337
Juanus
Major Dude
 
Juanus's Avatar
 
Join Date: Oct 2004
Location: Santa Monica, CA
Posts: 740
Send a message via AIM to Juanus
Benski, No, this did not happen with previous betas or previous versions of any type. I am able to use 5.24 still (it is what I am using for now) and I did try 787 and 801 and everything worked fine. Is there anything that I could tell you that might help?
Juanus is offline  
Old 15th August 2006, 00:25   #338
Benski
Ben Allison
Former Winamp Developer
 
Benski's Avatar
 
Join Date: Jan 2005
Location: Brooklyn, NY
Posts: 1,057
Quote:
Originally posted by Juanus
Benski, No, this did not happen with previous betas or previous versions of any type. I am able to use 5.24 still (it is what I am using for now) and I did try 787 and 801 and everything worked fine. Is there anything that I could tell you that might help?
private message sent...
Benski is offline  
Old 15th August 2006, 02:01   #339
amano
Major Dude
 
amano's Avatar
 
Join Date: Apr 2003
Location: where the llamas come from!
Posts: 952
Since I just glanced at that HA thread: http://www.hydrogenaudio.org/forums/...opic=40134&hl=

Maybe something like that should be added to the 24bit warning:
"* increasing the bitrate will most certainly not be audibly perceptible for plain music listening"

eeeee eeeeeee eeeee eeeee eeeee
8 8 8 8 8 8 8 8 8 8 88
8eee8 8e 8 8 8eee8 8e 8 8 8
88 8 88 8 8 88 8 88 8 8 8
88 8 88 8 8 88 8 88 8 8eee8
amano is offline  
Old 15th August 2006, 07:03   #340
wa21guy
Member
 
Join Date: Nov 2000
Location: Seattle, WA USA area
Posts: 87
Send a message via AIM to wa21guy Send a message via Yahoo to wa21guy
Crash in Winamp

Just got a crash...

Winamp client version: 5.25 build 801 Beta Winamp caused an Integer Divide by Zero (0xc0000094) in module xvidcore.dll at 001b:057d54a2.

Exception handler called in Winamp.
Attached Files
File Type: zip report.zip (34.9 KB, 488 views)
wa21guy is offline  
Old 15th August 2006, 09:59   #341
osmosis
Major Dude
 
osmosis's Avatar
 
Join Date: Jan 2006
Location: Cananada
Posts: 841
try 812

Request: A little SmartView Query Language love.
osmosis is offline  
Old 15th August 2006, 10:04   #342
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
You're still using build 801? Does it happen with build 812?
You're using XviD's poor DirectShow Filter to play XviD content instead of ffdshow?
What is the filesize of the video you're playing? Greater than 2GB?
DJ Egg is offline  
Old 15th August 2006, 13:37   #343
BenJammin
Junior Member
 
Join Date: Aug 2006
Posts: 2
All right, WinAmp just totally crashed and made my entire computer go crazy. Here's my problem -

By the way, I was trying to use the Media Library/in2tv feature:

Winamp client version: 5.25 build 812 Beta
Winamp caused an Access Violation (0xc0000005)
in module Winamp.exe at 001b:39444334.

I'll attach the report.zip


Thanks!
Attached Files
File Type: zip winampcrashreport.zip (60.8 KB, 474 views)
BenJammin is offline  
Old 15th August 2006, 14:38   #344
kr4zy
Junior Member
 
Join Date: Jun 2003
Posts: 30
Winamp 5.25 build 812 beta crashed when enqueuing 700+ songs...

I enqueued, then they disappeared, as in weren't enqueued anymore, queued them again, back and forth like three times, then winamp.exe crashed:

Winamp client version: 5.25 build 812 Beta
winamp caused an Access Violation (0xc0000005)
in module gen_jumpex.dll at 001b:05b12bd2.

Exception handler called in Winamp.
kr4zy is offline  
Old 15th August 2006, 14:41   #345
kr4zy
Junior Member
 
Join Date: Jun 2003
Posts: 30
Winamp client version: 5.25 build 812 Beta
winamp caused an Access Violation (0xc0000005)
in module gen_jumpex.dll at 001b:05b22bd2.

Exception handler called in Winamp.

Crashed again, just attached crash report now
Attached Files
File Type: zip report.zip (64.1 KB, 536 views)
kr4zy is offline  
Old 15th August 2006, 16:11   #346
net-cruizer
Senior Member
 
net-cruizer's Avatar
 
Join Date: Jul 2001
Location: BC, CANADA
Posts: 367
Quote:
Originally posted by kr4zy
Winamp 5.25 build 812 beta crashed when enqueuing 700+ songs...

I enqueued, then they disappeared, as in weren't enqueued anymore, queued them again, back and forth like three times, then winamp.exe crashed:

Winamp client version: 5.25 build 812 Beta
winamp caused an Access Violation (0xc0000005)
in module gen_jumpex.dll at 001b:05b12bd2.

Exception handler called in Winamp.
I just tried, enqued over 2000 songs from Media Libray, no probs, then selected all mp3s from the folder itself and enqued in Winamp, no probs.
Just thought I'd try to see if there was in deed a bug when enqueing lots of mp3s.
net-cruizer is offline  
Old 15th August 2006, 16:53   #347
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
@kr4zy

Your report is invalid

Could be any of these 3rd-party plugins to blame:

Module 25
C:\Program Files\Winamp v5.2\Plugins\dsp_dfx.dll

Module 46
C:\Program Files\Winamp v5.2\Plugins\ml_atfext.dll

Module 56
C:\Program Files\Winamp v5.2\Plugins\gen_mp3cue.dll

Module 57
C:\Program Files\Winamp v5.2\Plugins\gen_msn.dll

Module 60
C:\Program Files\Winamp v5.2\Plugins\gen_tips.dll

_______________________________________________________


@ all audigy 2 zs users

Just found a better 'fix' for the cmss2/24bit problem
(where effects alternate on/off on seek etc)

Disable 'fade on seek' in out_ds config > fading :-)
DJ Egg is offline  
Old 15th August 2006, 17:33   #348
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
Build 825 posted

Winamp 5.25 Beta Full
Winamp 5.25 Beta Pro (asks for key during install)
Winamp 5.25 Beta Standard (same as Full but no ML or viz)
Winamp 5.25 Beta Lite

changelog between build 812 and build 825

Fixed: playlist extension registry writing
Fixed: remote playlists nested within a playlist
Fixed: dialog fixes (font change had knocked some things out of whack)
Fixed: xp themed dialogs
Fixed: rogue winamp agent registry Run key
Fixed: [dsp_sps] 24 bit fix
Fixed: [in_dshow] seek to key frame
Fixed: [in_mp3] do Viz after DSP
Fixed: [in_mp3] made genre dropdown bigger again (only effects pre-XP os's)
Fixed: [gen_jumpex] Crash when clicking 'switch to vis/video' button
Fixed: [gen_ml] tree icon fixup (working around an OS bug that was causing CreateDIBSection to sometimes crash (divide-by-zero in ICM32) using V4 bitmap header struct)
Fixed: [ml_local] fix for setting the watch folders extension list
Fixed: [ml_local] fixed crash when trying to create a new view before mldb has loaded
Improved: expanded 24bit warning
Updated: [gen_jumpex] jtfe 0.97.7h (build 57)


Update

Newer in_mp3.dll

(see posts below for details)
DJ Egg is offline  
Old 15th August 2006, 19:00   #349
YtseJam
Forum King
 
YtseJam's Avatar
 
Join Date: Dec 2000
Location: Israel
Posts: 2,398
Send a message via ICQ to YtseJam Send a message via AIM to YtseJam
Seriously, guys, why is it sooooo diffecult to add this [goddamn] button?

Why Oh Why?

Bugs can be fixed within "minutes", but a button can't be added? And mind you, it's a button many want!

YtseJam is offline  
Old 15th August 2006, 19:40   #350
ap1978
Junior Member
 
Join Date: Jan 2001
Location: Bodø. Norway
Posts: 19
Send a message via ICQ to ap1978
Typo in the window that pops up when clicking on (more info) under Winamp Setup - Internet Connection and Language Settings

neccessary = necessary
ap1978 is offline  
Old 15th August 2006, 21:49   #351
osmosis
Major Dude
 
osmosis's Avatar
 
Join Date: Jan 2006
Location: Cananada
Posts: 841
something i just noticed: you can open the preferences with winamp minimized to the systray, and once they're open you can go to General and uncheck Systray icon, but the setting doesn't actually do anything unless the main window is open.

Request: A little SmartView Query Language love.
osmosis is offline  
Old 15th August 2006, 21:56   #352
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
Hmm... that could be by design.
What if you've got Winamp set to show in the systray only?
If the icon were to disappear then you've got no way of restoring Winamp
(other than killing the process in Task Mgr and editing winamp.ini).
DJ Egg is offline  
Old 15th August 2006, 21:58   #353
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,341
Quote:
Yes, the 24bit mode of dsp_sps was broken. I just fixed it *yay*
Thanks Benski. Cheers Egg.
Koopa is offline  
Old 15th August 2006, 22:36   #354
soljarag
Member
 
Join Date: May 2003
Posts: 92
Windows XP SP2
512 RAM
Winamp 2.5 Build 825, 812

whenever I play almost any of my songs I hear some REALLY bad clicks or just wierd noises .... i can hear it alot when I have my headphones on


Its not really easy to hear it out of the speakers.... but if you listen closly you can hear it

when I installed 2.24 back, there are no wierd clicks or noises...


first I thought my collection got corrupted, but was relieved when I installed 2.24 back
soljarag is offline  
Old 15th August 2006, 22:42   #355
Benski
Ben Allison
Former Winamp Developer
 
Benski's Avatar
 
Join Date: Jan 2005
Location: Brooklyn, NY
Posts: 1,057
Quote:
Originally posted by soljarag
Windows XP SP2
512 RAM
Winamp 2.5 Build 825, 812

whenever I play almost any of my songs I hear some REALLY bad clicks or just wierd noises .... i can hear it alot when I have my headphones on

Its not really easy to hear it out of the speakers.... but if you listen closly you can hear it

when I installed 2.24 back, there are no wierd clicks or noises...

first I thought my collection got corrupted, but was relieved when I installed 2.24 back
What kind of files? MP3? Can you upload one somewhere for us to test with?
Benski is offline  
Old 15th August 2006, 22:48   #356
amano
Major Dude
 
amano's Avatar
 
Join Date: Apr 2003
Location: where the llamas come from!
Posts: 952
Damn. You are right. I can reproduce that. There are clicks within my mp3 files if I listen carefully. At least with some mp3 tracks that I listen to just now.

I will investigate a bit further.

24 bit is off. Turning on/off dither doesn't change anything.
soundblaster live! 5.1 with the kx drivers installed.

EDIT: Doesn't seem to happen with all files. I will attach some seconds of a song that exposes it.

eeeee eeeeeee eeeee eeeee eeeee
8 8 8 8 8 8 8 8 8 8 88
8eee8 8e 8 8 8eee8 8e 8 8 8
88 8 88 8 8 88 8 88 8 8 8
88 8 88 8 8 88 8 88 8 8eee8
amano is offline  
Old 15th August 2006, 22:56   #357
soljarag
Member
 
Join Date: May 2003
Posts: 92
Quote:
Originally posted by Benski
What kind of files? MP3? Can you upload one somewhere for us to test with?
can I pm you a link, i dont want to post it to the board
soljarag is offline  
Old 15th August 2006, 22:57   #358
Benski
Ben Allison
Former Winamp Developer
 
Benski's Avatar
 
Join Date: Jan 2005
Location: Brooklyn, NY
Posts: 1,057
Quote:
Originally posted by soljarag
can I pm you a link, i dont want to post it to the board
of course
Benski is offline  
Old 15th August 2006, 23:14   #359
amano
Major Dude
 
amano's Avatar
 
Join Date: Apr 2003
Location: where the llamas come from!
Posts: 952
Hear the click halfway the sample. Only with winamp, not with mpc eg.

And please delete the attachment when you have downloaded this.

eeeee eeeeeee eeeee eeeee eeeee
8 8 8 8 8 8 8 8 8 8 88
8eee8 8e 8 8 8eee8 8e 8 8 8
88 8 88 8 8 88 8 88 8 8 8
88 8 88 8 8 88 8 88 8 8eee8
amano is offline  
Old 15th August 2006, 23:19   #360
soljarag
Member
 
Join Date: May 2003
Posts: 92
haha, the song i sent him was 10 times worse than that

and yeah, i agree its not every song.... more like 15% of my songs
soljarag is offline  
Closed Thread
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump