Old 8th September 2011, 02:43   #1
aerecords
Junior Member
 
Join Date: Sep 2011
Posts: 3
Why is my stream requiring visitors login?

Hello all i've put a copy of the latest download of the shoutcast server on my ubuntu 10.04 vps. I easily got it running and Sam Broadcaster connects and transmits perfectley.

The thing is anyone trys to listen to my stream it requests a user name and password for what it says is realm (null). I have spent hours looking for the solution and not found anything.

Does any Body know how i can fix this issue.

There is a matter of urgency so any help is greatley apreciated.
aerecords is offline   Reply With Quote
Old 8th September 2011, 03:43   #2
jaromanda
Forum King
 
Join Date: Jun 2007
Location: Under the bridge
Posts: 2,289
what URL are the listeners trying to listen on?

"If you don't like DNAS, write your own damn system"

So I did
jaromanda is offline   Reply With Quote
Old 8th September 2011, 10:15   #3
aerecords
Junior Member
 
Join Date: Sep 2011
Posts: 3
http://87.239.22.176:8000/index.html ill leave sam boradcaster running auto dj from 3am uk time. I don't no what that would be in your timezone but your post states 04:43 this morning.
aerecords is offline   Reply With Quote
Old 8th September 2011, 10:31   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
Quote:
Originally Posted by aerecords View Post
The thing is anyone trys to listen to my stream it requests a user name and password for what it says is realm (null). I have spent hours looking for the solution and not found anything.
there's at least 3 threads about this issue. the usual cause is not having got / created an authhash for your stream(s) as you're using a v2 DNAS.

http://wiki.winamp.com/wiki/SHOUTcas...ash_Management will show you how to do that if not already.

if you have done that there are streamauthhash entries in your config file, then you'll need to look at the DNAS's log and see what error code is being returned when it tries to get itself listed.


the way things work is that if the DNAS is set to be public and cannot get a YP connection, it enters an invalid state and as a result will prevent client connections until the YP connection issue is resolved. since the DNAS will use information from the authhash you make for the information provided to clients, this is a valid reason to block client connections.

-daz
DrO is offline   Reply With Quote
Old 8th September 2011, 10:44   #5
aerecords
Junior Member
 
Join Date: Sep 2011
Posts: 3
Thank sorry for any time wasting i was lead to beleive that was only required for people wanting there streams on the shoutcast directory. Thank you for your support.
aerecords is offline   Reply With Quote
Old 8th September 2011, 10:57   #6
DrO
 
Join Date: Sep 2003
Posts: 27,873
no time wasted, is a valid question and something needing to be clarified.

the authhash registration is only required if you want to be publically broadcasting (will amend the wiki page to reflect that shortly).

if this is an internal stream, you either need to change the source to be 'private' of change the DNAS config itself to publicserver=never

[edit]
have now added http://wiki.winamp.com/wiki/SHOUTcas..._Key_needed.3F which i hope will make things a bit easier to follow for other people having similar questions about this.

-daz
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Tags
authentication, http, shoutcast

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump