Old 21st May 2001, 18:31   #1
cloudscapes
Junior Member
 
Join Date: May 2001
Posts: 4
Hi, so far I've never had any problems with Winamp, and I still think it's by-far the best media player available! There's this one problem though. Winamp plays audio CDs just fine except this one. "Slow Riot For A Zero Kanada" by Godspeed You Black Emporer. A great two-song 29-minute EP. Winamp gives me this error as soon as I right-click on Winamp and select "Play Audio CD"

WINAMP caused an invalid page fault in
module IN_CDDA.DLL at 0167:01613710.
Registers:
EAX=01631fc8 CS=0167 EIP=01613710 EFLGS=00210206
EBX=0161e348 SS=016f ESP=006ea02c EBP=bff77332
ECX=00000000 DS=016f ESI=01632047 FS=0fb7
EDX=00000000 ES=016f EDI=000002f9 GS=593e
Bytes at CS:EIP:
c6 06 00 8b 03 47 81 c6 80 00 00 00 3b f8 7c d0
Stack dump:
00000000 01619f48 00000000 00000044 00000004 97000d00 50000bb9 75746369 53206572 646e756f 63617274 0079006b 736f0065 69740065 65502065 7274656e

I'm not a very good programmer, but it seems it's having problems with the CDDA data.

The funny thing is it played the CD just fine on any version of Winamp before 2.73! I have 2.75 now. I am running Litestep as the OS shell but it still produces this error under the ordinary explorer shell. And as for Winamp itself, no fancy plugins or anying. Just the same skin I've had for a year.

Can anyone shed some light on this mystery? I'm running a 533 MHz Celeron with 128 megs RAM and 4 gigs free HD space, for what it's worth. I sure hope I can fix this problem, this is the first problem I've had with Winamp ever.

Doing great everyone, keep it up! :)

Regards,

Etienne Blythe
eblythe@mochamail.com
******************************
http://nearworlds.cjb.net
http://ampcast.com/droolingampfanclub
cloudscapes is offline   Reply With Quote
Old 21st May 2001, 19:58   #2
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Does the CD play ok in other players? (eg. Windows CD Player)
If all other AudioCD's play ok with Winamp, then maybe this one's a bit damaged?
Have you tried cleaning it?
Naturally, this CD plays in a normal hi-fi CD player, yes?
Though I could do with you confirming this, and also whether the trax are definitely in CDA format. This can be achieved via:
My Computer -> CD-ROM drive (with this CD in the drive) -> rt click -> Explore
DJ Egg is offline   Reply With Quote
Old 21st May 2001, 20:16   #3
cloudscapes
Junior Member
 
Join Date: May 2001
Posts: 4
Re..

I deleted the IN_CDDA.cdb file in the Winamp plugins directory and now the CD plays fine. Must be corrupted CDDA data.

Thanks for the help anyways!

Etienne Blythe
eblythe@mochamail.com
******************************
http://nearworlds.cjb.net
http://ampcast.com/droolingampfanclub
cloudscapes is offline   Reply With Quote
Old 21st May 2001, 20:34   #4
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Oh, okay! Weird!
I hope you didn't have too much other cddb info stored in there?
DJ Egg is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump