Old 15th October 2012, 20:37   #1
JotaSelector
Junior Member
 
Join Date: Jan 2012
Posts: 24
Help: Can get DSP to work but not sc_trans

I'm trying to get my sc_trans to run so that I can take advantage of the djlogin features but can't seem to get it working.

By 'not working' I mean that whenever I start up the sc_trans, it doesn't seem to connect to the server and if I try to listen to the stream, I get a "file not found" error. When I look at the sc_trans log the only errors are about the playlists:
E msg:[PLAYLISTMGR] Could not activate playlist `' because no playlist file found
I have the DSP Plug-in up and running so I imagine it's just something that I've configured incorrectly in the sc_trans.

Obviously, I'm nowhere near an expert but here are my best guesses as to what the problem is.

(1) Something with the playlist files? I'm doing strictly live capture with this stream so I haven't bothered creating one. I've tried pointing it to the empty default file (playlist.pls) as well as commenting out all/some of the playlist parameters but nothing seemed to work. Do I need any of the playlist stuff if I don't plan to use playlists?

(2) Something with my srcip= configuration? As I stated earlier, the stream works with the DSP plug-in and for that I used local host (127.0.0.1) but maybe the sc_trans needs to be told explicitly?

(3) Something with my 'capturedevice=, captureinput=' configurations? The sc_trans log makes me think it's set up correctly (see below) but maybe not.
I msg:[CAPTUREWIN32] Using device `Stereo Mix (SoundMAX Integrated'


Probably way off on all these guesses but I thought they'd help if I were on the right track.

I'd appreciate it greatly if someone with more expertise could give this a look to see where the problem is.

Below are my .conf and calendar file contents.
Also, attached are a log file each for the sc_serv and sc_trans.
NOTE: In the logs, server ip changed to '129.sss.sss.sss'
and all client ip's were changed to ###.ccc.ccc.ccc


System specs:
Windows 7 (32-bit)
====================================================================
My sc_serv.conf file
;DNAS configuration file

password=my_source_password
adminpassword=my_source_password
adminport=7999
flashpolicyfile=C:\Program Files\SHOUTcast\crossdomain.xml
requirestreamconfigs=1
logfile=C:\Program Files\SHOUTcast\sc_serv.log
w3clog=C:\Program Files\SHOUTcast\sc_w3c.log
publicserver=never
banfile=C:\Program Files\SHOUTcast\sc_serv.ban
ripfile=C:\Program Files\SHOUTcast\sc_serv.rip
maxuser=50

;;;; ENDPOINTS

;;;; ENDPOINT 1 - Hi quality
streamid_1=1
streampath_1=/test_hi
streammaxuser_1=50
streampassword_1=my_source_password
streamadminpassword_1=my_admin_pass


;;;; ENDPOINT 2 - Lo Quality
streamid_2=2
streampath_2=/test_lo
streammaxuser_2=50
streampassword_2=my_source_password
streamadminpassword_2=my_admin_pass

include=c:\Program Files\SHOUTcast\sc_serv_debug.conf
====================================================================
My sc_trans.conf file:
;Transcoder configuration file
;Made with the SHOUTcast 2 Configuration Builder

streamtitle=My Station Name
streamurl=http://MyWebsite.org
genre=misc
usemetadata=0
flashpolicyfile=C:\Program Files\SHOUTcast\crossdomain.xml
;inheritconfig=C:\Program Files\SHOUTcast\test_sc_serv.conf
unlockkeyname=Jota Selector
unlockkeycode=#####-######-#####-#####
logfile=C:\Program Files\SHOUTcast\sc_trans.log

;;;; STORED PLAYLIST FILES
playlistfilename_1=playlist

playlistfilepath_1=C:\Program Files\SHOUTcast\playlists\playlist.pls
;playlistfile=C:\Program Files\SHOUTcast\playlists\playlist.lst
;shuffle=0
;playlists=C:\Program Files\SHOUTcast\playlist\

;;;; RECORDED STREAM ARCHIVES
;archive=C:\Program Files\SHOUTcast\archived\

;;;; CALENDAR FILE
calendarfile=C:\Program Files\SHOUTcast\calendar\test_calendar.xml
calendarrewrite=0

;;;; REMOTE DJ LOGIN INFO
djport=8888
djcapture=1
djlogin_1=dj1
djpassword_1=dj_pass
djpriority_1=1

;;;; LIVE CAPTURE INFO
capture=1
capturedevice=Stereo Mix (SoundMAX Integrated
captureinput=Master Volume

;;;; Endpoints
;;;; ENDPOINT 1 - Hi Quality
encoder_1=mp3
mp3quality_1=1
bitrate_1=196000

;;;; ENDPOINT 2 - Lo Quality
encoder_2=mp3
bitrate_2=128000

include=C:/Program Files/SHOUTcast/sc_trans_debug.conf
====================================================================
My calendar file (.xml):

<?xml version="1.0" encoding="UTF-8" ?>
<eventlist>

<!-- if more DJ's are required in the system
then we just add in more event blocks -->

<event type="dj">
<dj archive="1">dj1</dj>
<!-- for this example we will allow the DJ
to connect to sc_trans at any time -->
<calendar />
</event>

</eventlist>
====================================================================
JotaSelector is offline   Reply With Quote
Old 15th October 2012, 20:41   #2
JotaSelector
Junior Member
 
Join Date: Jan 2012
Posts: 24
Attachments

Oops.
Attached Files
File Type: log test_sc_serv.log (100.5 KB, 95 views)
File Type: log test_sc_trans.log (10.8 KB, 119 views)
JotaSelector is offline   Reply With Quote
Old 16th October 2012, 17:46   #3
JotaSelector
Junior Member
 
Join Date: Jan 2012
Posts: 24
Just noticed this:
Quote:
Originally Posted by JotaSelector View Post
;inheritconfig=C:\Program Files\SHOUTcast\test_sc_serv.conf
I think that I turned it off after reading something here on the SC tech support boards about it may not always play nice. In other words, pretty sure I was having problems before I turned it off.

So with the inheritconfig off, I need to set the following (from the SC Trans_2 wiki) where the parameters correspond to sc_serv.conf -> sc_trans.conf.:

Quote:
portbase -> serverport
password -> password - Master source password overriden by streampassword
streampassword -> password
uvoxcipherkey -> djcipher
srcip -> serverip - Will use the ip set unless is empty or srcip=any
yp2 -> outprotocol - Sets outprotocol=1 if with yp2=0 otherwise it sets outprotocol=3 as a v2 DNAS is assumed to be used and if found to be v1 configuration then outprotocol=1
Passwords and streampasswords look okay and I don't need the 'yp2 -> outprotocol' or 'uvoxcipherkey -> djcipher' because the stream is not public. So that just leaves the 'srcip -> serverip.' If both are on the same machine, can I just set it to localhost for both? Or do I need to use the public IP address?

I'm actually away from the server/transcoder machine presently (I'll be working on it again Thursday) so just thinking aloud here and maybe someone out there has some feedback, too.

Thanks in advance to anyone giving this a look.
JotaSelector is offline   Reply With Quote
Old 16th October 2012, 17:48   #4
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: On the streets of Kings County, CA.
Posts: 3,030
Send a message via Skype™ to thinktink
127.0.0.1 or localhost
thinktink is offline   Reply With Quote
Old 16th October 2012, 17:52   #5
DrO
 
Join Date: Sep 2003
Posts: 27,873
as a note, if the main playlist is empty / unable to be loaded, in most cases it will then block DJ events from being able to connect. so even if you get things seemingly right, it can still fail due to that - am mentioning as i saw the playlist loading error at the start.

and yes the inherit config can cause some issues but it's usually when doing it to a remote DNAS rather than being on the same host.

-daz
DrO is offline   Reply With Quote
Old 16th October 2012, 18:09   #6
JotaSelector
Junior Member
 
Join Date: Jan 2012
Posts: 24
Thanks for the feedback guys!

I will set both the srcip= and serverip= to 127.0.0.1 and give it another shot and report back.

And thanks for the heads up on the empty playlist snag. I'll get the taken care of, too.

By the way, I'm wondering how the transcoder decides between a playlist file and the live capture. If I want to do live capture only (i.e. not use playlist files), will I need to set something in the sc_trans or calendar (e.g. set the unused playlist file in the calendar to priority="2") to do so, or will the transcoder default to the live capture?

Thanks again for your help.

Last edited by JotaSelector; 16th October 2012 at 18:12. Reason: clarity
JotaSelector is offline   Reply With Quote
Old 18th October 2012, 10:20   #7
DrO
 
Join Date: Sep 2003
Posts: 27,873
if capture is specified in the config then that will be used by default and then it's down to any events taking priority. obviously that is assuming that the capture mode even works for you.

-daz
DrO is offline   Reply With Quote
Old 18th October 2012, 20:41   #8
JotaSelector
Junior Member
 
Join Date: Jan 2012
Posts: 24
Okay. Still not working.

In sc_serv.conf, I added "srcip=127.0.0.1".
And in the sc_trans.conf, I added "serverip=127.0.0.1".

I added an mp3 file (silence.mp3) to the ...\playlists\plalylist.lst so it wasn't empty and could be read properly.

The good news is that no errors appeared in the logs. The bad news is that no errors appeared in the log... and it didn't work which brings me to daz's last post:

Quote:
"...obviously that is assuming that the capture mode even works for you."
-daz

Uh oh. So it sounds like there's a reasonable possibility that capture mode simply doesn't work on some machines. Am I inferring that correctly?

My sc_trans.log makes me think it is working (see bolded below) but maybe it's not and that's the whole problem?

I looked at the time stamp of the sc_trans.log and compared it to the sc_serv.log. The server started up normally but never even registered an attempted source connection from the localhost (or anything else for that matter).

When I use the winamp DSP plug-in as transcoder, everything connects just fine. Well, almost fine. My streamid_2 keeps connecting to the streamid_1 (maxusers=50; streammaxuser_1=50; streammaxuser_2=50, see above for full .conf) but I think that warrants a new thread.

Scratching my head here...

sc_trans.log:
Quote:
2012-10-18 10:58:48 I msg:[MAIN] Logger updating log file to use
2012-10-18 10:58:48 I msg:[MAIN] Loaded config from sc_trans.conf
2012-10-18 10:58:48 I msg:[MAIN] TimeMultiplier = 1, TimeShift = 0
2012-10-18 10:58:48 I msg:[CALENDARMGR] Adding DJ event: m_djName=dj1 m_archive=1 m_id=1 m_startDate=year:0,mon:0,mday:0,hour:0,min:0,sec:0,isdst:0,wday:0,yday:0 m_endDate=year:0,mon:0,mday:0,hour:0,min:0,sec:0,isdst:0,wday:0,yday:0 m_duration=0 m_timeOffset=year:0,mon:0,mday:0,hour:0,min:0,sec:0,isdst:0,wday:0,yday:0 m_hasStartDate=0 m_hasEndDate=0 m_hasDuration=0 m_hasTimeOffset=0 m_repeat=0
2012-10-18 10:58:48 I msg:[VUPUSH] 101 VU images loaded for left channel
2012-10-18 10:58:48 I msg:[VUPUSH] 101 VU images loaded for right channel
2012-10-18 10:58:48 D msg:[PLAYLISTMGR] Registering playlist playlist:C:\Program Files\SHOUTcast\playlists\playlist.lst : 0
2012-10-18 10:58:48 D msg:[PLAYLISTMGR] Playlist registry: namelaylist path:C:\Program Files\SHOUTcast\playlists\playlist.lst
2012-10-18 10:58:48 D msg:[PLAYLISTMGR] Activating playlist=playlist id=-1 loop=1 prior=0 shuffle=1 dur=0 curt=0
2012-10-18 10:58:48 I msg:[PLAYLISTMGR] Playlist load from file C:\Program Files\SHOUTcast\playlists\playlist.lst
2012-10-18 10:58:48 D msg:[PLAYLISTMGR] Root path is C:\Program Files\SHOUTcast\playlists\
2012-10-18 10:58:48 D msg:[PLAYLISTMGR] Win32 fully qualified path
2012-10-18 10:58:48 D msg:[PLAYLISTMGR] Expanding C:\Program Files\SHOUTcast\playlists\silence.mp3
2012-10-18 10:58:48 D msg:[PLAYLISTMGR] New entry C:\Program Files\SHOUTcast\playlists\Silence.mp3
2012-10-18 10:58:48 I msg:[PLAYLISTMGR] Caching playlist C:\Program Files\SHOUTcast\playlists\playlist.lst
2012-10-18 10:58:48 I msg:[PLAYLISTMGR] Load complete
2012-10-18 10:58:48 D msg:[PLAYLISTMGR] Playlist queue: namelaylist priority:0 loop:1 shuffle:1 id:-1 stop:0
2012-10-18 10:58:48 D msg:[DJMGR] DJ Information
2012-10-18 10:58:48 D msg:[DJMGR] dj - L:dj P:noise R:1 B:0 E:0 C:0
2012-10-18 10:58:48 D msg:[DJMGR] remote - L:dj1 P:dj_pass R:1 B:0 E:0 C:0
2012-10-18 10:58:48 I msg:[MAIN] Streaming thread starting
2012-10-18 10:58:48 I msg:[MAIN] Starting audio capture
2012-10-18 10:58:48 I msg:[CAPTUREWIN32] Building directShow graph objects
2012-10-18 10:58:48 I msg:[SOURCERELAY] Thread starting
2012-10-18 10:58:48 I msg:[CAPTUREWIN32] Locating capture device
2012-10-18 10:58:48 D msg:[CAPTUREWIN32] Begin audio devices
2012-10-18 10:58:48 D msg:[CAPTUREWIN32] device [Stereo Mix (SoundMAX Integrated]
2012-10-18 10:58:48 D msg:[CAPTUREWIN32] device [Aux (SoundMAX Integrated Digita]
2012-10-18 10:58:48 D msg:[CAPTUREWIN32] device [Line In (SoundMAX Integrated Di]
2012-10-18 10:58:48 D msg:[CAPTUREWIN32] End audio devices
2012-10-18 10:58:48 I msg:[CAPTUREWIN32] Using device `Stereo Mix (SoundMAX Integrated'
2012-10-18 10:58:48 D msg:[CAPTUREWIN32] Begin audio inputs
2012-10-18 10:58:48 D msg:[CAPTUREWIN32] input [Master Volume]
2012-10-18 10:58:48 D msg:[CAPTUREWIN32] End audio inputs

2012-10-18 10:58:48 I msg:[CAPTUREWIN32] Graph built.
2012-10-18 10:58:48 I msg:[CAPTUREWIN32] Graph running.
2012-10-18 10:58:48 I msg:[MAIN] Playlist decoder thread starting
2012-10-18 10:58:48 I msg:[CAPTUREWIN32] EVENT 13
2012-10-18 10:58:48 I msg:[CAPTUREWIN32] EVENT 14
2012-10-18 10:58:48 I msg:[MICROSERVER] Listening for connection on port 8889
2012-10-18 10:58:48 I msg:[RGCALC] Thread running
2012-10-18 10:58:48 I msg:[DECODE] Giving replay gain calculator a head start
2012-10-18 10:58:48 I msg:[DECODE] Begin decoding
2012-10-18 10:58:48 I msg:[BROADCASTSTALLMANAGER] Timed content set to TRUE
2012-10-18 10:58:48 I msg:[MAIN] Broadcast Receiver thread starting
2012-10-18 10:58:49 D msg:[CALENDARMGR] calendarMgr::timeSlice
2012-10-18 10:58:49 D msg:[CALENDARMGR] id=1 is not active. running activation check.
2012-10-18 10:58:49 D msg:[CALENDARMGR] id=1 start date range is ok
2012-10-18 10:58:49 D msg:[CALENDARMGR] id=1 end date range is ok
2012-10-18 10:58:49 D msg:[CALENDARMGR] id=1 is a non-repeating event
2012-10-18 10:58:49 D msg:[CALENDARMGR] id=1 start date is today
2012-10-18 10:58:49 D msg:[CALENDARMGR] id=1 has not yet run
2012-10-18 10:58:49 D msg:[CALENDARMGR] id=1 non-repeating event activating.
2012-10-18 10:58:49 D msg:[DJMGR] DJ `remote' enabled. Archive flag is true
2012-10-18 10:58:50 D msg:[CALENDARMGR] calendarMgr::timeSlice
2012-10-18 10:58:50 D msg:[CALENDARMGR] id=1 is active. running deactivation check
2012-10-18 10:58:51 D msg:[CALENDARMGR] calendarMgr::timeSlice
2012-10-18 10:58:51 D msg:[CALENDARMGR] id=1 is active. running deactivation check
2012-10-18 10:58:52 D msg:[CALENDARMGR] calendarMgr::timeSlice
2012-10-18 10:58:52 D msg:[CALENDARMGR] id=1 is active. running deactivation check
2012-10-18 10:58:53 D msg:[CALENDARMGR] calendarMgr::timeSlice
2012-10-18 10:58:53 D msg:[CALENDARMGR] id=1 is active. running deactivation check
2012-10-18 10:58:54 D msg:[CALENDARMGR] calendarMgr::timeSlice
(Repeat ad nauseum)

Last edited by JotaSelector; 18th October 2012 at 20:42. Reason: redundancy
JotaSelector is offline   Reply With Quote
Old 19th October 2012, 16:28   #9
DrO
 
Join Date: Sep 2003
Posts: 27,873
i would have to assume that the capture support is working ok - if it's gotten to that point in the log output then it's likely to be ok (if it doesn't like your setup then it usually bombs everything out).

as for the not attempting to stream to the DNAS, it's most likely one of 2 things, a bug in the altered config file you made after the attachment above or you're hitting an issue where sc_trans will just sit and spin and prevent the streams from being started (which also tends to come from it not liking specific configuration combinations).

-daz
DrO is offline   Reply With Quote
Old 19th October 2012, 16:35   #10
JotaSelector
Junior Member
 
Join Date: Jan 2012
Posts: 24
From above:
Quote:
2012-10-18 10:58:48 I msg:[MAIN] Broadcast Receiver thread starting
2012-10-18 10:58:49 D msg:[CALENDARMGR] calendarMgr::timeSlice
2012-10-18 10:58:49 D msg:[CALENDARMGR] id=1 is not active. running activation check.
2012-10-18 10:58:49 D msg:[CALENDARMGR] id=1 start date range is ok
2012-10-18 10:58:49 D msg:[CALENDARMGR] id=1 end date range is ok
2012-10-18 10:58:49 D msg:[CALENDARMGR] id=1 is a non-repeating event
2012-10-18 10:58:49 D msg:[CALENDARMGR] id=1 start date is today
2012-10-18 10:58:49 D msg:[CALENDARMGR] id=1 has not yet run
2012-10-18 10:58:49 D msg:[CALENDARMGR] id=1 non-repeating event activating.
2012-10-18 10:58:49 D msg:[DJMGR] DJ `remote' enabled. Archive flag is true
2012-10-18 10:58:50 D msg:[CALENDARMGR] calendarMgr::timeSlice
2012-10-18 10:58:50 D msg:[CALENDARMGR] id=1 is active. running deactivation check
So am I interpreting this log correctly? It appears to me that the sc_trans isn't sending the live capture source-- as evidenced by the lack of an attempted connection in the sc_serv.log-- and therefore sc_serv is just waiting on the DJ source? [NOTE: Not important but just fyi, the above dj 'remote' is consistent with the actual djlogin_1 in my sc_trans.conf file. In the initial post, I had listed it as 'dj1.']

Maybe I should try to run the sc_trans and then do a DJ login using the DSP plug-in to see if that would work?

Again, I'm away from the machine and won't be able to tinker with it until later next week. My apologies. (I'm a volunteer at a college radio station and only have time to work on this a couple of times per week and I thought this would take a couple of hours, tops. D'oh!)

Thanks again for everyone's volunteering their time to help me. I truly appreciate it.

Last edited by JotaSelector; 19th October 2012 at 16:38. Reason: typos
JotaSelector is offline   Reply With Quote
Old 19th October 2012, 16:41   #11
DrO
 
Join Date: Sep 2003
Posts: 27,873
the bit you're quoting is what i'd expect to see from the calendarmgr when you've got the debugging options enabled and that will keep going on and on as that's just how it works.

the problem is the streaming aspects aren't firing (as there's no reference to it) and that makes me think it is more a configuration issue or that you're just hitting a sc_trans bug (this is one of the reasons it is marked as beta).


when you have the time / means to provide the newer config file then that will make it easier to work out what is / isn't going on.

-daz
DrO is offline   Reply With Quote
Old 19th October 2012, 16:44   #12
JotaSelector
Junior Member
 
Join Date: Jan 2012
Posts: 24
Thanks for helping me troubleshoot, daz. You're the best.

Give me a sec and I'll post the latest .conf file. I copied it to my hard drive.
JotaSelector is offline   Reply With Quote
Old 19th October 2012, 16:54   #13
JotaSelector
Junior Member
 
Join Date: Jan 2012
Posts: 24
Quote:
;Transcoder configuration file
;Made with the SHOUTcast 2 Configuration Builder

streamtitle=My Station Name
streamurl=http://MyWebsite.org
genre=misc
usemetadata=0
flashpolicyfile=C:\Program Files\SHOUTcast\crossdomain.xml
;inheritconfig=C:\Program Files\SHOUTcast\test_sc_serv.conf
unlockkeyname=Jota Selector
unlockkeycode=#####-######-#####-#####
logfile=C:\Program Files\SHOUTcast\sc_trans.log

serverip=127.0.0.1

;;;; STORED PLAYLIST FILES
playlistfilename_1=playlist
playlistfilepath_1=C:\Program Files\SHOUTcast\playlists\playlist.pls
playlistfile=C:\Program Files\SHOUTcast\playlists\playlist.lst
shuffle=0

;playlists=C:\Program Files\SHOUTcast\playlist\

;;;; RECORDED STREAM ARCHIVES
;archive=C:\Program Files\SHOUTcast\archived\

;;;; CALENDAR FILE
calendarfile=C:\Program Files\SHOUTcast\calendar\test_calendar.xml
calendarrewrite=0

;;;; REMOTE DJ LOGIN INFO
djport=8888
djcapture=1
djlogin_1=remote
djpassword_1=remote_pass
djpriority_1=1

;;;; LIVE CAPTURE INFO
capture=1
capturedevice=Stereo Mix (SoundMAX Integrated
captureinput=Master Volume

;;;; Endpoints
;;;; ENDPOINT 1 - Hi Quality
encoder_1=mp3
mp3quality_1=1
bitrate_1=196000

;;;; ENDPOINT 2 - Lo Quality
encoder_2=mp3
bitrate_2=128000

include=C:/Program Files/SHOUTcast/sc_trans_debug.conf
Okay, here's the latest sc_trans.conf. Changes are in red.

I made one addition to the sc_serv.conf file (shown above):
srcip=127.0.0.1
JotaSelector is offline   Reply With Quote
Old 19th October 2012, 17:04   #14
DrO
 
Join Date: Sep 2003
Posts: 27,873
you need a streamid=1 as the stream encoding in that build needs a streamid specified to be able to associate the encoder settings with it. this is one of the things the inheritconfig option does for you (when you factor out the few things that it can break).

-daz
DrO is offline   Reply With Quote
Old 19th October 2012, 17:21   #15
JotaSelector
Junior Member
 
Join Date: Jan 2012
Posts: 24
Of course! Thanks, daz! That's probably it exactly. ::fingers crossed:: I bet it may resolve the streamid_2 (low quality) connecting to streamid_1 (high quality) issue, as well.

I'm excited to give it a shot next week and report back.

Not to butter your toast too much, daz, but having read through many of the archived threads, I really admire how generous you-- and many of the other regular posters like thinktink-- are with your time and expertise and how patient you are with your replies to novice users like myself. So, a hat tip to you all.
JotaSelector is offline   Reply With Quote
Old 20th November 2012, 19:03   #16
JotaSelector
Junior Member
 
Join Date: Jan 2012
Posts: 24
Been a while since I last posted in this thread but I'm happy to report that I finally got the sc_trans.exe to launch (without using the winamp DSP Plug-In) so I thought that I'd share the solution here for posterity's sake. I hope someone will find this info useful in the future while scouring the message boards for solutions.

I made the following changes to sc_trans.conf (from above):
Quote:
inheritconfig=C:\Program Files\SHOUTcast\test_sc_serv.conf
streamid_1=1
streamid_2=2
outprotocol_1=3
outprotocol_2=3
At first, I just added the 'streamids' and the 'outprotocols' but it didn't work. However, it did try to connect! Hooray, progress!

Using the timestamp from when the sc_trans tried to connect, I looked in the sc_serv.log for the attempted connection and I found an error in the 'sc_serv.log' that told me I was using a bad password even though it appeared (to me, at least) that the passwords all matched up so that's when I turned on the 'inheritconfig.' I tried it again and... success!

So really, maybe it was just a matter of turning the 'inheritconfig' back on since both 'outprotocol' and 'streamid' (and of course, passwords) are configured automatically with the 'inheritconfig' command. I must have had something else incorrect way back when I first attempted to run sc_trans.exe since I'm pretty confident I had it turned on originally and only turned it off while troubleshooting. :shrugs: It's working now...

These changes (and a server reset) also fixed the issue that I mentioned about 'streamid_2' opening as 'streamid_1.'

===========

With those problems fixed, now I'm working on getting the 'djlogin' to work correctly. Basically, I'm using the latest winamp DSP Plug-in and it says the stream is connected and info is being sent so everything appears to work on the dj end but the actual stream remains unaffected.

In other words, sc_serv.exe continues to stream the local host's stream and not the djlogin's for some reason. I should note that the DSP plugin would only let me login using legacy mode even though I'm using v2 in all phases so this issue may have something to do with v1 versus v2.

Any ideas on that, folks? Maybe this djlogin issue deserves another thread?

Thanks again for everyone's help. I'd be lost without you.

-jota
JotaSelector is offline   Reply With Quote
Old 20th November 2012, 19:29   #17
JotaSelector
Junior Member
 
Join Date: Jan 2012
Posts: 24
FYI - Here's the link to new thread regarding the separate djlogin issue:

http://forums.winamp.com/showthread....96#post2899296
JotaSelector is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Tags
file not found, live capture, sc_trans configuration

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump