Old 17th May 2012, 16:05   #1
endiny
Junior Member
 
Join Date: May 2012
Posts: 2
Can't start SHOUTcast server due to port error

Each time i try to start it. I get this
code:
2012-05-17 22:02:01 I msg:<***> Logger startup
2012-05-17 22:02:01 I msg:<***> version 2.0.0.29
2012-05-17 22:02:01 D msg:<***>
2012-05-17 22:02:01 I msg:***************************************************************
2012-05-17 22:02:01 I msg:** SHOUTcast Distributed Network Audio Server (DNAS)
2012-05-17 22:02:01 I msg:** Copyright (C) 1999-2011 Nullsoft, Inc. All Rights Reserved.
2012-05-17 22:02:01 I msg:** Use "sc_serv filename.conf" to specify a config file.
2012-05-17 22:02:01 I msg:***************************************************************
2012-05-17 22:02:01 I msg:[SHOUTcast] DNAS/posix(linux x86) v2.0.0.29 (Jul 31 2011) starting up...
2012-05-17 22:02:01 I msg:[MAIN] PID: 4932
2012-05-17 22:02:01 I msg:[MAIN] Loaded config from sc_serv.conf
2012-05-17 22:02:01 I msg:[MAIN] Calculated CPU count is 1
2012-05-17 22:02:01 I msg:[MAIN] Starting 1 network threads
2012-05-17 22:02:01 I msg:[MICROSERVER] Listening for connection on port 4594
2012-05-17 22:02:01 I msg:[MICROSERVER] Listening for connection on port 4594
2012-05-17 22:02:01 E msg:Error opening port 4594 because Could not bind to :4594 because Address already in use
2012-05-17 22:02:01 I msg:[MAIN] Runner shutdown
2012-05-17 22:02:01 I msg:<***> Logger shutdown



Here's my config

code:
MaxUser=16
Password=123
PortBase=4594
LogFile=sc_serv.log
ScreenLog=0
W3CEnable=Yes
W3CLog=sc_w3c.log
SrcIP=127.0.0.1
DestIP=ANY
Yport=80
NameLookups=0
AdminPassword=1488
AutoDumpUsers=1
AutoDumpSourceTime=60
TitleFormat=Verne (Test Broadcasting): %s
PublicServer=default
AllowRelay=No
AllowPublicRelay=No
MetaInterval=32768



What can I do to solve my problem?
endiny is offline   Reply With Quote
Old 17th May 2012, 16:23   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
make sure there is no other instances of sc_serv running using the same configuration and that there are no other programs running which might also be using port 4594.

-daz
DrO is offline   Reply With Quote
Old 17th May 2012, 16:27   #3
endiny
Junior Member
 
Join Date: May 2012
Posts: 2
Nothing uses port 4594. Anything else can be a problem?
endiny is offline   Reply With Quote
Old 17th May 2012, 16:51   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
only other thing would be to try it with the destip and srcip lines commented out. otherwise there shouldn't be a reason for it to fail with your config file is _definitely_ no other sc_serv instances are running.

-daz
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump