Old 11th December 2003, 11:40   #1
Noctraptor
Junior Member
 
Join Date: Sep 2003
Location: In darkness
Posts: 10
Send a message via Yahoo to Noctraptor
Media Library not sorting videos

Ok I noticed this problem in winamp2 and now in 5.0rc10
All my mp3's are added to the library just fine but when I add video they all end up in the audio section not the video section. Am I doing some thing wrong, or is this just some funkyness of the media library.
Noctraptor is offline   Reply With Quote
Old 11th December 2003, 14:12   #2
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,913
Using a 3rd-party video plugin?
Or just the default Nullsoft in_dshow.dll ?
What file extensions ae the videos? (mpg, avi, divx, wmv, ogm, etc)
Are these extensions listed in the DirectShow Decoder config? (Prefs -> Input)
Have you edited the Local Media -> Video view in the library?
Query: type = 1
DJ Egg is offline   Reply With Quote
Old 11th December 2003, 14:25   #3
Noctraptor
Junior Member
 
Join Date: Sep 2003
Location: In darkness
Posts: 10
Send a message via Yahoo to Noctraptor
3 party video plugins, not that I know of. I did install the vid4wa pluging on my winamp 2 but have not installed it on the 5.0.
All the videos are in .mpg format.
Yes Mpg is listed in the DirectShow decoder config.
And no I have not edited the local media video view. Every thing should be as it would be set after a new install save for a DSP plugin or two and a lyrics plugin.
And thanks for takeing the time to help, I am just stumped on this one.
Noctraptor is offline   Reply With Quote
Old 11th December 2003, 14:32   #4
Noctraptor
Junior Member
 
Join Date: Sep 2003
Location: In darkness
Posts: 10
Send a message via Yahoo to Noctraptor
I just checked the input list and the vid4wa plugin is listed there.
Noctraptor is offline   Reply With Quote
Old 11th December 2003, 14:43   #5
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,913
Close Winamp
Go to: the Winamp\Plugins dir
Remove or disable vid4wa plugin (eg. rename to in_vid4wa.dll.off)
Reopen Winamp and rescan your folders.
DJ Egg is offline   Reply With Quote
Old 11th December 2003, 15:11   #6
Noctraptor
Junior Member
 
Join Date: Sep 2003
Location: In darkness
Posts: 10
Send a message via Yahoo to Noctraptor
I renamed the Vid4wa plugin checked to make sure it was no longer listed and then rescaned my files, and still the videos are in the audio section. And nothing at all shows up on the video section.
Noctraptor is offline   Reply With Quote
Old 11th December 2003, 16:04   #7
Sawg
Guest
 
Posts: n/a
You are going to have to delete the contents of the \Winamp\plugins\ml\ folder and add everything again.
  Reply With Quote
Old 11th December 2003, 16:17   #8
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,913
Hmm, that's a bit drastic.

Instead, can't Noctraptor just go to:
Library -> Local Media
Right click an entry -> select all
Right click -> remove from library (del)
Then re-add folders?
DJ Egg is offline   Reply With Quote
Old 11th December 2003, 16:28   #9
Noctraptor
Junior Member
 
Join Date: Sep 2003
Location: In darkness
Posts: 10
Send a message via Yahoo to Noctraptor
I've done both in the past, trying to fix this problem and one I used to have with the ml opening the internet radio window. untill I found all I had to do was deleat the radio files and not the whole ml file. but this too did not solve the problem. I can play my movies in win amp with no problem, I can add them to the ml with no problem it's just that it lumps them all into the audio section and will not list them in the video section. This is not a problem that stops me from useing my winamp just some thing that has always bothered me. It would be nice to be able to use the ml for all my audio and video files sort them and such but this may be just wishfull thinking. has any one else had this problem that you know of?
Noctraptor is offline   Reply With Quote
Old 11th December 2003, 16:37   #10
Noctraptor
Junior Member
 
Join Date: Sep 2003
Location: In darkness
Posts: 10
Send a message via Yahoo to Noctraptor
Well I'll be. just as DJ Egg suggested I deleated all files useing the select all>deleat from ml option and them gave loading my videos a nother try, this time it worked. All videos are now listed in the video section and do not show up in the audio section. Thank you so much for all the help DJ Egg. I most humbly bow, in the deepest of respect to you. And again thank you.
Noctraptor is offline   Reply With Quote
Old 11th December 2003, 16:41   #11
Noctraptor
Junior Member
 
Join Date: Sep 2003
Location: In darkness
Posts: 10
Send a message via Yahoo to Noctraptor
Well make that all but one video, but I can live that that one being off. :-)
Noctraptor is offline   Reply With Quote
Old 11th December 2003, 16:46   #12
JonnyMac
Moderator
 
JonnyMac's Avatar
 
Join Date: Dec 2000
Posts: 14,385
1. In the media library, right click on Audio
2. Edit view...
3. Advanced editor tab > make sure type = 0 is in the Query box
4. OK button
5. right click on Video
6. Edit view...
7. Advanced editor tab > make sure type = 1 is in the Query box
8. OK button

Note: there should be a single space on either each of equal sign

Please do not PM me for tech support. Any request for tech support through PM will be ignored.
Read the Stickies
---> | | | | <--- Knowledge is power
JonnyMac is offline   Reply With Quote
Old 11th December 2003, 16:48   #13
Noctraptor
Junior Member
 
Join Date: Sep 2003
Location: In darkness
Posts: 10
Send a message via Yahoo to Noctraptor
Just checked and it is set up as you said.




Quote:
Originally posted by JonnyMac
1. In the media library, right click on Audio
2. Edit view...
3. Advanced editor tab > make sure type = 0 is in the Query box
4. OK button
5. right click on Video
6. Edit view...
7. Advanced editor tab > make sure type = 1 is in the Query box
8. OK button

Note: there should be a single space on either each of equal sign
Noctraptor is offline   Reply With Quote
Old 11th December 2003, 16:54   #14
JonnyMac
Moderator
 
JonnyMac's Avatar
 
Join Date: Dec 2000
Posts: 14,385
Whoops

Sorry, I was editing my reply when you posted your “this time it worked” reply to DJ Egg. My reply was too late. Glad it is working for you now.
JonnyMac is offline   Reply With Quote
Old 11th December 2003, 16:56   #15
Noctraptor
Junior Member
 
Join Date: Sep 2003
Location: In darkness
Posts: 10
Send a message via Yahoo to Noctraptor
Thanks.
Noctraptor is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump