Old 25th July 2008, 10:09   #1
Zaha
Junior Member
 
Join Date: Jul 2008
Posts: 3
Compiling issue with "!insertmacro MUI_PAGE_WELCOME"

I've been searching for the past two days and haven't found anything on this.

Basically, I duplicated the nsi file for installer I had already used which had worked. The only alterations I made to it were in registry values (which are solid) and filepaths for the actual files for the installer to install.

However, the compiler is consistently giving me errors on line 52, which is:
!insertmacro MUI_PAGE_WELCOME

I've attached the nsi file for anyone to go over, but I honestly can't see what's tripping the compiler up. It's a completely innocuous line, and it was fine with it in every other installer I've used it in.
Attached Files
File Type: nsi tyranids05ss.nsi (7.2 KB, 626 views)

Last edited by Zaha; 25th July 2008 at 10:34.
Zaha is offline   Reply With Quote
Old 25th July 2008, 10:28   #2
Afrow UK
Moderator
 
Afrow UK's Avatar
 
Join Date: Nov 2002
Location: Surrey, England
Posts: 8,434
Be nice if you told us what the errors were.

Stu
Afrow UK is offline   Reply With Quote
Old 25th July 2008, 10:33   #3
Zaha
Junior Member
 
Join Date: Jul 2008
Posts: 3
Unfortunately it just says "Error in script "C:\[...]\tyranids05ss.nsi" on line 52 -- aborting creation process".

Not very helpful to man or beast.
Zaha is offline   Reply With Quote
Old 25th July 2008, 10:37   #4
Afrow UK
Moderator
 
Afrow UK's Avatar
 
Join Date: Nov 2002
Location: Surrey, England
Posts: 8,434
The actual error will be further up, typically in the form of Usage: ....

Stu
Afrow UK is offline   Reply With Quote
Old 25th July 2008, 11:04   #5
Zaha
Junior Member
 
Join Date: Jul 2008
Posts: 3
Quote:
!insertmacro: MUI_PAGE_WELCOME
Error while loading icon from "D:\[...]\tyranids.ico": can't open file
Error in macro MUI_INTERFACE on macroline 64
Error in macro MUI_PAGE_INIT on macroline 2
Error in macro MUI_PAGE_WELCOME on macroline 5
Error in script "C:\[...]\tyranids05ss.nsi" on line 52 -- aborting creation process
Edit: Ahhh, that does it. The ico file was incorrectly named - PEBKAC error. Sorry to be a bother, it works now. ^_^
Zaha is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Developer Center > NSIS Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump