Old 7th December 2011, 10:05   #1
malinka
Junior Member
 
Join Date: Dec 2011
Posts: 2
Winamp crashes when plugin ml_sony.dll installed

Hello everybody!

I have a Windows 7 system, and also the Sony mp3-player nw-a1000.
Because i don't want to use the sony software (long story), i followed the Steps on a website.
So I tried to install the winamp plugin ml_sony.dll by drag and dropping it in my winamp/plugins folder. Is this maybe wrong? Because when i start winamp after that, winamp crashes and says that there is a problem.

Now I'm really desperate and really could use some help. I cannot use the sony software, it is terrible and doesn't work at all, and it crashes also at the slightest movement of the mouse, or so

Please tell me what i can do to fix it. Is maybe the latest version of winamp different, and the instructions on the page are too old? Is there a new plugin? I need to know.


Links mentioned above:
http://poptunes.org/how-to-use-the-s...nnect-software

For the plugin: http://sourceforge.net/projects/mlsony/



Thanks a lot, Malinka
malinka is offline   Reply With Quote
Old 7th December 2011, 10:14   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
ml_sony is a 3rd party plug-in so if it's not working with the current Winamp release then you're going to need to contact the plug-in author and see if they have a fix or can fix it for you.

most likely it doesn't like Windows 7 or is missing something it needs, though as the last update on the plug-in was over 3 years ago i'd start to assume the plug-in is no longer being developed and you're not going to have much luck in getting a solution.

-daz
DrO is offline   Reply With Quote
Old 7th December 2011, 10:37   #3
malinka
Junior Member
 
Join Date: Dec 2011
Posts: 2
Nooooo!
I really can't afford another mp3-player O.o
But thanks for the answer, I'll try to do so
malinka is offline   Reply With Quote
Old 4th January 2013, 12:13   #4
LiveFreeDead
Junior Member
 
Join Date: Jan 2013
Posts: 1
I know it's been a while, but someone else may be looking for a solution to this.

To allow the plugin to work with any version of Winamp simply set it to run as Administrator and it will work perfectly. This has been tested in Windows 7 and Windows 8 with winamp 5.3 and 5.6. I am using a sony walkman nw-s203f with the oma files and after jsymphonic failed to work in Windows 8 I had to get it working.

So your old Sony Walkman MP3 players can be useful again

Find winamp at C:\Program Files (x86)\Winamp\Winamp.exe and follow the link below for winamp.exe

http://mintywhite.com/vista/vsecurit...strator-howto/
LiveFreeDead is offline   Reply With Quote
Old 5th December 2016, 12:00   #5
BugletsPussycat
Junior Member
 
Join Date: Dec 2016
Posts: 1
FIX to use ml_sony.dll in WinAmp and NOT have it crash

Hi there everyone,

I recently acquired a Sony NW-A3000 Walkman MP3 player, which is a good little piece of kit, ONCE you get a player onto it that will work.

6 hours, much swearing and several coffees and pints later and my great IT guru of a friend managed to get WinAmp, with ml_sony.dll working and said mp3 player giving output of sound!! (and actually GREAT tonal quality).

Thing is he did all that on HIS laptop, but we knew *how* to do it.

I came home, installed WinAmp as it wasn't already on my new lappy... then got the ml_sony.dll into the plug-ins folder and... meh won't work.

Thankfully said IT guru was online and a bewailed 'HEEEEEEEEEEEEELP!' to him gave me a very simple fix that works.

OK, if you have the ml_sony.dll file in your plug ins folder for WinAmp you've got it right so far. Now...

1. Restart your computer
2. Right Click your WinAmp desktop (or toolbar icon) and 'Run as Administrator'
3. Plug in your mp3 player, it should show up on the right hand side.
4. If you have a media library sorted for WinAmp simply drag and drop the albums/songs you want on your mp3 player onto where it says USB Drive D:/ (well *mine* is D, it will have it under Device... will be pretty obvious which it is since it'll be there when plugged in, and disappear if you take the USB out!!).
5. Click on Device and you should have 'Apply' in the bottom right corner of your whole WinAmp window... click on that and it'll transfer the songs.

Hope this works for you, it did for me!
BugletsPussycat is offline   Reply With Quote
Old 26th July 2022, 13:33   #6
kastor
Junior Member
 
Join Date: Nov 2017
Posts: 1
Hi all,

Fastforward a few years, we are now on Windows 10 and it seems to not be working anymore.

I used the proess described by BugletsPussycat above and it doesn't discover it at all when I plug it in while Winamp running as administrator.

I went in the Options/Preferences/PlugsIns/Media Library to select the plugin and hit the button "Configure selected plugin" and it crashes.

Any ideas for a quick fix?
kastor is offline   Reply With Quote
Old 26th July 2022, 20:34   #7
musicf8
Major Dude
 
musicf8's Avatar
 
Join Date: Apr 2013
Posts: 837
Did you try this in 5.666?

I do know that in the past my 3rd party ipod plugin didn't work on newer winamp and i was stuck on v5.63 so might also give that a try.

All in all though it might be easier to find another piece of software for syncing given the lack of development of winamp and 3rd party. I have used a Portable musicbee to much success.

Current Setup: Windows 10 Pro, Sound Blaster Z, Logitech Z-5500, Winamp v5.666.3516

Get wacup
musicf8 is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump