Old 8th July 2019, 00:41   #1
Blarghmasta
Junior Member
 
Join Date: Jul 2019
Posts: 0
Troubleshooting Issues With Bugged, Saved Preset Mash-Ups

I'm running Milkdrop 2 in WinAMP 5.8.

After deleting all of the presets I did not like, I mashed them up and saved the mash-ups with specific names. I then "upgrade(d) the preset's pixel shader version" to 4 since it seemed to improve the quality of the visualization, and moved all of my saved presets to a new directory. All of the saved preset mash-ups were loading fine until I moved them to a new directory; after I moved them, loading them would result in Milkdrop's image freezing until I loaded an unmash-upped preset. I then moved the presets back--no change. Pressing escape while one of the bugged presets is loaded freezes Milkdrop entirely.

Can anyone help? I don't want to have to rebuild all of my mash-ups from scratch, and I don't want to encounter this issue again.
Blarghmasta is offline   Reply With Quote
Old 8th July 2019, 16:26   #2
Nitorami
Major Dude
 
Join Date: Mar 2008
Location: Erlangen
Posts: 854
Hi
There is absolutely no reason to change running presets to shader version 4. It does not improve quality, it merely allows presets to use 1024 machine instructions insetad of 512 (or 64 with model 1). Which means it allows you to write more code. For presets which actually run with model 3 (and that is 99.999%), shader model 4 has no benefit; what is worse, it will crash on some video cards.
I have no idea why your presets seem to run and then fail, but it is quite probably related to the model 4 bug. Suggest you use some simple batch processing tool to convert your presets back to 3. It's only lines 2,3, and 4 in the .milk files.
Nitorami is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Visualizations > MilkDrop > MilkDrop Troubleshooting Forum

Tags
mash-up, milkdrop 2, preset, winamp

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump