Old 15th April 2011, 00:05   #1
jaap424
Junior Member
 
Join Date: Apr 2011
Posts: 2
Forcing library rating field to sync with id3v2 field

I am currently using Winamp 5.61 and other then my slight problem everything seems to be in working order. I am using “writeratings=1” in “gen_ml.ini” to write my ratings in the Winamp database and directly into the id3 tag of my music files, again no real problem with this.

I have a rather large backlog of files that only have a rating in the Winamp database and a blank rating in their id3 tag rating field and short of re-rating all of these files by hand to force Winamp to also write the rating to the file itself i don't really know how to fix this.

Playing a song with a rating in Winamp and no rating in id3 doesn’t make it sync and neither does rescanning my watch folders, removing and adding the songs from my Winamp library or forcing Winamp to read the current metadata obviously does nothing more then also removing the rating in the Winamp library.

Also to be clear, songs rated after the inclusion "writeratings=1" in “gen_ml.ini” dutifully write a rating to the database and its respective tag, and files that are rated outside of Winamp do get their ratings put into Winamp after rescanning my watch folders

I am at a loss and i do not look forward to manually rerating hundreds of files, maybe somebody here knows a better way?
jaap424 is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Tags
gen_ml, id3, rating

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump