Old 26th February 2019, 12:10   #1
rendiok
Junior Member
 
Join Date: Feb 2019
Posts: 2
Configuring DNAS v2 protocol

Hello,

I have running a Shoutcast Server v2.6.0.750 for Linux.

On the source streaming side I have a SamCast and, for testing, a Winamp with the Shoutcast DSP plug-in v2.3.5 build 222.

Streaming with v1 protocol from Samcast and Winamp (not at the same time) to the Shoutcast Server works fine.

But changing protocol to v2, in both sources, I have the following behaviour when try to connect:

Shoutcast Server Log:
2019-02-26 12:55:41 INFO [SRC *******:58896] SHOUTcast 2 source connection starting.
2019-02-26 12:55:41 DEBUG [SRC *******::58896] state_SendCrypto
2019-02-26 12:55:41 DEBUG [SRC *******::58896] state_SendBuffer
2019-02-26 12:55:41 DEBUG [SRC *******::58896] state_ConfirmPasswordGet
2019-02-26 12:55:41 DEBUG [SRC *******::58896] state_ConfirmPassword
2019-02-26 12:55:41 DEBUG [SRC *******::58896 sid=1] Password accepted. Stream id is 1
2019-02-26 12:55:41 DEBUG [SRC *******::58896 sid=1] state_SendBuffer
2019-02-26 12:55:41 DEBUG [SRC *******::58896 sid=1] state_StreamConfigurationGet
2019-02-26 12:55:48 WARN [SRC *******::58896 sid=1] Timeout waiting for data
2019-02-26 12:55:48 DEBUG [SRC *******::58896 sid=1] ~protocol_uvox2Source
2019-02-26 12:55:48 INFO [SRC *******::58896 sid=1] SHOUTcast 2 source disconnected.

My sc_serv Shoutcast Server config file:

logfile=/var/log/shoutcast/sc_serv.log
w3clog=/var/log/shoutcast/sc_w3c.log
banfile=control/sc_serv.ban
ripfile=control/sc_serv.rip
publicserver=always
portbase=8080
sslcertificatefile = /etc/letsencrypt/live/*****/cert.pem
sslcertificatekeyfile = /etc/letsencrypt/live/*****/privkey.pem
alternateports=8443
password=*******
adminpassword=*******
streamauthhash=*****
licenceid=*******
userid=******
shoutcastsourcedebug=1
uvox2sourcedebug=1

And when Winamp DSP is trying to connect it, it shows:

Receiving Authorization Response

And the log of Winamp DSP:

2019-02-26 13:02:46 Logging starting
2019-02-26 13:02:47 Disconnecting
2019-02-26 13:02:48 Not Connected
2019-02-26 13:02:52 Connecting to... Server: *****; Port: ******; Mode: v2; Stream ID: 1; DJ / User ID: n/a
2019-02-26 13:02:52 Cipher Response Received
2019-02-26 13:02:52 Receiving Authorization Response

Can anyone help me?

Thanks!
rendiok is offline  
Old 4th March 2019, 09:26   #2
rendiok
Junior Member
 
Join Date: Feb 2019
Posts: 2
Hi,

My fault. Our firewall was blocking protocol v2 in Layer 7.

Regards,
rendiok is offline  
Old 4th March 2019, 11:57   #3
NJK
FRYSK BLOED TSJOCH OP- FRISIAN
 
NJK's Avatar
 
Join Date: Sep 2003
Location: a real Frisian hometown
Posts: 15,084
good to read you solved the issue

thread locked before the spam starts.

Each Thursday a new show on Celtica Radio with Darkwave music.
**************************************************************************

WINAMPSHOUTCAST
NJK is offline  
Closed Thread
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump