Old 9th December 2004, 03:18   #1
kuriti
Junior Member
 
Join Date: Dec 2004
Location: Charlotte, NC
Posts: 6
Wont auto play new file

Hello,

newbie here. i searched, Faqed etc. Been playin with Winamp and like it very much. all is well except when i double click a file in windows, it wont automatically open in winamp. i have associated all files with winamp, they even show the winamp icon. once a playlist is set up, there are no problems. however, if i download a new song for instance, and want to listen before saving, i have to right click and "open with" winamp. it works fine then.

while i am at it, i couldn't get my video files to play either. i am not sure which format it was, but i am more concerned with the above issue.

So far, i like this player alot better than the competition.

thanks all,

kuriti
kuriti is offline   Reply With Quote
Old 9th December 2004, 06:15   #2
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,107
So, you're downloading files with some p2p app,
and you want to preview them in winamp before the download is complete, yes?

If that's the case, then you will need to find out the file extension of these files.
It's possible that they're using the .temp or .part file extension.
Then, assuming that they're actually mp3 files, add the extension as follows:

Winamp > Prefs (Ctrl+P) > Plugins > MPEG Audio Decoder (in_mp3.dll) > Config

Add the relevant extension to the Extension List, eg.

MP3;MP2;MP1;AAC;APL;MPGA;PART;TEMP

You can then go to:
Prefs > File Types
and select said extension from the list to make Winamp the default player.


Note: This will only work if the files are actually mp3 (or another extension/format supported by in_mp3.dll).
ie. it won't work if the actual file format is .ogg or .m4a or .wav, etc...
Well, they'll still open with Winamp when double-clicked, but in_mp3.dll will probably puke on them :/
DJ Egg is online now   Reply With Quote
Old 9th December 2004, 11:11   #3
kuriti
Junior Member
 
Join Date: Dec 2004
Location: Charlotte, NC
Posts: 6
not that complex

Nope, i am patient enough to listen to them after they download. i am just saying any file (mp3,wav, etc.), even one that has previously been played through the playlist, wont open when double clicked from within My Music/my shared folder/etc in windows where they are stored on the hard drive. they play if i right click and "open with" winamp. Again, i selected all associations with Winamp. These are files that i previously double clicked when using realplayer and they opened fine. i know winamp is assiciated with them (.ra excluded) because the winamp icon is there.

Thanks for all your help. i really want this app to work because i have already downloaded the .ra input and .mp3 output. i burned all my cds in .ra (hindsight...) and didn't realize that my mp3 player wont read them. Doh! i still have about 4000 other songs, but i want my cd tracks as well.

thanks

kuriti
kuriti is offline   Reply With Quote
Old 9th December 2004, 12:25   #4
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,107
Ok then, we're going to need to know what your Windows OS is... but I'm going to assume it's Windows XP sp2, yes?

Have you disabled the DCOM Launcher Service?
If so, you need to re-enable it.
See here for instructions.

Apart from that . . . make sure MP3, WAV, RA, etc are all selected (hi-lighted) in:
Winamp 5.07 > Prefs (Ctrl+P) > File Types
and that "restore associations at winamp startup" is checkmarked.

Close & reopen Winamp.

If the problem persists, then it's probable that some other player has messed up the associations.

Do you see "Play in Winamp", "Enqueue in Winamp" and "Add to Winamp's Bookmark List" in the right click menu for mp3 (and other) files?
If yes, then which Action is in bold text? (ie. the default action)

Again, assuming you've got WinXP, go to:
Control Panel > Folder Options > File Types tab
Scroll down for and hi-lite: MP3
Click "Advanced"
Make sure "Play in Winamp" is the default action
(if it's there, hi-lite it and click "set default").
The command line (c/o Edit button) should be:

"C:\Program Files\Winamp\winamp.exe" "%1"

(assuming you installed Winamp to the default dir).

You will need to repeat this for WAV, RA, etc.
DJ Egg is online now   Reply With Quote
Old 10th December 2004, 00:57   #5
kuriti
Junior Member
 
Join Date: Dec 2004
Location: Charlotte, NC
Posts: 6
Dj Egg,

you da bomb diggidy. i have about every other player including creative so it was option "c". i had to reset the default. See ya later and thanks for the help.

ciao
kuriti
kuriti is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump