Old 25th May 2006, 17:38   #1
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,088
Winamp 5.22 Released

Winamp 5.22

Winamp 5.22 Full emusic plus
Winamp 5.22 Pro (asks for key during install)
Winamp 5.22 Lite

Whats new:
* New: loading of additional playlist formats: ASX/WAX/WMX/WVX, WPL, B4S
* New: [gen_ff] modern skin unicode support
* New: [in_wm] burning of DRM protected files (if allowed by content provider)
* New: [ml_pmp] transfer of playlists to portable devices
* Improved: More informative CD burning status window
* Improved: [gen_ff] modern skinning engine speed optimizations
* Improved: [in_wm] seeking improvements
* Improved: [in_wm] gapless WMA support
* Improved: [ml_nowplaying] Redesigned 'Now Playing' media library view (it actually works now)
* Improved: [pmp_ipod] Loading times for iPods reduced
* Fixed: Winamp won't restore after being minimized with a dialog box open
* Fixed: $abbr() title formatting lockup
* Fixed: Add Folder adds tracks BEFORE the last track
* Fixed: Clicking 'Next' in Fullscreen video OSD acts like clicking it twice
* Fixed: Rating in pledit right-click context menu always shows "No Rating"
* Fixed: CD burning bugs and crashes
* Fixed: CD Ripping not creating artist/album metadata under Win9x
* Fixed: Delete key not working in Online Services or SC Wire search
* Fixed: [out_wave] Stop with fadeout (Shift+V) just stops playback, no fadeout
* Fixed: [gen_jumpex] modern skin pledit docked toolbar mode not remembered
* Fixed: [gen_jumpex] ML size/position not remembered when switching from Classic to Modern and back to Classic skin
* Fixed: [gen_ml] playlists root view slowness bug
* Fixed: [gen_ml] Modern skin: Media Library > View (menu) > Devices
* Fixed: [in_midi] corrupt header crash
* Fixed: [in_mp4] metadata writing crash
* Fixed: [in_mp4] seek bug when using right arrow key
* Fixed: [in_mp3] MPEG-2 and MPEG-2.5 Layer 3 playback crash
* Fixed: [in_mp3] Winamp crashes when trying to play any wrongly named .aac file
* Fixed: [in_wave] WAV burning fix
* Fixed: [in_wave] Locking files (wav's can't be renamed/deleted)
* Fixed: [in_wm] lockup on wma with expired/unrenewable drm license
* Fixed: [in_wm] out of sync audio/video on some WMV streams
* Fixed: [in_vorbis] fullpath shown in playlist for tagless files with atf disabled
* Fixed: [ml_pmp] Duplicates being synchronized
* Fixed: [ml_pmp] Several crashes during transfers
* Fixed: [in_wm] out_ds hang/crash when removing active external soundcard
* Fixed: [out_ds] Can't select different Output Device with two active instances of out_ds
* Fixed: [out_ds] incorrect enumeration of stereo outputs for two of same pro soundcard
* Updated: [gen_jumpex] JTFE v0.97.1 [build 17] (Thanks DrO)
* Updated: [gen_tray] Tray Control 2.0: Enhanced icon pack support (Thanks DrO)


Updates

26th May

-A few Media Library Playlist related issues have been reported where ml playlists aren't being saved; 'import playlists from folder' is using the containing dir to name the playlists, instead of using the m3u filenames; Add > Add Folder adds all filetypes (not just all-supported); and Rt-click Enqueue is not working.

There's now a new & fixed ml_playlists.dll & playlist.w5s available separately.

More info here, here & here & here <-- Read this post for instructions!


-A newer version of ml_pmp.dll (Portable Device Support module) is now available separately, and should fix the reported 'syncing duplicates' issue (direct zip download).

More info here, here & here.


Undocumented

-gen_ml.dll is now just a Media Library plugin loader. All components can be removed separately. Now Playing (ml_nowplaying.dll), Bookmarks (ml_bookmarks.dll), History (ml_history.dll), Local Media (ml_local.dll), Playlists (ml_playlists.dll), Rip & Burn (ml_disc.dll), Online Services (ml_online.dll), Portables (ml_pmp.dll), SC Wire (ml_wire.dll). eg. If you remove all those dll's, then you'll just be left with an empty Media Library frame.

-JTFE search delay (on typing into search field): Default hard-coded value is 500ms. Depending on how fast/slow you type, you can adjust this value by adding: jtfe_search_delay=xxx to the [Jump To File Extra] section of winamp.ini (accepted values = anything from 1 to 3000 ms, eg. jtfe_search_delay=250 for a quarter second delay). This value will be editable via "Prefs > Jump To File" in a forthcoming build.
Full JTFE (Jump to File Extra - gen_jumpex.dll) changelog here.

-in_mp3 > config > Tags/Titles tab: Now has options to read/write id3v1/v2, unicode/latin/iso tags, etc :-)

-Native asx, wax, wpl, b4s playlist support: If you ever installed it, the installer should auto detect & delete the 3rd-party Playlist Loader plugin (gen_b4s2m3u.dll), because 1) it is no longer required and 2) there will certainly be a conflict if it is present.

-Sonic Engine: The file which links Winamp to the Sonic Rip/Burn Engine is now renamed from pxsdkpls.dll to primosdk.dll (Winamp root dir). Note, a reboot may be required on some systems when installing the updated Sonic Engine. It isn't essential that you reboot here, but burning will probably not work until you do so.

-Other new files: Winamp root dir: burnlib.dll (required for burning); nde.dll (Nullsoft Database Engine) - extracted from gen_ml.dll; nscrt.dll (Nullsoft C++ Runtime Engine) - a combination of msvcr71.dll & unicows.lib (required for winamp to run on all windows os'es, note: MSVCR71.DLL uses some NT-only functions, but NSCRT.DLL re-routes those through unicows under Win9x). Winamp\System dir: watcher.w5s = the Scanner for ML Watch Folders (also extracted from gen_ml.dll)

-Winamp\the Media Library is now compatible with Windows Vista.

-Online Services: New "Back | Forward | Home | Stop | Refresh" buttons, and other optimizations (shame the winamp.com server is sooo busy/slow at the moment though, heh). New "Games" channel, new In2TV channel (U.S. only) & MusicNow store (U.S. only).

-Now Playing / minibrowser: No longer uses winampmb.htm when 'not connected to internet' is selected in Prefs. This will hopefully be fixed/reimplemented at some point, maybe for 5.24. Also note that the More button > Links section is also gone (as was used/configured via winamp.lks). Hopefully there'll be a new 'Links' view implemented in Online Services, again maybe for 5.24. Also note that it's a known issue where it says "Upgrade to Winamp Pro" even for registered versions. Again, this issue will hopefully be addressed, and can probably be implemented serverside...

-The issue with in_wave.dll v3.0 where it doesn't support riff-wav's etc (embedded mp3 / and other codecs not supported by libsndfile) still exists (sorry, but there wasn't enough time to fix/address it, but it will be dealt with eventually). Workarounds are still listed here (including link to old in_wave.dll from 5.13 and/or instructions on how to manually setup in_dshow to handle wav playback instead).


Please do not post any issues in this thread which require Tech Support
(eg. unreproducable crashes, slow load times, strange error messages, etc).
Please post them in a new thread in the Tech Support forum,
and remember to include all relevant info.

Reproducable bugs should be posted in the Bug Reports forum, but be sure to read the stickys in there first and follow the guidelines/supply all the required info etc (ie. your report will be invalid otherwise).



______________________________________________
Old Winamp 5.21 Released thread
Old Winamp 5.2 Released thread
DJ Egg is offline   Reply With Quote
Old 25th May 2006, 19:21   #2
will
Nullsoft Newbie (Moderator)
 
will's Avatar
 
Join Date: Mar 2001
Location: Sheffield, England
Posts: 5,569
At last!

DO NOT PM ME WITH TECH SUPPORT QUESTIONS
will is offline   Reply With Quote
Old 25th May 2006, 19:52   #3
d3x7r0
Senior Member
 
d3x7r0's Avatar
 
Join Date: Jun 2004
Location: Lisbon, Portugal
Posts: 380
Send a message via Skype™ to d3x7r0
Excelent... *Mr Burns style*

NOTE: I am Dextro!
d3x7r0 is offline   Reply With Quote
Old 25th May 2006, 20:06   #4
fisher819
Senior Member
 
fisher819's Avatar
 
Join Date: Sep 2004
Location: Lebanon
Posts: 225
Send a message via Yahoo to fisher819
hurrayyyyyyyyyyyyy.....

very nice version.
10x

help us count :Click here
fisher819 is offline   Reply With Quote
Old 25th May 2006, 20:26   #5
Squadman
Senior Member
 
Squadman's Avatar
 
Join Date: Nov 2004
Location: UK
Posts: 284
Send a message via AIM to Squadman
Excellent.

Thanks Dev Team, i've been looking forward to this one for a while.
Squadman is offline   Reply With Quote
Old 25th May 2006, 20:48   #6
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,340
Nice update. I like the ability to uninstall CD-Ripping.

The modern skin color editor seem to be broken with the new build.
Koopa is offline   Reply With Quote
Old 25th May 2006, 21:45   #7
J_Darnley
Forum King
 
J_Darnley's Avatar
 
Join Date: Apr 2004
Location: Belgium, Europe
Posts: 3,625
Send a message via ICQ to J_Darnley
Can I ask why Winamp promted me to restart Windows? It has never needed to do that in the past.

Winamp ATF ReferenceMy cPro timer widgetMy port of AVS
Do NOT email me with general tech support questions.
J_Darnley is offline   Reply With Quote
Old 25th May 2006, 21:46   #8
siebe83
Forum King
 
siebe83's Avatar
 
Join Date: Feb 2004
Posts: 9,229
Re: Winamp 5.22 Released

@J_Darnley:
Quote:
Originally posted by DJ Egg
-Sonic Engine: The file which links Winamp to the Sonic Rip/Burn Engine is now renamed from pxsdkpls.dll to primosdk.dll (Winamp root dir). Note, a reboot may be required on some systems when installing the updated Sonic Engine. It isn't essential that you reboot here, but burning will probably not work until you do so.
Nice release!
I really like the idea of splitting up the ML.

If you're bored go here or, if the boredom is more serious, here.
siebe83 is offline   Reply With Quote
Old 25th May 2006, 21:49   #9
retchless
Member
 
Join Date: Oct 2003
Location: Canada
Posts: 97
Soooo happy
retchless is offline   Reply With Quote
Old 25th May 2006, 21:57   #10
Dimmuxx
Junior Member
 
Join Date: May 2006
Posts: 4
Play->File with Files of type: All supported types show all files *.* instead. Winamp 5.221 hotfix needed or is it only I that have this extremly annoying bug?
Dimmuxx is offline   Reply With Quote
Old 25th May 2006, 21:59   #11
J_Darnley
Forum King
 
J_Darnley's Avatar
 
Join Date: Apr 2004
Location: Belgium, Europe
Posts: 3,625
Send a message via ICQ to J_Darnley
Re: Re: Winamp 5.22 Released

Quote:
Originally posted by siebe83
@J_Darnley:
Quote:
Originally posted by DJ Egg
-Sonic Engine: The file which links Winamp to the Sonic Rip/Burn Engine is now renamed from pxsdkpls.dll to primosdk.dll (Winamp root dir). Note, a reboot may be required on some systems when installing the updated Sonic Engine. It isn't essential that you reboot here, but burning will probably not work until you do so.
Now, how did I miss that?

Winamp ATF ReferenceMy cPro timer widgetMy port of AVS
Do NOT email me with general tech support questions.
J_Darnley is offline   Reply With Quote
Old 25th May 2006, 22:18   #12
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,088
Quote:
Originally posted by Dimmuxx
Play->File with Files of type: All supported types show all files *.* instead. Winamp 5.221 hotfix needed or is it only I that have this extremly annoying bug?
Sorry, but I can't reproduce that here. Do you have any 3rd-party plugins installed (probably of the Input variety)?

Have you tried removing association for the some of the rarer filetypes from in_wave, in_midi, in_mod configs (Prefs > Plugins > Input)?

eg.

in_wave > config:
Deselect everything except for WAV (unless you need support for any of the others)

in_midi > config > File Types tab:
Deselect everything except for MID, RMI . . .

in_mod > config > Loaders tab
Hi-lite the available loaders in succession, and uncheck "enabled" for eg. Polytracker, Amiga Okt, DSMIAMF, Far Composer, 669, Ultratracker.

in_mp3 > config > Extension List
Remove APL, VLB, MP1

That should cut down the number of extensions listed under 'all supported types', and should also get rid of your problem in doing so (note, it's a Windows Open File Dialog limitation, not a Winamp bug).
DJ Egg is offline   Reply With Quote
Old 25th May 2006, 22:31   #13
STanger
Senior Member
 
STanger's Avatar
 
Join Date: Jul 2004
Location: Memphis TN
Posts: 399
Send a message via AIM to STanger Send a message via Yahoo to STanger
sonic bits

Has anyone ever found a burner drive compatibility list for the sonic engine? I still haven't. If anyone has pls let me know. Also have a sony dru-800a dvd burner. Now in builds past sonic has worked very poorly for me which has led me to believe that the sonic engine is not compatible in my case. but in dj egg's post about the filename change has me wondering if 5.22 has a new sonic engine version if it does it might work for me for a change, but then again it may not.

<edit>Well..my sony dru-800a is properly detected in the ML down to my firmware version so does that mean it disc burning should work now??</edit>

Thanks for a killer build,
STanger

Last edited by STanger; 26th May 2006 at 00:04.
STanger is offline   Reply With Quote
Old 25th May 2006, 22:53   #14
CPingN
Junior Member
 
Join Date: Jun 2005
Location: Fremont, CA
Posts: 10
BOOOO!!
5.22 killed my theme colorer, ColorEditor. AND my colors. and instead, I have 2 menu items off the right-click menu that are just boxes (like undisplayable characters).

Also, what good is the sonic engine? I've been disabling that for months now as it caused nothing but problems in the past. One can burn without it so... why have it???

--update--
Well, I removed ColorEditor (coloreditor.wac + its data and xml folders) and another plugin (jpgload.wac ..??). They were under Plugins\freeform\wacs\ - My guess is that type of plugin is no longer supported..?


Last edited by CPingN; 25th May 2006 at 23:17.
CPingN is offline   Reply With Quote
Old 25th May 2006, 22:53   #15
sekond
Junior Member
 
Join Date: May 2006
Posts: 13
ahhhhh simply beautiful
sekond is offline   Reply With Quote
Old 25th May 2006, 22:54   #16
Dimmuxx
Junior Member
 
Join Date: May 2006
Posts: 4
Quote:
Originally posted by DJ Egg
Sorry, but I can't reproduce that here. Do you have any 3rd-party plugins installed (probably of the Input variety)?

Have you tried removing association for the some of the rarer filetypes from in_wave, in_midi, in_mod configs (Prefs > Plugins > Input)?
Thanks! Removed some from in_wave and now it works as it should again.
Dimmuxx is offline   Reply With Quote
Old 25th May 2006, 23:21   #17
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,088
@Dimmuxx

cool


@CPingN & Koopatrooper

Oops. Hopefully the Color Editor issue will get fixed asap.

btw, it's not a good idea to delete jpgload.wac, 'cos that is a required file.

To temporarily disable Color Editor, just rename coloreditor.wac to eg. coloreditor.wac.off (nothing like having a good wac.off) ;-)
and keep all the other files (xml etc), so when the Color Editor issue is fixed you can just easily restore everything to how it was before.

Update: Benski's working on a new Color Editor as we speak
(apparently, he broke a lot of the wa3 API's with the unicode conversion).
DJ Egg is offline   Reply With Quote
Old 25th May 2006, 23:22   #18
DrO
 
Join Date: Sep 2003
Posts: 27,873
using the default modern skin and a load of additional colourthemes pulled from these forums, they are working correctly for me (install is based in c:\program files\winamp and not using the multi-user options).

the colour editor is broken and could even be related to the unicode changes in gen_ff/modern support which has been added in this build. it could even be that the colour editor needs to be recompiled, i just don't know for sure.

-daz
DrO is offline   Reply With Quote
Old 25th May 2006, 23:26   #19
CPingN
Junior Member
 
Join Date: Jun 2005
Location: Fremont, CA
Posts: 10
Yeah, based on the weird entry in the menu, I'd guess it's unicode related, too. Would it be so hard to include a/the coloreditor within winamp itself (or as an included plugin)? hmm
Anyway, I'm happy for now. I pulled the colors out put them in the main xml file. In a way, better, as I don't have to load that plugin. I'm just stuck with my choices, and would have to edit the hard way to change them.
Thanks for the quick replies!
CPingN is offline   Reply With Quote
Old 25th May 2006, 23:29   #20
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,088
CPingN: ^see edited post^
DJ Egg is offline   Reply With Quote
Old 25th May 2006, 23:29   #21
DrO
 
Join Date: Sep 2003
Posts: 27,873
it is very much looking like it's the unicode support since a number of internal apis for wacs (which generally aren't used now) were broken so you'll have to see what the devs can come up with.

i think due to the way that things work, it's easier for the colour editor to be a separate download since it's really not important for the majority of users (that's how i see it since it's really just a tool for skinners)

-daz
DrO is offline   Reply With Quote
Old 26th May 2006, 02:58   #22
amano
Major Dude
 
amano's Avatar
 
Join Date: Apr 2003
Location: where the llamas come from!
Posts: 952
It is great that you can now de-install all the unused ML stuff. Modularity is the greatest point of winamp. Thus: Well done.

Thanks go out to benski, tag, DrO and Co.

eeeee eeeeeee eeeee eeeee eeeee
8 8 8 8 8 8 8 8 8 8 88
8eee8 8e 8 8 8eee8 8e 8 8 8
88 8 88 8 8 88 8 88 8 8 8
88 8 88 8 8 88 8 88 8 8eee8
amano is offline   Reply With Quote
Old 26th May 2006, 03:11   #23
ctkatz8086
Senior Member
 
Join Date: Sep 2002
Location: louisville, ky home of the CARDINALS
Posts: 401
can someone repost the instructions to return the text of the minimized playlist editor for classic skins to their previous size and style?

ctkatz8086 is offline   Reply With Quote
Old 26th May 2006, 03:24   #24
drewbar
Sawg 2.0
Major Dude
 
Join Date: Mar 2004
Posts: 5,916
Preferences > Skins > Classic Skins > Classic Skin Options > "Use skinned font for main window title display"

Count with us!
Jan 1st, 12AM (PST, GMT -8) 2010 - 282,246
drewbar is offline   Reply With Quote
Old 26th May 2006, 04:59   #25
gordol
Member
 
Join Date: Oct 2004
Posts: 93
Re: Winamp 5.22 Released

Quote:
Originally posted by DJ Egg
Winamp 5.22

* Fixed: [ml_pmp] Duplicates being synchronized
Nope, still broke. Now using a Creative Zen Vision:M and looking for something to replace the Creative MediaSource sync.
gordol is offline   Reply With Quote
Old 26th May 2006, 05:20   #26
BoyNG
Member
 
BoyNG's Avatar
 
Join Date: Feb 2006
Location: Russian Federation
Posts: 60
Send a message via ICQ to BoyNG
fix it please:
in_wm - Configure select filetype & edit then.
In opened window for Protocol I see Extension & for Ext I see Protocol. When i switch-switch Extension Type then all right.
Check it!

& why Sonic try find winamp.msi on Winamp start?
What can i do?
BoyNG is offline   Reply With Quote
Old 26th May 2006, 05:29   #27
osmosis
Major Dude
 
osmosis's Avatar
 
Join Date: Jan 2006
Location: Cananada
Posts: 841
ml_playlists appears to be a bit buggy still .. i tried adding all my playlists and it did it (very fast, great work there, very impressive), but when i close and reopen winamp - to test the load time with massive number of playlists, since 5.21 was brutal this way - winamp crashes. the crash occurs after the main window is drawn (windowshade mode) but before the playlist editor is drawn using the default skin. also i noticed that Load Playlists from Folder.. displays a dialogue containing the string "__foo". this is only asthetics, obviously, but i thought i'd point it out while i was at it.

there were 322 playlists loaded.

Request: A little SmartView Query Language love.
osmosis is offline   Reply With Quote
Old 26th May 2006, 06:22   #28
jmbattle
Senior Member
 
Join Date: Apr 2004
Location: Hamamatsu, Japan
Posts: 166
Hello chaps!

Just installed 5.22 - I'm delighted to see the ML broken up into separate .dlls, thank you!

I have moved all of the ml_*.dll files into a separate folder, except ml_local.dll; as noted previously, the strength of WinAMP is it's modularity. However, I did note that there is an 'Online Media' tab remaining - is this intentional?

On a separate note, may I ask how Dr0 displays a Desktop listing in the ML, visible in the image below.



Finally, is it necessary to have two copies of 'nscrt.dll' in both WinAMP\ and WinAMP\ ?

Anyway, thanks again for the excellent work chaps - keep the updates coming - I'm looking forward seeing customisable columns in the Artist/Album views one of these days!

Cheers,
James
x

Last edited by jmbattle; 26th May 2006 at 06:39.
jmbattle is offline   Reply With Quote
Old 26th May 2006, 07:07   #29
Juanus
Major Dude
 
Juanus's Avatar
 
Join Date: Oct 2004
Location: Santa Monica, CA
Posts: 740
Send a message via AIM to Juanus
Quote:
Originally posted by osmosis
ml_playlists appears to be a bit buggy still .. i tried adding all my playlists and it did it (very fast, great work there, very impressive), but when i close and reopen winamp - to test the load time with massive number of playlists, since 5.21 was brutal this way - winamp crashes. the crash occurs after the main window is drawn (windowshade mode) but before the playlist editor is drawn using the default skin.
there were 322 playlists loaded.
I am having this same problem also.
402 playlists loaded and then when I close and open again, I crash also.
No Third Party plugins. Just base install.

[EDIT] If I delete the Playlist.xml file in the ML folder, then I can start it up again. But no playlists Please please please fix

[EDIT AGAIN] Maybe it has something to do with this post
http://forums.winamp.com/showthread....30#post1940730

Last edited by Juanus; 26th May 2006 at 09:25.
Juanus is offline   Reply With Quote
Old 26th May 2006, 07:13   #30
billyvnilly
Forum King, M.D.
 
billyvnilly's Avatar
 
Join Date: Mar 2004
Location: Detroit burbs
Posts: 3,379
Send a message via ICQ to billyvnilly Send a message via AIM to billyvnilly
@jmbattle, that is one of dro's plugins, and he will hopefully release it when its good and ready to be released. its called explorer playlist.

hopefully breaking the ml components up will make it easier for dro to integrate it easier...i dunno.
billyvnilly is offline   Reply With Quote
Old 26th May 2006, 09:24   #31
DrO
 
Join Date: Sep 2003
Posts: 27,873
jmbattle: i think the last time i'd worked on explorer playlist i'd gotten that part to work pretty well but it was other areas that were a bit messed up. the splitting up of the ml doesn't really affect things so my current internal dev version should work without any change

the duplicate nscrt.dll is to fix certain issues with apps like zonealarm (and a load of others that i can't remember but i'm sure Egg will/has posted) and without the second one in the plugins folder you get unable to load XXX.dll messages when opening the window menus in a modern skin

amano: you mean more modularity now

-daz
DrO is offline   Reply With Quote
Old 26th May 2006, 09:33   #32
will
Nullsoft Newbie (Moderator)
 
will's Avatar
 
Join Date: Mar 2001
Location: Sheffield, England
Posts: 5,569
Re: Re: Winamp 5.22 Released

Quote:
Originally posted by gordol
Winamp 5.22

* Fixed: [ml_pmp] Duplicates being synchronized

Nope, still broke. Now using a Creative Zen Vision:M and looking for something to replace the Creative MediaSource sync.
Using several screenshots from ml_pmp (or otherwise) could I have a list of all the songs on your zen, and a list of those which get synched twice please.

DO NOT PM ME WITH TECH SUPPORT QUESTIONS
will is offline   Reply With Quote
Old 26th May 2006, 09:44   #33
djsolidsnake86
Senior Member
 
Join Date: Apr 2004
Posts: 115
with this build when i close winamp i have a windows errore in a .dll file.. what can be?
djsolidsnake86 is offline   Reply With Quote
Old 26th May 2006, 09:54   #34
jmbattle
Senior Member
 
Join Date: Apr 2004
Location: Hamamatsu, Japan
Posts: 166
Dr0, thanks for the response. With any luck you will be able to fix those minor issues in the near future.

Cheers,
James
x
jmbattle is offline   Reply With Quote
Old 26th May 2006, 09:57   #35
djsolidsnake86
Senior Member
 
Join Date: Apr 2004
Posts: 115
the file of my error is: gen_expplorerpl.dll
when i close winamp i have always this error
please help me
djsolidsnake86 is offline   Reply With Quote
Old 26th May 2006, 10:01   #36
drewbar
Sawg 2.0
Major Dude
 
Join Date: Mar 2004
Posts: 5,916
Remove it, then. It's not one of the native plugins that comes with Winamp.

Count with us!
Jan 1st, 12AM (PST, GMT -8) 2010 - 282,246
drewbar is offline   Reply With Quote
Old 26th May 2006, 10:05   #37
DrO
 
Join Date: Sep 2003
Posts: 27,873
a fixed version of gen_explorerpl.dll will be released as soon as the issues are resolved/features for the next version of it are completed. i've not tested it with 5.22 since it's not installed in my main test setup so i'm not surprised that one has issues

-daz
DrO is offline   Reply With Quote
Old 26th May 2006, 10:07   #38
YtseJam
Forum King
 
YtseJam's Avatar
 
Join Date: Dec 2000
Location: Israel
Posts: 2,398
Send a message via ICQ to YtseJam Send a message via AIM to YtseJam
Great release people!

YtseJam is offline   Reply With Quote
Old 26th May 2006, 12:00   #39
colorspace
Member
 
colorspace's Avatar
 
Join Date: Jan 2006
Location: Netherlands
Posts: 69
I noticed this line when reading Winamp.com's Feature Comparison : "New in Pro! Rip to HE-AAC at >128k bitrate!".

Why would anyone want to use HE-AAC at ≥96k bitrate? LC-AAC would be a smarter choice.
colorspace is offline   Reply With Quote
Old 26th May 2006, 14:11   #40
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,088
@ Juanus & osmosis

I can't reproduce the problem with ml_playlists / playlists.xml, but I'm sure it will be looked into. Naturally, it will get dealt with a lot faster if you provide all the required info that makes a proper valid bug report, including Windows OS, confirmation of a clean install with no 3rd-party plugins, installation type (shared/separate user settings), hjt log, crash logs, etc.

Can either of you confirm whether there's any of the following characters in any of your Playlist Names (ie. the playlist title which is displayed in ml > playlists):

< > & " '

[Edit]

Yup, that's it!
The frst post has been updated accordingly, with link to new ml_playlists.dll


@ BoyNG

Well spotted. I'll copy that report over to the internal bugtracker
(re: in_wm config > filetype > edit > protocol/extension = reversed)

Re: "why Sonic try find winamp.msi on Winamp start? What can i do?"

Hmm, I'm not entirely sure about that. What's your Windows OS?
As stated in the first post, if installing Sonic Burning Engine you will be prompted to reboot, so maybe it's something to do with that? However, it doesn't happen here (I've not rebooted for over a week since I was first prompted to reboot, and everything works fine - though I haven't tried burning yet, but I don't use Winamp for burning anyway... well, to be more precise, I very rarely make Audio CDs any more, heh).

Quote:
Originally posted by osmosis
also i noticed that Import Playlists from Folder.. displays a dialogue containing the string "__foo". this is only asthetics, obviously, but i thought i'd point it out while i was at it.
Oops, well spotted also. It's supposed to be the checkbox for "Recurse subdirectories", heh (will be fixed for 5.23).
DJ Egg is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump