Old 17th September 2009, 09:37   #1
TechnoCentrist
Junior Member
 
Join Date: Sep 2009
Posts: 1
Buffering + crossfading + slow read = bug

If you turn on buffering in mpeg audio decoder (to cache whole mp3 file which will be played), and cross fade between track is also switched on, and you are in wireless network (54g) where mp3 files are stored on one storage, you have to wait for at least couple of seconds for file to be cached over wireless connection. In another words - Winamp is trying to cache next mp3 file for play very very late. It should be cached at least 20 seconds before end of current file which is playing.
This bug is also noticeable when playing files from CD/DVD, because cd/dvd drive stops spinning, and when Winamp requires next file, couple of seconds are needed to spin up drive, and few seconds more for caching, so it is also too late - cross fade broke and user have silence break for couple of seconds (which is longer if on wireless network).
Winamp should try to find out if files are not played from local disk, or to try to find out speed of reading, and to compensate time if buffering is used.
If you ask why in the first place we are using buffering, it is because we don't want to have constant traffic in wireless network.
TechnoCentrist is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump