Old 25th November 2006, 12:16   #1
renox
Junior Member
 
Join Date: Nov 2006
Posts: 4
Winamp loads last played song

Hello,

I'm not sure if this can be classified as a bug or wheter it's just ment to be like it is now.

I currently use Winamp 5.x and when I dubbleclick an MP3 file (lets say song A), Windows automatically loads Winamp.
Normally I get to see the last played song (song B) in Winamp for a few seconds and after a second (I think after it loaded song A into the memory) it starts playing that song (A).

I found out today that it when you click song A which is on your harddrive and before you had played song B that is on your CD Drive, it starts spinning the CD in the CD Drive for a few seconds. Your song (song A) won't start playing until Windows has started spinning the cd, which can take about 2 seconds.

My question is; if you want to play a song that is on your harddrive, why would you want to load extra information about a song that has been played before?

Is it possible to make Winamp start up fresh (without it knowing what the last song was?) that way this problem could be solved and Winamp would start up faster.

Rex
renox is offline   Reply With Quote
Old 25th November 2006, 18:24   #2
siebe83
Forum King
 
siebe83's Avatar
 
Join Date: Feb 2004
Posts: 9,229
Hi,
To make Winamp start up fresh, empty the playlist and close Winamp. Then go to the Winamp folder (by default C:\Program Files\Winamp) and right-click winamp.m3u, checkmark 'Read Only' and click OK.
That way Winamp won't be able to save the current playlist on exit, and the playlist should be empty each time you load Winamp.

If you selected 'Separate settings for each user' when you installed Winamp, winamp.m3u is stored here instead:
C:\Documents and Settings\<yourusername>\Application Data\Winamp

If you're bored go here or, if the boredom is more serious, here.
siebe83 is offline   Reply With Quote
Old 25th November 2006, 18:49   #3
renox
Junior Member
 
Join Date: Nov 2006
Posts: 4
Wow that is a (temporary?) solution to this problem. Thanks!

Is it a bug/glitch though? And can it be fixed so people dont have to do is manual solution in the future?
renox is offline   Reply With Quote
Old 29th November 2006, 13:58   #4
renox
Junior Member
 
Join Date: Nov 2006
Posts: 4
Even though the thread has been moved and even though a (temporary) solution has been given. I still think it's a bug and that if its fixed, people will get a faster loading Winamp.
renox is offline   Reply With Quote
Old 29th November 2006, 16:02   #5
siebe83
Forum King
 
siebe83's Avatar
 
Join Date: Feb 2004
Posts: 9,229
I can't reproduce this. When I open a file via explorer, Winamp opens and the file starts playing instantly, even when I played files from a CD last time I ran Winamp.

Are you running any 3rd-party plugins?
What are your settings under Prefs > Titles > Metadata Reading?

If you're bored go here or, if the boredom is more serious, here.
siebe83 is offline   Reply With Quote
Old 30th November 2006, 00:53   #6
renox
Junior Member
 
Join Date: Nov 2006
Posts: 4
Hello, I got the recommended setting. (Read metadata when files are played or viewed in the playlist editor.)

And like I said, normally when I play a file from my HDD and close winamp and then try to play an other file, I can see the last played song for about a sec. After the sec, it plays the song I originally clicked on.
Thinking about it: Maybe my laptop (which is about 6 months old), is slower then your pc and therefore it seems to you like it plays instantly while it actually (unnecesserely) loads metadata (?) first.

The problem is when the last played song is an MP3 from a CD. After closing Winamp and trying to play an MP3 from my harddrive it spins up my CD (asif its getting data) and after that it continues loading the song it was supposed to play (which is the one on my harddrive).

I havent got any 3rd party plugins. Its a clean install. NO settings have been manually changed after installing.

(It now loads instantly, now that I made winamp.m3u read-only, btw.)
renox is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump