Old 8th September 2022, 20:32   #1
nofaithvaeth
Junior Member
 
Join Date: Sep 2022
Posts: 1
winamp cannot find mp3 encoder

Hello, ive been trying to set up my winamp to broadcast music to others. However, Winamp refuses to do anything and tells me the following:

"Unable to find the MP3 encoder dll (lame_enc.dll).
Please make sure it is installed in the following location:

E:\Program Files (x86\Winamp\Shared"

Now, i have looked in this folder and it DOES indeed have the DLL file installed. So I am confused as to why it will not detect it. I have uninstalled and reinstalled several times and it did not fix the issue. I have no idea what to do. I cannot find any information on how to fix this. Please help, I am at an impasse.
nofaithvaeth is offline   Reply With Quote
Old 9th September 2022, 17:19   #2
stevehtowcester
Junior Member
 
Join Date: Sep 2022
Posts: 2
I have the same problem.
Just installed the 2019 C++ distributable.
Then installed Winamp v5.9.0. build 9999
Now I can't double click on my music files and have them auto play.
On Winamp load, I get an error message saying
"Unable to find the MP3 encloder dll (lame_enc.dll).
Please make sure it is in the correct location.
The Source DSP will now abort loading until resolved."
Please help, what do I need to do?
stevehtowcester is offline   Reply With Quote
Old 9th September 2022, 19:07   #3
NJK
FRISIAN
 
NJK's Avatar
 
Join Date: Sep 2003
Location: in a house
Posts: 16,407
Quote:
Originally Posted by nofaithvaeth View Post

Now, i have looked in this folder and it DOES indeed have the DLL file installed. So I am confused as to why it will not detect it. I have uninstalled and reinstalled several times and it did not fix the issue. I have no idea what to do. I cannot find any information on how to fix this. Please help, I am at an impasse.

the latest version of Winamp is no longer using the Lame.dll
but is using in.mp3.dll
which could point to an upgrade instead of doing a clean install of Winamp.
With a clean install you also delete the Winamp folder in your program files , if you still see the lame.dll , you upgraded.
NJK is offline   Reply With Quote
Old 9th September 2022, 20:28   #4
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,091
Shoutcast Source DSP still uses Shared\lame_enc.dll
but lame_enc.dll isn't included with Winamp 5.9 because the Lame mp3 encoder is now embedded in enc_lame.dll instead.

There's a separate Shoutcast Source DSP for Winamp 5.9 installer which includes lame_enc.dll (v3.100.1)
http://forums.winamp.com/showthread.php?t=458120#misc
http://wiki.shoutcast.com/wiki/Sourc...ng_the_Plug-in
DJ Egg is online now   Reply With Quote
Old 11th September 2022, 12:44   #5
stevehtowcester
Junior Member
 
Join Date: Sep 2022
Posts: 2
Fixed

Thanks guys.
I have installed Winamp v5.9.0 and now installed the Shoutcast DSP v2.4.1 and all works great.
Keep up the good work, love Winamp.
stevehtowcester is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Tags
encoder, technical issues

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump