Old 3rd October 2012, 20:12   #1
ThiefMaster
Junior Member
 
Join Date: Mar 2003
Posts: 21
Send a message via ICQ to ThiefMaster Send a message via AIM to ThiefMaster Send a message via Yahoo to ThiefMaster
Broken YP2 connection causes clients to be rejected

After getting an 400 error from YP2 my stream rejected all clients with "Stream not available.".

Restarting shoutcast did not help (even though it was already reconnected to the source relay), the same error occurred.

After setting publicserver=never and restarting shoutcast it immediately worked again.

Not sure if this behaviour is intended or a bug but I don't think a broken YP connection should affect any listeners.
ThiefMaster is offline   Reply With Quote
Old 3rd October 2012, 20:33   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
there was a YP outage earlier which has caused an issue with some v2 listings (which some of the changes are meant to help in the next release). it should all be working now, if not then i need to know more details so i can try to track it.

as for the blocking clients if the YP goes down, unfortunately the current build is not as forgiving as it should be and is something which was changed a while back in the builds partners get.

-daz
DrO is offline   Reply With Quote
Old 3rd October 2012, 20:35   #3
ThiefMaster
Junior Member
 
Join Date: Mar 2003
Posts: 21
Send a message via ICQ to ThiefMaster Send a message via AIM to ThiefMaster Send a message via Yahoo to ThiefMaster
How to get such a build?

Or will it be fixed in the next public release?
ThiefMaster is offline   Reply With Quote
Old 3rd October 2012, 21:15   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
in the next release. though that still doesn't cover off the issue you've mentioned if it is still on-going or have you got listed again now?

-daz
DrO is offline   Reply With Quote
Old 3rd October 2012, 21:17   #5
ThiefMaster
Junior Member
 
Join Date: Mar 2003
Posts: 21
Send a message via ICQ to ThiefMaster Send a message via AIM to ThiefMaster Send a message via Yahoo to ThiefMaster
I kept the server private since a good availability is more important for me than the YP listing
ThiefMaster is offline   Reply With Quote
Old 3rd October 2012, 22:35   #6
further
Junior Member
 
Join Date: Oct 2012
Posts: 4
Any time I hit the Create Authhash button it crashes my sc_serv w/ the 400 msg.

new user. help!
further is offline   Reply With Quote
Old 3rd October 2012, 22:43   #7
DrO
 
Join Date: Sep 2003
Posts: 27,873
what is the _exact_ error shown with the 400 error code as i need something specific to be able to look into the issue.

-daz
DrO is offline   Reply With Quote
Old 3rd October 2012, 22:50   #8
further
Junior Member
 
Join Date: Oct 2012
Posts: 4
Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\test>cd\radio\shoutcast

C:\radio\SHOUTcast>sc_Serv
2012-10-03 15:25:43 I msg:<***> Logger startup
2012-10-03 15:25:43 I msg:<***> version 2.0.0.29
2012-10-03 15:25:43 D msg:<***>
2012-10-03 15:25:43 I msg:********************************************
*******************

......


2012-10-03 15:39:16 I msg:[SRC 127.0.0.1:49953 sid=1] Got complete met
adata message type=3902 [357 bytes] id=6 span=1 content=
<?xml version="1.0" encoding="UTF-8" ?>
<metadata><TIT2>Vagon Brei- Quantum electrodynamics</TIT2>
<TENC>SHOUTcast Source DSP v2.2.3.112</TENC>
<TRSN>further</TRSN>
<WORS>http://www.shoutcast.com</WORS>
<extension>
<title seq="1">Vagon Brei- Quantum electrodynamics</title>
<title seq="2">01-listen</title>
<soon>01-listen</soon>
</extension>
</metadata>
2012-10-03 15:44:57 I msg:[YP2] Connecting to yp.shoutcast.com
2012-10-03 15:44:58 I msg:[ADMINCGI] Updating configuration file(s)
2012-10-03 15:44:58 I msg:[YP2] Connecting to yp.shoutcast.com
2012-10-03 15:44:59 E msg:[DST 205.188.202.174:60667 sid=1] SHOUTcast
1 client connection rejected. Stream not available. SHOUTcast Directory Tester
2012-10-03 15:44:59 I msg:[DST 205.188.202.174:60667 sid=1] SHOUTcast
1 client connection closed (0 seconds) [Bytes: 0] Agent: `SHOUTcast Directory Te
ster'
2012-10-03 15:44:59 E msg:[YP2] /yp/resp/updatefreq missing
2012-10-03 15:44:59 E msg:[YP2] Connection attempt failed. YP2 error c
ode is 400 (Generic error)
2012-10-03 15:45:10 I msg:[SRC 127.0.0.1:49953 sid=1] Got complete met
adata message type=3902 [371 bytes] id=7 span=1 content=
<?xml version="1.0" encoding="UTF-8" ?>
<metadata><TIT2>01-listen</TIT2>
<TENC>SHOUTcast Source DSP v2.2.3.112</TENC>
<TRSN>further</TRSN>
<WORS>http://www.shoutcast.com</WORS>
<extension>
<title seq="1">01-listen</title>
<title seq="2">Ricardo Donoso - Reflection &amp; Rotation</title>
<soon>Ricardo Donoso - Reflection &amp; Rotation</soon>
</extension>
</metadata>
2012-10-03 15:45:58 I msg:[YP2] Connecting to yp.shoutcast.com
2012-10-03 15:45:58 E msg:[DST 205.188.202.172:52114 sid=1] SHOUTcast
1 client connection rejected. Stream not available. SHOUTcast Directory Tester
2012-10-03 15:45:58 I msg:[DST 205.188.202.172:52114 sid=1] SHOUTcast
1 client connection closed (0 seconds) [Bytes: 0] Agent: `SHOUTcast Directory Te
ster'
2012-10-03 15:45:58 E msg:[YP2] /yp/resp/updatefreq missing
2012-10-03 15:45:58 E msg:[YP2] Connection attempt failed. YP2 error c
ode is 400 (Generic error)
further is offline   Reply With Quote
Old 3rd October 2012, 22:52   #9
further
Junior Member
 
Join Date: Oct 2012
Posts: 4
apologies for too much info. I only just learned how to copy and paste within cmd.
further is offline   Reply With Quote
Old 3rd October 2012, 22:54   #10
DrO
 
Join Date: Sep 2003
Posts: 27,873
am looking into it now...

-daz
DrO is offline   Reply With Quote
Old 3rd October 2012, 23:00   #11
further
Junior Member
 
Join Date: Oct 2012
Posts: 4
thanks. let me know i you need anythign else form me.
further is offline   Reply With Quote
Old 3rd October 2012, 23:09   #12
DrO
 
Join Date: Sep 2003
Posts: 27,873
the problem is the YP is trying to return responses in a way that the DNAS doesn't support (specifically chunked encoding as i'm getting a 'transfer-encoding : chunked' in the headers returned). that is definitely not a purposeful change made with todays update so i now need to see what i can found out as being the cause of that, otherwise it's going to be until some point tomorrow (EST) when anything can be really done to resolve it.
DrO is offline   Reply With Quote
Old 3rd October 2012, 23:41   #13
DrO
 
Join Date: Sep 2003
Posts: 27,873
on further checking what i thought was not the case. i've gone back and tried things on build 29 (as you're using) and against an internal build and both are working as expected. i've enabled some debug output on one of the YP servers to see if i can catch the reason for the error but haven't seen anything yet.

one thing to try is enabling yp2debug=1 and webclientdebug=1 in the configuration file. though as it can create large files, if you compress it and attach to this thread then that would be easier.

-daz
DrO is offline   Reply With Quote
Old 4th October 2012, 00:08   #14
steveschuh
Junior Member
 
Join Date: Oct 2012
Posts: 3
Our YP Authash isn't working since mid day

This is what we are getting. This server has been running for months.

2012-10-03 19:57:57 E msg:[DST scdp-m03.websys.aol.com:54155 sid=1] SHOUTcast 1 client connection rejected. Stream not available. SHOUTcast Directory Tester
2012-10-03 19:57:57 I msg:[DST scdp-m03.websys.aol.com:54155 sid=1] SHOUTcast 1 client connection closed (0 seconds) [Bytes: 0] Agent: `SHOUTcast Directory Tester&apos;
2012-10-03 19:57:57 E msg:[YP2] /yp/resp/updatefreq missing
2012-10-03 19:57:57 E msg:[YP2] Connection attempt failed. YP2 error code is 400 (Generic error)
2012-10-03 19:58:27 I msg:[YP2] Connecting to yp.shoutcast.com
2012-10-03 19:58:45 I msg:[YP2] Connecting to yp.shoutcast.com
2012-10-03 19:58:57 I msg:[YP2] Connecting to yp.shoutcast.com
2012-10-03 19:58:57 E msg:[DST scdp-m02.websys.aol.com:54328 sid=1] SHOUTcast 1 client connection rejected. Stream not available. SHOUTcast Directory Tester
2012-10-03 19:58:57 I msg:[DST scdp-m02.websys.aol.com:54328 sid=1] SHOUTcast 1 client connection closed (0 seconds) [Bytes: 0] Agent: `SHOUTcast Directory Tester&apos;
2012-10-03 19:58:57 E msg:[YP2] /yp/resp/updatefreq missing
2012-10-03 19:58:57 E msg:[YP2] Connection attempt failed. YP2 error code is 400 (Generic error)
2012-10-03 19:59:57 I msg:[YP2] Connecting to yp.shoutcast.com
2012-10-03 19:59:58 E msg:[DST scdp-d02.websys.aol.com:62949 sid=1] SHOUTcast 1 client connection rejected. Stream not available. SHOUTcast Directory Tester
2012-10-03 19:59:58 I msg:[DST scdp-d02.websys.aol.com:62949 sid=1] SHOUTcast 1 client connection closed (0 seconds) [Bytes: 0] Agent: `SHOUTcast Directory Tester&apos;
2012-10-03 19:59:58 E msg:[YP2] /yp/resp/updatefreq missing
2012-10-03 19:59:58 E msg:[YP2] Connection attempt failed. YP2 error code is 400 (Generic error)
2012-10-03 20:00:57 I msg:[YP2] Connecting to yp.shoutcast.com
2012-10-03 20:00:57 E msg:[DST scdp-m01.websys.aol.com:38755 sid=1] SHOUTcast 1 client connection rejected. Stream not available. SHOUTcast Directory Tester
2012-10-03 20:00:57 I msg:[DST scdp-m01.websys.aol.com:38755 sid=1] SHOUTcast 1 client connection closed (0 seconds) [Bytes: 0] Agent: `SHOUTcast Directory Tester&apos;
2012-10-03 20:00:57 E msg:[YP2] /yp/resp/updatefreq missing
2012-10-03 20:00:57 E msg:[YP2] Connection attempt failed. YP2 error code is 400 (Generic error)


I hope this helps and we can get this going

Thanks
Steve
steveschuh is offline   Reply With Quote
Old 4th October 2012, 00:29   #15
DrO
 
Join Date: Sep 2003
Posts: 27,873
unfortunately it doesn't help too much, though i've got someone connected to one of the YP servers who is experiencing the issue that i'm now working through debugging the issue on that host.

so if that doesn't help to find the issue (as the "400 Generic Error" means something has failed in a manner which is not expected to happen) then it's not going to be a fun time for v2 users.

will update this thread once i've got a better idea and / or a solution for the issue. sorry about this - this should not have happened as it never came up during the testing before this was all deployed (has just been one of those days where anything and everything goes wrong ).

-daz
DrO is offline   Reply With Quote
Old 4th October 2012, 00:47   #16
diversity
Junior Member
 
Join Date: Oct 2010
Posts: 14
Hi Daz,

I am also experiencing the same 400 generic error after literally months of uptime. I am running build 29 on linux, let me know if I can do anything to help debug this issue.

Cheers,
div

Edit: YP successfully connected literally minutes after this post. Hopefully it stays up
diversity is offline   Reply With Quote
Old 4th October 2012, 00:55   #17
DrO
 
Join Date: Sep 2003
Posts: 27,873
i've found the cause of the issue. i cannot get the fix out to all of the servers until tomorrow morning (EST) but it's running on one of the YP servers so there's a fair chance that your server should get listed again over the next hour or so (and once it's added the first time then it should be ok as long as you don't restart it / loose the source).

otherwise i can only apologise for the issue and i will be duly punishing myself with a week away from all things SHOUTcast (need it after today!).

[edit]
just seen the edit above, so that's another confirmation of the fix working.

-daz
DrO is offline   Reply With Quote
Old 4th October 2012, 01:00   #18
steveschuh
Junior Member
 
Join Date: Oct 2012
Posts: 3
Yipee Mine is working again

Thanks
Steve
steveschuh is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump