Old 17th June 2006, 17:45   #1
MikeBertolino
Junior Member
 
Join Date: Jun 2006
Posts: 15
Can't change File Association to Winamp

I just changed profiles on my Windows XP computer and now my MP3 & wav files don't play in Winamp. I uninstalled Winamp and installed 5.23 but that didn't help.
I can launch Winamp and drag a file to it to play in Winamp, but I can't get Winamp to be associated with the files. Winamp Agent is turned on. WinAmp is not in the File Types list when I tried to associate the files. I browse, find the Winamp App and click OK but nothing changes. It still doesn't show up in the association list. Does anyone has any ideas on what could cause this?
MikeBertolino is offline   Reply With Quote
Old 17th June 2006, 18:11   #2
k_rock923
\m/
(Forum King)
 
k_rock923's Avatar
 
Join Date: Jul 2003
Location: /bin/bash
Posts: 7,850
Send a message via AIM to k_rock923
http://forums.winamp.com/showthread....hreadid=154683

perhaps this thread? I did a search of association and user and it was one of the things that came up.

Never underestimate the bandwidth of a station wagon full of tapes hurtling down the highway.
k_rock923 is offline   Reply With Quote
Old 17th June 2006, 19:57   #3
MikeBertolino
Junior Member
 
Join Date: Jun 2006
Posts: 15
It looks like that may help for Winamp v2.x. I'm using 5.23. When I installed v5.23, it asked me if I wanted to share the same settings with all profiles. I said no, so it copied my preferences into my profile. So I'm assuming the plug-in is included with v5.x. I also uninstalled 5.23 and re-installed it but choosing share settings with other users. But I still have the same problem. Thanks for researching anyway. I'm thinking there may be a registry setting that is corrupt.
MikeBertolino is offline   Reply With Quote
Old 17th June 2006, 20:16   #4
MarkRH
Senior Member
 
Join Date: Nov 2002
Location: Oklahoma City, OK
Posts: 405
What program starts up when you click on an MP3? You may need to go into the preferences for that program and un-associate MP3s in it. It's possible this program has a process running that detects changes in file associations and sets them back to itself when it detects a change.
MarkRH is offline   Reply With Quote
Old 17th June 2006, 20:17   #5
JonnyMac
Moderator
 
JonnyMac's Avatar
 
Join Date: Dec 2000
Posts: 14,384
Are you talking about the Open Files dialogue? In other words, when you open a file via Winamp, you do not see all file types even though they are there? If so maybe this...
Quote:
From the Common Issues section of the Troubleshooters Sticky...

Problems with 'All Supported Filetypes' in Open File Dialog
(eg. it either shows all extensions, or some supported types are missing)
http://forums.winamp.com/showthread.php?threadid=238906
Otherwise, if you double click from Windows Explorer folder/session, are the file types played correctly? Do they have Winamp’s icon?

[edit] Whoops, a little late

Please do not PM me for tech support. Any request for tech support through PM will be ignored.
Read the Stickies
---> | | | | <--- Knowledge is power
JonnyMac is offline   Reply With Quote
Old 17th June 2006, 23:00   #6
MikeBertolino
Junior Member
 
Join Date: Jun 2006
Posts: 15
Right now Windows Media Player plays the files. I've also switched those files to other players. But I like Winamp. The problem is, there is no way to associate Winamp with music files through My Computer-Tools-Folder Options-File Types. Winamp does not show up in the list, and when I browse to find the Winamp app, then try to associate the file, nothing happens.
MikeBertolino is offline   Reply With Quote
Old 17th June 2006, 23:30   #7
Bubba Smith
Major Dude
 
Bubba Smith's Avatar
 
Join Date: Apr 2006
Location: Bubbaville, USA
Posts: 599
Have you tried browsing to a media file via Windows Explorer or My Computer, then right-clicking on that file, then select Open With > Choose Program, and then press the 'Browse' button? You should be able to locate Winamp then. Then you would also need to checkmark 'Always use the selected program to open this kind of file' and then press the 'OK' button (see my attached screenshot - always-associate.jpg)

Winamp should then immediately always be associated with that media file type, and Winamp should always open when double-clicking on that file-type. In addition, Winamp should also then be listed in File Types from that point forward.
Attached Images
File Type: jpg always-associate.jpg (35.7 KB, 481 views)
Bubba Smith is offline   Reply With Quote
Old 18th June 2006, 00:46   #8
MikeBertolino
Junior Member
 
Join Date: Jun 2006
Posts: 15
Winamp doesn't show up there either. When I click choose program, I'm back to the File Types window, and again, I can't select the Winamp app.
MikeBertolino is offline   Reply With Quote
Old 18th June 2006, 01:02   #9
JonnyMac
Moderator
 
JonnyMac's Avatar
 
Join Date: Dec 2000
Posts: 14,384
Please provide additional system specs. You mentioned profiles, are you installing with an administrator or user profile/account?
JonnyMac is offline   Reply With Quote
Old 18th June 2006, 02:04   #10
MikeBertolino
Junior Member
 
Join Date: Jun 2006
Posts: 15
I've got 2 profiles on Windows XP. Both are set as Administrator. I have Winamp installed and it plays MP3's fine when I launch Winamp, then drag the MP3 file over to it. The problem is that I'm having trouble getting Windows to associate MP3 files with Winamp.
MikeBertolino is offline   Reply With Quote
Old 18th June 2006, 04:54   #11
Bubba Smith
Major Dude
 
Bubba Smith's Avatar
 
Join Date: Apr 2006
Location: Bubbaville, USA
Posts: 599
Quote:
Originally posted by MikeBertolino
Winamp doesn't show up there either. When I click choose program, I'm back to the File Types window, and again, I can't select the Winamp app.
OK. Maybe you misunderstood me. The picture in the first attachment in my post above probably threw you off. Ignore the fact that Winamp shows as listed in my first attachment. In your case it is not. But, as I indicated above, you can still browse to your Winamp folder and locate winamp.exe there by clicking the 'Browse' button. See the new attached image below (browse-2-always-associate.gif).

Then, once winamp.exe is selected, click the 'Open' button in that dialog box. Then go ahead and checkmark 'Always use the selected program to open this kind of file' in the initial dialog box and then press the 'OK' button. Winamp will open the media file, and should be added to the list thereafter.
Attached Images
File Type: gif browse-2-always-associate.gif (47.5 KB, 425 views)
Bubba Smith is offline   Reply With Quote
Old 18th June 2006, 08:15   #12
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,822
Have you tried associating filetypes via the Winamp Prefs first?

Winamp > Prefs (Ctrl+P) > File Types
Select the extensions (mp3, aac, m4a, wma, ogg, etc) that you want Winamp to be the default player for, checkmark "restore associations at winamp startup"....

Close Prefs.
Close & reopen Winamp.

Are those filetypes still selected in Winamp Prefs?


Is there a file called paths.ini in your Winamp folder?
eg. C:\Program Files\Winamp\paths.ini

If so, then this is the file which tells Winamp to save all settings to your profile folder (%appdata%\winamp) instead of in the Program Files\Winamp folder. Maybe try disabling that file by renaming it to eg. paths.ini.off, then try all the above again.
DJ Egg is offline   Reply With Quote
Old 20th June 2006, 01:18   #13
MikeBertolino
Junior Member
 
Join Date: Jun 2006
Posts: 15
I've tried browsing file types. I pick Winamp.exe, click open, but that's as far as it goes. I never see it appear in the list, so I can never associate Winamp to my MP3 files, (usually it would show up in the top of the list). I do see the paths.ini file. When I open it, it shows this:
[Winamp]
inidir={26}\Winamp
Any other suggestions?
MikeBertolino is offline   Reply With Quote
Old 23rd June 2006, 01:07   #14
MikeBertolino
Junior Member
 
Join Date: Jun 2006
Posts: 15
I just installed Winamp 5.24 in hopes it would fix my problem. Unfortunately it did not. Winamp still does not show up in the file association list, even when I use the browse option and pick Winamp.exe. Yet Winamp says it is associated to these audio files under preferences. I tried renaming the Paths.ini file, but that didn't fix the problem either. Does anyone have any other ideas?
MikeBertolino is offline   Reply With Quote
Old 23rd June 2006, 01:17   #15
Bubba Smith
Major Dude
 
Bubba Smith's Avatar
 
Join Date: Apr 2006
Location: Bubbaville, USA
Posts: 599
5.24 was a 'forced' release due to a security vulnerability.
Quote:
Originally posted by DJ Egg
21st June 2006 : 5.24 released
winamp.exe = 5.2.4.703 | in_midi.dll updated (info)
Everything else is exactly the same as 5.23
Main post in thread updated accordingly.
And that's all that's changed, nothing more. Gotta wait for 5.25 now for all bug fixes.

Anyway, as far as YOUR problem is concerned...
I've offered all I could and I'm still fresh out of ideas. But Egg will be by at some point to help I'm sure. Only... LOL!!! ... MikeBertolino will have to wait while Egg takes a bit of a break.

Just hang tight dude. You'll be rescued.
Bubba Smith is offline   Reply With Quote
Old 23rd June 2006, 01:43   #16
MikeBertolino
Junior Member
 
Join Date: Jun 2006
Posts: 15
I just read the thread. Wow, looks like the exact same problem. My settings look similar also. I can wait. Egg deserves a breather after that. Thanks!
MikeBertolino is offline   Reply With Quote
Old 23rd June 2006, 01:55   #17
Bubba Smith
Major Dude
 
Bubba Smith's Avatar
 
Join Date: Apr 2006
Location: Bubbaville, USA
Posts: 599
He's amazing, isn't he?
Bubba Smith is offline   Reply With Quote
Old 24th June 2006, 18:47   #18
MikeBertolino
Junior Member
 
Join Date: Jun 2006
Posts: 15
I agree.
I do have the Winamp.file entry in my registry. When I tried to look in it, windows said error while opening file. When I checked permissions, it said I do not have current permissions to view, but I can make permission changes. I'm set up as administrator. I went through the process of assigning permissions on that folder to my user name, but when I tried assigning permission to the sub folders, (Default Icon or Shell), I couldn't change permissions.
MikeBertolino is offline   Reply With Quote
Old 2nd July 2006, 21:07   #19
MikeBertolino
Junior Member
 
Join Date: Jun 2006
Posts: 15
I just reset all my registry permissions back to default using an app created by Ramesh Srinivasan and got XP to associate mps files with Winamp. Everything mp3 plays in Winamp fine but the Icon for MP3 files still shows QuickTime's Icon. I tried changing the icon through file associations but they didn't change. I also deleted IconCache.db but that didn't help either. Any ideas?
MikeBertolino is offline   Reply With Quote
Old 2nd July 2006, 21:38   #20
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,822
Yeah, that's a slightly different issue...

http://forums.winamp.com/showthread....86#post1956786

Basically, you need to delete this registry key

HKEY_CLASSES_ROOT\Winamp.File\ShellEx\IconHandler

The attached .reg file will auto delete that key for you
(unzip & run WinampIconFix.reg)
Attached Files
File Type: zip winampiconfix.zip (265 Bytes, 369 views)
DJ Egg is offline   Reply With Quote
Old 2nd July 2006, 23:12   #21
MikeBertolino
Junior Member
 
Join Date: Jun 2006
Posts: 15
That fixed it.
Thanks!
MikeBertolino is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump