Old 10th December 2004, 22:42   #1
sym007
Junior Member
 
Join Date: Dec 2004
Posts: 7
sorting issue

I just upgraded from 5.01 to 5.07.

I've got most of my options back to the way I had them... except one.

In 5.01, when I had a band name that started with "the" it would sort it with that letter (for example 'The Shins' would be under 'S' instead of 'T', 'The Cure' would be under 'C' instead of 'T', etc..).

One way I think that I could fix this is to use id tags. I know I'm kind of in the minority, but I really really hate tags, they seem to complicate things for me, and I like to keep everything nice and simple. Plus it's a major pain to update them.

I was really happy when I found out that version 5 did that, since I never came across it in version 3. I've searched the forums and couldn't find anything, so any help from you guys would be very appreciated.
sym007 is offline   Reply With Quote
Old 11th December 2004, 00:34   #2
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,076
Hmm . . . it still does sort like that. Nothing's changed since then.

How are your files organized? (folder structure / filename)

What metadata detection mode are you using?
(prefs > media library > watch folders > "configure" button)
Attached Images
File Type: jpg ml_a-z.jpg (98.0 KB, 147 views)
DJ Egg is offline   Reply With Quote
Old 11th December 2004, 03:36   #3
sym007
Junior Member
 
Join Date: Dec 2004
Posts: 7
I have all my mp3s in one folder (my music folder). I have each album as a playlist. None of them have any ID3 tags at all. The filenames have the band first then a dash and then the song (eg, 'Chevelle - Vitamin R'). Kind of a simple custom setup.

Right now I have no options selected for metadata. I've tried each one and restarted winamp each time just to make sure that the option would load up, but no luck. I did that in both the 'configure' button and the 'edit selected' button.

Also, in prefs >titles I have the advanced title formatting turned on and set to $filepart(%filename%) if that makes any difference.

I'm really thinking of just going back to 5.01, since I was happy with it.. Although the security bug bothers me, and it kept crashing about some unknown field type association thing. But since it supposedly hasn't changed since then, I don't see why it wouldn't be doing the same thing there as well.
sym007 is offline   Reply With Quote
Old 11th December 2004, 09:08   #4
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,076
Like I said, nothing's changed in that department since 5.01 - only bugfixes.

Advanced Title Formatting only controls the display & sort options in the Playlist window, not the Media Library. :/

Metadata detection mode only controls how files will be organised in the Media Library database (Local Media > views).

Have you actually added your music folder to the library?
DJ Egg is offline   Reply With Quote
Old 11th December 2004, 19:21   #5
sym007
Junior Member
 
Join Date: Dec 2004
Posts: 7
Alrighty then. I fixed it. I just uninstalled 5.07, then installed 5.01. It worked there, so I uninstalled it and reinstalled 5.07. (just reinstalling should give the same effect)

So now it works in 5.07... I set all the options when I was adding the media folder to the library. Before, I set them after I added the media folder. I did everything exactly the same other than that. Not sure if that was what made the difference or if it was just a bug in the install procedure.

Either way, thanks for trying to help and keep up the good work. =)

Last edited by sym007; 11th December 2004 at 20:10.
sym007 is offline   Reply With Quote
Old 11th December 2004, 19:54   #6
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,076
Yeah, the settings need to be adjusted BEFORE you import the music, not after, heh.
DJ Egg is offline   Reply With Quote
Old 11th December 2004, 20:10   #7
sym007
Junior Member
 
Join Date: Dec 2004
Posts: 7
The problem has arised again. In the media library some of the files are jumbled up(see attachment). When I sort them out with the 'filename' column the problem occurs again ('the band name' under 'T'), but the files are sorted.

To counter that I added the artist and title column. I sort it out with the 'artist' column and the problem goes away, but the files are jumbled again. So, yeah, catch 22.

I believe the reason that this happens is because I have multiple dashes in some of the files, like soundtracks and whatnot. Right now soundtracks are all grouped together by their filename instead of a playlist (eg, 'Soundtracks - Kill Bill Vol 1 - 01 - Bang Bang').

I just reinstalled 5.01 and it does the same thing. But there must be a way to do it because that's the way I did it before. =\

EDIT: Problem solved! I just added the 'title' column! Hehe, feel kind of stupid now, something so simple. Thanks again.
Attached Images
File Type: jpg jumbled.jpg (57.8 KB, 157 views)
sym007 is offline   Reply With Quote
Old 11th December 2004, 20:33   #8
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,076
hehe
DJ Egg is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump