Old 8th September 2004, 02:50   #1
bshosby
Junior Member
 
Join Date: Sep 2004
Posts: 1
crossfader won't work

I have been a winamp 3 user, and i recently upgraded to winamp 5.05. The only problem is that the crossfader is on, but the tracks won't fade. It doesn't seem to matter whether the fader is set to 6, 10, or 20 seconds, absolutely no crossfading between tracks. Please help..Thanks
bshosby is offline   Reply With Quote
Old 8th September 2004, 03:01   #2
Nunzio390
Nugatory Aluminator
Look it up

 
Nunzio390's Avatar
 
Join Date: Oct 2002
Location: Tharsis Ridge (Martian lowlands)
Posts: 8,588
Send a message via AIM to Nunzio390 Send a message via Yahoo to Nunzio390
Refer to this post by DJ Egg

Don't email or PM me concerning Winamp. Instead, either start a NEW TOPIC or post a REPLY in the appropriate thread in these forums. This will also benefit others who may have a similar question or problem. But before posting, please first Search the forums and read all FAQs and all Sticky threads.

ORB Remote Broadcast

[ Automated Jukebox | Nunzio's Home | Wacky Videos | Solve the Prunella Puzzle! ]
[ LINE RIDER! | My Resume | Virtual Chess | Composite Sketch | My Niece's Band ]
[ Plugins by Joonas | DrO's Winamp Plugins and Extras | K-Jöfol ]
Nunzio390 is offline   Reply With Quote
Old 31st May 2005, 06:15   #3
Ashnohgrimbatul
Junior Member
 
Join Date: May 2005
Posts: 6
Won't fade in

I used to be able to use the direct sound crossfader. Since I reformated my computer nothing that I have tried will get the fader to make songs fade in. They will fade out just fine. I have updated my DirectX, Audigy Drivers, Winamp...everything that I can think of that might possibly affect this. Still no dice. And based on what I've read it appears I'm not the only one who has had or is having this issue. Anyone have any suggestions further to what DJ Egg has suggested?
Ashnohgrimbatul is offline   Reply With Quote
Old 31st May 2005, 11:06   #4
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
And you've enabled that feature, yes?

Prefs > Plugins > Output > DirectSound > config > Fading tab
Hi-lite "On start", checkmark both "enabled" and "use custom fade time"
Set "custom fade" value according to taste (eg. 6000ms for 6 secs)

If fade-out works, then it doesn't make sense that fade-in doesn't.

If the problem persists, tell us what file formats you're playing, what version of winamp, whether you've installed ANY extra 3rd-party plugins (and if so, which ones), and any extra information that might help us to help you.
DJ Egg is offline   Reply With Quote
Old 31st May 2005, 17:16   #5
Ashnohgrimbatul
Junior Member
 
Join Date: May 2005
Posts: 6
That is what I was thinking...why would the fade out work but not the fade in, but that is what is happening. I have adjusted all the settings you mentioned in your post http://forums.winamp.com/showthread....46#post1212346 but the "fade on start" and "fade on first start" do nothing. Also of note, the "Remove Silence" option found on the next tab also doesn't work either, but it also used to before I reformated.

I only play mp3 files, I have Winamp Version 5.092 and the only third party plugin I have installed is Enhancer V 0.17.

Thanks very much for your help.

Edit: My system info

Windows XP
512 MB PC 2700 DDR
Sound Blaster Audigy

Last edited by Ashnohgrimbatul; 31st May 2005 at 17:33.
Ashnohgrimbatul is offline   Reply With Quote
Old 31st May 2005, 17:37   #6
Ashnohgrimbatul
Junior Member
 
Join Date: May 2005
Posts: 6
I just was checking other options in Winamp to see if there is anything else not working properly....and the "Balance" slider also does nothing (as in when I try to shift it to the left or right channel.
Ashnohgrimbatul is offline   Reply With Quote
Old 1st June 2005, 01:27   #7
Ashnohgrimbatul
Junior Member
 
Join Date: May 2005
Posts: 6
Uninstalled and then reinstalled winamp, fixed the balance issue but not the fade in or the remove silence issue.
Ashnohgrimbatul is offline   Reply With Quote
Old 1st June 2005, 01:44   #8
ujay
Forum King
 
ujay's Avatar
 
Join Date: Jul 2001
Location: London
Posts: 6,072
http://forums.winamp.com/showthread....52#post1687552
ujay is offline   Reply With Quote
Old 1st June 2005, 03:07   #9
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Ok, I think you could well be right here.
It doesn't appear to be fading in on start any more.
The 'fade on end of song' setting works (whether enabled via the xfade controls in the modern skin eq, or manually via the out_ds config), and the tracks do actually crossfade (especially more noticable when using a larger value between 10000 and 20000 ms), but the 'on start' and 'on first start' options seem to be broken in 5.092 (ie. tracks are starting at normal constant volume, instead of fading in).

Hopefully, I'll try to get Ben to look into this tomorrow...
DJ Egg is offline   Reply With Quote
Old 1st June 2005, 03:44   #10
Ashnohgrimbatul
Junior Member
 
Join Date: May 2005
Posts: 6
So I'm not crazy!
Ashnohgrimbatul is offline   Reply With Quote
Old 1st June 2005, 16:23   #11
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
No, you're not

You'll be glad to know that this bug has already been fixed in the latest internal test build.

Also note that (believe it or not) the bug is in in_wm.dll (WMA Input plugin), and if you don't have any wma files then you can temporarily disable in_wm.dll and the bug will go away.

Thanks.
DJ Egg is offline   Reply With Quote
Old 2nd June 2005, 01:21   #12
Ashnohgrimbatul
Junior Member
 
Join Date: May 2005
Posts: 6
Awesome, tried it and it works flawlessly. Who needs WMAs anyway! Thanks.
Ashnohgrimbatul is offline   Reply With Quote
Old 29th June 2005, 04:12   #13
barcodetobago
Junior Member
 
Join Date: Jun 2005
Posts: 2
i followed these instructions and still cant get the fader to work . please assist
barcodetobago is offline   Reply With Quote
Old 29th June 2005, 06:22   #14
barcodetobago
Junior Member
 
Join Date: Jun 2005
Posts: 2
fader

fader not working on seek buttons
barcodetobago is offline   Reply With Quote
Old 29th June 2005, 17:54   #15
ujay
Forum King
 
ujay's Avatar
 
Join Date: Jul 2001
Location: London
Posts: 6,072
If, by Seek button(singular) you are referring to the track progress button, then make sure you have 'On seek' enabled in the fading tab.
Note that if the point you seek from has substantially the same musical content as the point you are seeking to then you may not notice too much except maybe a sight dip in volume.

If, by Seek buttons(plural) you are referring to the next/previous track buttons, then make sure you have 'On pause/stop' enabled in the fading tab.

You should also be using v5.093 now, to avoid the problems discussed earlier in this thread.

UJ
ujay is offline   Reply With Quote
Old 11th December 2007, 03:44   #16
A1955Harley
Junior Member
 
Join Date: Nov 2007
Posts: 2
Same Problem

Need help with the fading issue.
How do you disable the in_wm.dll file??
DO you just uninstall the plugin???
I do play windows media files in Winamp
How do you enable the plugin if you uninstall it???
Thanks for the help
A1955Harley is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump