Old 8th January 2011, 02:23   #1
Kamens
Junior Member
 
Join Date: Jan 2011
Posts: 18
Winamp Not Connecting With Shoutcast

Hello everyone. I've been having trouble getting my Winamp to connect to my Shoutcast. I've downloaded and set-up everything correctly: changed Shoutcast information (pw, # of listeners, etc.), set-up the plug-in correctly, etc. I've also followed all of the steps correctly. When I open the Shoutcast DNAS (GUI) program and play a song on Winamp, this is what I get:

<01/07/11@22:22:12> [SHOUTcast] DNAS/win32 v1.9.8 (Feb 28 2007) starting up...
<01/07/11@22:22:12> [main] loaded config from C:\Program Files (x86)\SHOUTcast\sc_serv.ini
<01/07/11@22:22:13> [main] initializing (usermax:50 portbase:8000)...
<01/07/11@22:22:13> [main] No ban file found (sc_serv.ban)
<01/07/11@22:22:13> [main] No rip file found (sc_serv.rip)
<01/07/11@22:22:13> [main] opening source socket
<01/07/11@22:22:13> [main] error opening source socket! FATAL ERROR! Some other process is using this port!

My Wi-Fi is fine (hence me posting this). When I open the plug-in on Winamp and hit connect, it tells me "Cipher Response received" and my Shoutcast DNAS GUI just stays at the above. It disconnects after about 30 seconds. Anyone know what the problem is? All help is greatly appreciated.

EDIT: I have 1.98 for Shoutcast.
Kamens is offline   Reply With Quote
Old 8th January 2011, 02:30   #2
Kamens
Junior Member
 
Join Date: Jan 2011
Posts: 18
Woops, didn't even notice the fatal error there. I fixed it, but now I get this:

<01/07/11@22:29:18> [SHOUTcast] DNAS/win32 v1.9.8 (Feb 28 2007) starting up...
<01/07/11@22:29:18> [main] loaded config from C:\Program Files (x86)\SHOUTcast\sc_serv.ini
<01/07/11@22:29:18> [main] initializing (usermax:50 portbase:8000)...
<01/07/11@22:29:18> [main] No ban file found (sc_serv.ban)
<01/07/11@22:29:18> [main] No rip file found (sc_serv.rip)
<01/07/11@22:29:18> [main] opening source socket
<01/07/11@22:29:18> [main] source thread starting
<01/07/11@22:29:18> [main] opening client socket
<01/07/11@22:29:18> [source] listening for connection on port 8001
<01/07/11@22:29:18> [main] Client Stream thread [0] starting
<01/07/11@22:29:18> [main] client main thread starting

And it stays at that. I don't know in says "listening for connection on port 8001"... I have it set at 8000 on the plug-in. Help?
Kamens is offline   Reply With Quote
Old 8th January 2011, 03:12   #3
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: On the streets of Kings County, CA.
Posts: 3,008
Send a message via Skype™ to thinktink
On the legacy DNAS port 8000 is opened for listeners and the admin pages and port 8000+1 is opened for legacy SHOUTcast sources. Using the current SHOUTcast DSP in legacy mode already takes that into account for this setup so don't worry about it.

If that is your complete and full log then you are missing a "source" for the DNAS.

From just your description it would seem you forgot to put the SHOUTcast DSP in legacy mode as the last logs you've posted do not show a source connection attempt. If you did then double check the Address setting.
thinktink is offline   Reply With Quote
Old 9th January 2011, 18:36   #4
Kamens
Junior Member
 
Join Date: Jan 2011
Posts: 18
Did both, still getting the same log.

I un-installed and re-installed everything, followed the "15 step thread," looked for explanations everywhere, and I'm still getting the same log. I simply cannot figure out what I'm doing wrong. I'll make a hypercam video later and post it of my installation/set-up process.
Kamens is offline   Reply With Quote
Old 9th January 2011, 18:54   #5
fc*uk
Moderator
 
fc*uk's Avatar
 
Join Date: Dec 2005
Location: Atlantic Beach
Posts: 8,127
Which log? Your first or second?

If your first, then you are running something else that is trying to use port 8000. Please note that clicking the "x" in the dnas window does not kill the server, you have to select the "kill server" menu item.

If the second, then what address are you telling the dsp to connect to. If the dsp and dnas are running on the same computer, this needs to be set to localhost.
fc*uk is offline   Reply With Quote
Old 10th January 2011, 00:42   #6
Kamens
Junior Member
 
Join Date: Jan 2011
Posts: 18
Thanks! I changed my address to my IP address when I was fiddling with things; I changed it back and it worked fine!
Kamens is offline   Reply With Quote
Old 10th January 2011, 01:03   #7
Kamens
Junior Member
 
Join Date: Jan 2011
Posts: 18
Okay, I can start the GUI and the plug-in and they both seem to be working. However, when I go to (myIP):8000, it says "Internet Explorer cannot display the webpage." I've already turned off my firewall. Help?
Kamens is offline   Reply With Quote
Old 10th January 2011, 01:54   #8
jaromanda
Forum King
 
Join Date: Jun 2007
Location: Under the bridge
Posts: 2,289
Quote:
Originally Posted by Kamens View Post
Okay, I can start the GUI and the plug-in and they both seem to be working. However, when I go to (myIP):8000, it says "Internet Explorer cannot display the webpage." I've already turned off my firewall. Help?
are you "behind" a NAT router and trying to use your public IP address? if so, that wont work, ever

Is it just me or are shoutcast users getting dumber?
jaromanda is offline   Reply With Quote
Old 10th January 2011, 03:23   #9
Kamens
Junior Member
 
Join Date: Jan 2011
Posts: 18
I'm not sure. I'm not the techiest guy, just really into music. I have a Belkin router, if that helps. Aren't you able to change your NAT type to open or something like that?
Kamens is offline   Reply With Quote
Old 10th January 2011, 03:33   #10
jaromanda
Forum King
 
Join Date: Jun 2007
Location: Under the bridge
Posts: 2,289
don't know ... all I know is you can't use your "public" IP address to connect (via port forwarding in the router) to a "private" IP ... unless your router specifically supports such voodoo

Is it just me or are shoutcast users getting dumber?
jaromanda is offline   Reply With Quote
Old 10th January 2011, 03:40   #11
Kamens
Junior Member
 
Join Date: Jan 2011
Posts: 18
Alright, thanks. I'll figure out something. The last explanation I thought it might be was my computer. Try going here and see if it works.

http://76.180.186.69:8000
Kamens is offline   Reply With Quote
Old 10th January 2011, 03:42   #12
jaromanda
Forum King
 
Join Date: Jun 2007
Location: Under the bridge
Posts: 2,289
Quote:
Originally Posted by Kamens View Post
Alright, thanks. I'll figure out something. The last explanation I thought it might be was my computer. Try going here and see if it works.

http://76.180.186.69:8000
have you forwarded port 8000 to the computer running DNAS?

have you enabled port 8000 in that computers firewall?

Is it just me or are shoutcast users getting dumber?
jaromanda is offline   Reply With Quote
Old 11th January 2011, 03:06   #13
Kamens
Junior Member
 
Join Date: Jan 2011
Posts: 18
Just tried forwarding port 8000 and 8001, this is what I got:



Hit "Apply Changes" and



I followed the steps to forward ports according to this website, and yes, I can assure you that I'm forwarding with the correct Belkin router type.

Error message reads "No1. The IP that you entered is invalid."
Kamens is offline   Reply With Quote
Old 11th January 2011, 03:27   #14
jaromanda
Forum King
 
Join Date: Jun 2007
Location: Under the bridge
Posts: 2,289
Quote:
Originally Posted by Kamens View Post
Error message reads "No1. The IP that you entered is invalid."
I'd guess that the IP address you entered was invalid

looks BLANK - definitely not valid - you need your DNAS computer's IP address (the last number, the first three are done for you)

oh ... and forward port 8001 ONLY if you want to accept incoming source streams from the internet - otherwise leave port 8001 alone

and another thing ... only need TCP, not TCP+UDP

other than that, you did everything right

Is it just me or are shoutcast users getting dumber?
jaromanda is offline   Reply With Quote
Old 11th January 2011, 03:30   #15
jaromanda
Forum King
 
Join Date: Jun 2007
Location: Under the bridge
Posts: 2,289
see the bit on that "portforward" page which says "Do not skip this step!"

you skipped it, didn't you

Is it just me or are shoutcast users getting dumber?
jaromanda is offline   Reply With Quote
Old 11th January 2011, 21:39   #16
Kamens
Junior Member
 
Join Date: Jan 2011
Posts: 18
...yes. I went back and fixed it and it seemed to work. However, I'm still getting an "internet explorer cannot display the webpage" when I go to "myip:8000." I port-checked it through the site and it said it's open... why won't it show up?
Kamens is offline   Reply With Quote
Old 11th January 2011, 21:57   #17
jaromanda
Forum King
 
Join Date: Jun 2007
Location: Under the bridge
Posts: 2,289
Quote:
Originally Posted by Kamens View Post
...yes. I went back and fixed it and it seemed to work. However, I'm still getting an "internet explorer cannot display the webpage" when I go to "myip:8000." I port-checked it through the site and it said it's open... why won't it show up?
when you say "myip", do you mean your "public" or WAN ip, or do you mean the machines "private" IP, i.e. 192.168.2.???

it's the latter IP address YOU can connect to ... everyone else (outside your LAN) will connect to the public IP address

Is it just me or are shoutcast users getting dumber?
jaromanda is offline   Reply With Quote
Old 11th January 2011, 22:00   #18
daverogers
Senior Member
 
Join Date: Jan 2011
Location: Bristol, uk
Posts: 104
go to myip.com and whatever it says your ip is put that in so http://yourip:8000
daverogers is offline   Reply With Quote
Old 11th January 2011, 22:02   #19
jaromanda
Forum King
 
Join Date: Jun 2007
Location: Under the bridge
Posts: 2,289
Quote:
Originally Posted by daverogers View Post
go to myip.com and whatever it says your ip is put that in so http://yourip:8000
within your LAN, you CAN NOT use your WAN ip address

use your LAN ip address, as I stated above ... 192.168.2.???

Is it just me or are shoutcast users getting dumber?
jaromanda is offline   Reply With Quote
Old 11th January 2011, 22:39   #20
Kamens
Junior Member
 
Join Date: Jan 2011
Posts: 18
I tried both 192.168.2.1:8000 and 192.168.2.150:8000 (static IP it gave me) and neither of them work.
Kamens is offline   Reply With Quote
Old 12th January 2011, 02:50   #21
Kamens
Junior Member
 
Join Date: Jan 2011
Posts: 18
Fixed! Thanks for all your help!
Kamens is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump