Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Reply
Thread Tools Search this Thread Display Modes
Old 14th December 2010, 06:02   #1
akalakon231
Junior Member
 
Join Date: Dec 2010
Posts: 1
Resizing Winamp From WindowShade Mode 'squishes' other windows [FIX]

Hello fellow Winamp users. I came to this thread trying to find the solution to the 'squishing' problem many people were aggravated with. If you do not understand what I am talking about at this point, then most likely you need not worry about this post. Through reading a previous thread I was able to solve the problem but it appears that the answer was not clear to many people and this is why I feel the need to post..

This is the:
!!!!!!!!!!!SOLUTION!!!!!!!!!!!


While in full screen mode, go to an empty space and hold down CTRL then right click. A little menu should pop up with docked toolbar being the last option. Now all you have to do is check the 'Not Docked' option and you are home free!

Again, make sure you are in FULL SCREEN MODE when doing this, not WindowShade Mode.


If you want to understand why its screwed up then read on! If not, I understand.

First off, you have to realize the completely idiotic flaw in Winamp. When Winamp starts up for the first time on your computer every setting is shared between WindowShade mode and Full Screen mode.

This includes the Docked Toolbar setting as well!! (*Gasp*)
Yup.. programming fail.

Explanation time :

When winamp windowshade mode is in docked mode, it clears out a special area on the desktop in which no other program can have access. This is the reason why other windows dont overlap winamp while its in windowshade with the 'docked toolbar' option enabled.

However, every time you tried to switch to Maximized or full screen mode from docked windowshade mode, what winamp would do is stretch out the 'reserved space' on the desktop so that the maximized winamp would fit. This would push everything to the bottom of the screen, windows AND desktop icons alike (well at least for me anyway). This is because the full screen mode is sharing the Docked toolbar setting with the windowshade mode!!!!!!!!

FIX?
While in full screen mode, go to an empty space and hold down CTRL then right click. A little menu should pop up with docked toolbar being the last option. Now all you have to do is check the 'Not Docked' option and you are home free!

Again, make sure you are in FULL SCREEN MODE when doing this.

If you do everything correctly, the windowshade mode should still be docked and switching between modes should leave your precious windows alone.

TIP:
Also. I noticed that when Docked Toolbar option is enabled, Winamp would not maximize fully. Instead there would be a space showing the desktop where the Windowshade mode would be covering. To avoid that little annoyance all I did was simply not maximize Winamp. I stretched out its un-maximized window to cover the entire screen and when i want to switch between WindowShade and regular, I press the MAIN MODE button, NOT maximize winamp.

I hope this was helpful to anyone with this problem.
akalakon231 is offline   Reply With Quote
Old 15th October 2011, 01:32   #2
superesonator
Junior Member
 
Join Date: Oct 2005
Posts: 15
winamp no baka

Great to see some acknowledgement of this idiotic flaw which has persisted version after version.
k
But it must be noted that it is not a fix, it iis a workaround. Winamp developers need help if they can't sort out such a persistant problem.


Truly pathetic fail. Historý will remember this, with Winamp one of the great 'might have beens'.


QUOTE=akalakon231;2726326]Hello fellow Winamp users. I came to this thread trying to find the solution to the 'squishing' problem many people were aggravated with. If you do not understand what I am talking about at this point, then most likely you need not worry about this post. Through reading a previous thread I was able to solve the problem but it appears that the answer was not clear to many people and this is why I feel the need to post..

This is the:
!!!!!!!!!!!SOLUTION!!!!!!!!!!!


While in full screen mode, go to an empty space and hold down CTRL then right click. A little menu should pop up with docked toolbar being the last option. Now all you have to do is check the 'Not Docked' option and you are home free!

Again, make sure you are in FULL SCREEN MODE when doing this, not WindowShade Mode.


If you want to understand why its screwed up then read on! If not, I understand.

First off, you have to realize the completely idiotic flaw in Winamp. When Winamp starts up for the first time on your computer every setting is shared between WindowShade mode and Full Screen mode.

This includes the Docked Toolbar setting as well!! (*Gasp*)
Yup.. programming fail.

Explanation time :

When winamp windowshade mode is in docked mode, it clears out a special area on the desktop in which no other program can have access. This is the reason why other windows dont overlap winamp while its in windowshade with the 'docked toolbar' option enabled.

However, every time you tried to switch to Maximized or full screen mode from docked windowshade mode, what winamp would do is stretch out the 'reserved space' on the desktop so that the maximized winamp would fit. This would push everything to the bottom of the screen, windows AND desktop icons alike (well at least for me anyway). This is because the full screen mode is sharing the Docked toolbar setting with the windowshade mode!!!!!!!!

FIX?
While in full screen mode, go to an empty space and hold down CTRL then right click. A little menu should pop up with docked toolbar being the last option. Now all you have to do is check the 'Not Docked' option and you are home free!

Again, make sure you are in FULL SCREEN MODE when doing this.

If you do everything correctly, the windowshade mode should still be docked and switching between modes should leave your precious windows alone.

TIP:
Also. I noticed that when Docked Toolbar option is enabled, Winamp would not maximize fully. Instead there would be a space showing the desktop where the Windowshade mode would be covering. To avoid that little annoyance all I did was simply not maximize Winamp. I stretched out its un-maximized window to cover the entire screen and when i want to switch between WindowShade and regular, I press the MAIN MODE button, NOT maximize winamp.

I hope this was helpful to anyone with this problem. [/QUOTE]
superesonator is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump