Old 13th February 2013, 04:39   #1
CaptainSiberia
Junior Member
 
Join Date: Feb 2010
Posts: 8
Gapless playback snips things out

Something is wrong with Winamp's gapless playback. I'm using Directsound Output, and as far as I can figure, it's set up correctly. But when I play a CD or flac files where tracks flow into each other, the gapless playback doesn't work right. As it changes tracks, it snips a fraction of a second off the end of the first track, or perhaps off the beginning of the second, so the transition becomes jarring instead of smooth. What's going on here? How do I fix it?
CaptainSiberia is offline   Reply With Quote
Old 13th February 2013, 07:20   #2
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,440
Send a message via AIM to MrSinatra
thats odd, b/c i don't notice that unless its something thats "old" meaning encoded by an older codec.

is it everything, or just some things? perhaps post some example files at 4shared.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 13th February 2013, 11:21   #3
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,627
Quote:
Originally Posted by CaptainSiberia View Post
I'm using Directsound Output, and as far as I can figure, it's set up correctly.
Exactly how is it configured? It may not be correct or you may need a minor adjustment.

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 14th February 2013, 17:11   #4
CaptainSiberia
Junior Member
 
Join Date: Feb 2010
Posts: 8
It's set, I believe, to the prescribed config.

Device is Primary Sound Driver. Allow hardware acceleration, Create primary buffer.

Buffer length of 1000 ms. Same for Prebuffer and Buffer-ahead. Enable CPU usage control. And I think I've tried varying the buffer length and gotten the same result.

Default fade length 0 ms, all fades disabled. "Don't abort" is checked, incidentally.

Silence remover not enabled. Volume control disabled, because I like it that way. Smooth volume changes is checked, and control is set to linear.
CaptainSiberia is offline   Reply With Quote
Old 14th February 2013, 17:35   #5
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,440
Send a message via AIM to MrSinatra
doesn't sound like defaults to me.

note your current settings, then reset to defaults, then try it.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 14th February 2013, 19:26   #6
CaptainSiberia
Junior Member
 
Join Date: Feb 2010
Posts: 8
But I never said defaults. I said "prescribed."

Well, I tried reseting the plugin. Didn't help. There's still a small bit of snipping and sometimes a tiny click during changeovers.

I tried using a 4-second buffer for everything. No change. I played around with the CD Plugin settings; just got undesirable changes.
CaptainSiberia is offline   Reply With Quote
Old 14th February 2013, 19:49   #7
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,440
Send a message via AIM to MrSinatra
i didn't say you said defaults.

regardless, exactly how did u "reset" it?

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 15th February 2013, 00:13   #8
CaptainSiberia
Junior Member
 
Join Date: Feb 2010
Posts: 8
Nullsoft DirectSound Output v2.6 > Reset All.

Isn't there anything else I can try here?
CaptainSiberia is offline   Reply With Quote
Old 15th February 2013, 00:29   #9
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,440
Send a message via AIM to MrSinatra
i wonder if u have to do that for each tab, as the buffering tab has a second reset button?

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 15th February 2013, 01:21   #10
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,627
Quote:
Originally Posted by CaptainSiberia View Post
It's set, I believe, to the prescribed config.

Device is Primary Sound Driver. Allow hardware acceleration, Create primary buffer.

Buffer length of 1000 ms. Same for Prebuffer and Buffer-ahead. Enable CPU usage control. And I think I've tried varying the buffer length and gotten the same result.

Default fade length 0 ms, all fades disabled. "Don't abort" is checked, incidentally.

Silence remover not enabled. Volume control disabled, because I like it that way. Smooth volume changes is checked, and control is set to linear.
Those 'prescribed' settings are not very good. Who prescribed them?

Anyway, you may get better results by setting the output device to the actual device you want to use. Leaving it set to "Primary Sound Driver" leaves the choice up to the OS (what is set as the default device in the Windows sound control panel).

Hardware acceleration is no longer supported by the Windows versions since XP.

Creating a primary buffer is only recommended for old sound cards and even then it may not help, if the card and/or driver is very old.

Buffer lengths are associated with fades and silence removal. If all fades and the silence remover are disabled, then the buffer and fade lengths and abort options do not matter. Likewise, if volume control is disabled, then the associated volume control options do not matter.

Those settings would have disabled the DirectSound output control (including gapless playback) and what you have left is the input plug-in's decoded output passed through to the Windows mixer and your sound device's driver. It appears you need major adjustments.

As MrSinatra suggested, you should check all the DirectSound output plug-in options after trying the reset function. It may not reset everything.

The 'sure' way to get back to the installation defaults is to shutdown Winamp and then use a text file editor (like Notepad) to remove the DirectSound output plug-in section from the Winamp configuration file (winamp.ini). It will be rewritten to the installation defaults when Winamp is restarted. Do not mess with winamp.ini, if you are not comfortable with editing *.ini files.

Search for posts on 'recommended' gapless playback settings.

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 15th February 2013, 16:56   #11
CaptainSiberia
Junior Member
 
Join Date: Feb 2010
Posts: 8
Ok. Looks like it was actually one of my DSPs that was causing trouble. I turned it off, and things went as smoothly as you please.

Incidentally, I tried changing the buffer settings. I turned them all the way down, since you said they didn't matter. Turns out they do. When they're all the way down, gaps at changeovers get bigger. The buffer is used for more than just crossfades.
CaptainSiberia is offline   Reply With Quote
Old 15th February 2013, 18:49   #12
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,440
Send a message via AIM to MrSinatra
note to self:

remember to always get a one for nunz list first.

(assuming that DrO isn't going to forbid it)

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 15th February 2013, 21:50   #13
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,627
Quote:
Originally Posted by CaptainSiberia View Post
Ok. Looks like it was actually one of my DSPs that was causing trouble. I turned it off, and things went as smoothly as you please.

Incidentally, I tried changing the buffer settings. I turned them all the way down, since you said they didn't matter. Turns out they do. When they're all the way down, gaps at changeovers get bigger. The buffer is used for more than just crossfades.
Glad you found the problem.

I said that the buffers are also important to silence removal. Did you re-enable the silence remover? If not, thanks for that info. It means that the DirectSound plug-in now works a little differently than what has been described in the past.

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 16th February 2013, 01:35   #14
CaptainSiberia
Junior Member
 
Join Date: Feb 2010
Posts: 8
No silence remover. The buffer just buffers ahead on track change so it can occur smoothly. (Unfortunately, the program will not play tracks that are shorter than the buffer. If you've got a one-second sound bite and your buffer is set to two seconds, it won't play the song, unless it's sandwiched between longer tracks.)
CaptainSiberia is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump