Old 9th May 2005, 15:13   #1
JoeBoard
Junior Member
 
Join Date: Aug 2002
Posts: 24
How do I? No gaps - DirectSound output

Hello,
I have been searching the forum, found various answers but it is still not very clear to me.

I am trying to configure Winamp not to play any gaps and have the "radio effect" when the song finishes. I don't really want crossfading, because often it does not match but I would like the last sound to flow into the other song and the other song to start straight away. I have turned on the "no gaps" option and have it at -24 db but my Winamp still seems to play when the song goes soft.

I use to use SrqSoft Advanced Crossfading but often the crossfading does not match and when configuring the application Winamp crashes but something like that would be cool.

Thanks.
JoeBoard is offline   Reply With Quote
Old 9th May 2005, 15:42   #2
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,822
Hi. Did you read this?

From the "Common Issues" section of the Troubleshooters sticky

Gapless Playback
http://forums.winamp.com/showthread.php?threadid=158316
DJ Egg is offline   Reply With Quote
Old 9th May 2005, 16:15   #3
JoeBoard
Junior Member
 
Join Date: Aug 2002
Posts: 24
Ok, there is some great information there. I will play around and reply with my results.

What exactly does Buffer-ahead on track change mean? Mine was set 0. I put it to 1000.

Is MS millisecond? and what does that mean in terms of what I am trying to do?

Thanks
JoeBoard is offline   Reply With Quote
Old 9th May 2005, 16:24   #4
JoeBoard
Junior Member
 
Join Date: Aug 2002
Posts: 24
A different question: What will happen if I make direct show my default decoder for WMA so I can able WMA gapless play? Most of mine audio are Mp3 so the above still is in question. Thanks
JoeBoard is offline   Reply With Quote
Old 9th May 2005, 17:15   #5
JoeBoard
Junior Member
 
Join Date: Aug 2002
Posts: 24
Does the shoutcast DSP have to be off for this output to work right?
JoeBoard is offline   Reply With Quote
Old 9th May 2005, 17:45   #6
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,822
You never mentioned anything about Shoutcast DSP in your first post.
Shoutcast broadcasting related issues need to be asked in the Shoutcast forum, not here.


From a listener's aspect, for native gapless playback in Winamp, you need to apply some value to the "Buffer Ahead On Track Change" slider in out_ds config (in conjunction with the "Remove Silence" option).

And yes, the Buffer Ahead values are in milliseconds (ms).

Adding WMA to the in_dshow config will only work if the wma's are NOT drm-protected.
DJ Egg is offline   Reply With Quote
Old 9th May 2005, 17:53   #7
JoeBoard
Junior Member
 
Join Date: Aug 2002
Posts: 24
Thanks for reply. I know I never said anything about the Shoutcast DSP plugin but I thought that is why I might not notice any change in my configurations in the Direct SOund plugin, because I had it running. So far I do not notice any change, except songs start quick but there is still a gap. Will keep trying.
JoeBoard is offline   Reply With Quote
Old 9th May 2005, 17:55   #8
JoeBoard
Junior Member
 
Join Date: Aug 2002
Posts: 24
I changed the configuration to buffer ahead 1000 ms.
JoeBoard is offline   Reply With Quote
Old 10th May 2005, 10:58   #9
JoeBoard
Junior Member
 
Join Date: Aug 2002
Posts: 24
I can't get that Direct Output working right!!! :-(

I would like to configure my Direct Output to cut out the gaps and do just a little bit of crossfading, so you can hear one song go into the other... but if that's not possible, at least take the gap out.

My computer is as follows:

Athlon XP 2600+
XP
512 Ram
Sound Blaster Live
Winamp 5.09

I have read various posts, and changed the buffer sizes ahead to about 1000. Can anyone recommend me some settings and tell me how to get it to work right.

At the moment the song goes until the end and ends completly with the no sound.

Thank you,
Joachim

[edit > JonnyMac] Threads Merged [/edit]
JoeBoard is offline   Reply With Quote
Old 10th May 2005, 16:24   #10
siebe83
Forum King
 
siebe83's Avatar
 
Join Date: Feb 2004
Posts: 9,222
Hi,

Did you already read these threads from the troubleshooter / common issues sticky?

Gapless Playback
http://forums.winamp.com/showthread.php?threadid=158316

Built-in crossfader issues:
http://forums.winamp.com/showthread....46#post1212346

Good Winamp plugins by Joonas, DrO and shaneh.
If you're bored go here or, if the boredom is more serious, here.
siebe83 is offline   Reply With Quote
Old 10th May 2005, 17:44   #11
JoeBoard
Junior Member
 
Join Date: Aug 2002
Posts: 24
Thank you! :-) DJ Egg has suggested a page to me and I did read it but it still did not solve my problem. I read the information yet I still can't get it to play my Mp3 gaps properly.

Quote:
DirectSound Output -> config -> Other tab
"Remove silence at beginning/end of track"

Default Cut-Off value = -40dB
I wouldn't go much higher than -30dB
A happy medium is -35dB

eg. If you went as high as the maximum -15dB
then you will start to notice a fair few seconds of the actual music missing from the beginning & end of the track.

Important:
Changes to DirectSound Output config only take effect after playback is restarted!
My settings are almost like above, except I have -24.5 has a default cut-off value and don't notice the song cutting out at all.

The rest is the same.

First I would like to get gapless playback working and then I'll work on crossfading. YES, the "end of track" fade is off, so that the above would work.

Thanks for your help.
JoeBoard is offline   Reply With Quote
Old 10th May 2005, 20:36   #12
siebe83
Forum King
 
siebe83's Avatar
 
Join Date: Feb 2004
Posts: 9,222
Ok I found the thread you referred to:
http://forums.winamp.com/showthread....09#post1665409

Please do not just start a second thread on the same topic since we will just repeat the same questions again and you will have to answer them again as well...

So, does it work without the SHOUTcast plugin enabled? If this is a problem only when SHOUTcast is running you should post in SHOUTcast tech support instead, as DJ Egg said.

If it doesn't work without SHOUTcast either...

Did you install any other third-party plugins?
Are the mp3's absolutely silent at the end or is there a 'scratch' at the end (which sometimes occurs when badly ripped/encoded)?

Also try the DirectSound output tweaks.

Good Winamp plugins by Joonas, DrO and shaneh.
If you're bored go here or, if the boredom is more serious, here.
siebe83 is offline   Reply With Quote
Old 10th May 2005, 21:37   #13
JoeBoard
Junior Member
 
Join Date: Aug 2002
Posts: 24
Quote:
So, does it work without the SHOUTcast plugin enabled? If this is a problem only when SHOUTcast is running you should post in SHOUTcast tech support instead, as DJ Egg said.
No, forget the SHOUTcast plugin. That seems to be crashing now a lot too but I am trying it without the SHOUTcast plugin on.

Quote:
Please do not just start a second thread on the same topic since we will just repeat the same questions again and you will have to answer them again as well...
Sorry I just thought i rephrase myself better.

Quote:
Did you install any other third-party plugins?
Yes, quite a lot! :-( I'm afraid. I got the crossfading, now turning that off and trying the gapless play. Not many DSP plugins, just general stuff... but I got plugin starter, and can disable all those plugins.

Quote:
Are the mp3's absolutely silent at the end or is there a 'scratch' at the end (which sometimes occurs when badly ripped/encoded)?
Song goes really soft, and then a few seconds of silence. No scratch sounds

Thanks. Going to check out the tweaks.
JoeBoard is offline   Reply With Quote
Old 11th May 2005, 12:37   #14
siebe83
Forum King
 
siebe83's Avatar
 
Join Date: Feb 2004
Posts: 9,222
Mmh, not sure what to tell you... It could be one of the plugins to blame.

First, try the DirectSound output tweaks I linked to above (if you didn't already do so).

If that doesn't help, go to Prefs (Ctrl+P) > DSP/Effect, and select '(none)'.
Then under Prefs > Input, be sure you don't have any 3rd-party mp3 input plugins installed.
Are all input plugin names starting with Nullsoft?
Try removing all listed non-Nullsoft input plugins.

Still no luck?
Try disabling your other 3rd-party plugins as well.

Which version of Winamp are you using?

Good Winamp plugins by Joonas, DrO and shaneh.
If you're bored go here or, if the boredom is more serious, here.
siebe83 is offline   Reply With Quote
Old 11th May 2005, 12:58   #15
JoeBoard
Junior Member
 
Join Date: Aug 2002
Posts: 24
I am using Winamp 5.09.

I am getting better results now. I took a suggestion and changed my settings as follows:

Bufferlength: 10000 ms
Prebuffer: 500ms
Buffer-ahead: 0ms

Cut out at: -30db

Crossfade: 1 second.

This seems to give it a nice flow. I did not know the bufferlength had to be so high to notice an effect but now it works ok. I will give WMA gapless playback a try now.
JoeBoard is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump