Old 20th October 2003, 02:28   #1
Grievance
Junior Member
 
Join Date: Oct 2003
Posts: 9
Cannot view DNAS Status page

Others can listen to my music by tuning in through the yellow page listing. But nobody can go my DNAS page and listen to my music. On the computer that I am streaming from I can go to the page fine. I just want to be able to send people to a page so that they can bookmark it. It makes things a lot more convenient.

Heres the link
http://192.168.0.2:8000

What can I do?
Grievance is offline   Reply With Quote
Old 20th October 2003, 02:29   #2
whatapain
Junior Member
 
Join Date: Oct 2003
Posts: 7
lol.. is that an internet ip?
whatapain is offline   Reply With Quote
Old 20th October 2003, 02:35   #3
Grievance
Junior Member
 
Join Date: Oct 2003
Posts: 9
Dunno.. thats the IP address for this computer.
Grievance is offline   Reply With Quote
Old 20th October 2003, 02:47   #4
DJHotIce
Forum Loser
(Forum King)
 
DJHotIce's Avatar
 
Join Date: Jan 2003
Location: That place I can't remember the name.
Posts: 4,614
Send a message via AIM to DJHotIce Send a message via Yahoo to DJHotIce
thats a internal IP address you need to give them a real world IP address

http://www.whatismyip.com to find out your real world IP address.

-DJHotIce
Bounce Multimedia - Professional Web Design
DJHotIce is offline   Reply With Quote
Old 20th October 2003, 02:50   #5
Grievance
Junior Member
 
Join Date: Oct 2003
Posts: 9
Ok I used that and found my IP address but it still doesnt work...

http://4.33.66.184:8000/
Grievance is offline   Reply With Quote
Old 20th October 2003, 03:21   #6
DJHotIce
Forum Loser
(Forum King)
 
DJHotIce's Avatar
 
Join Date: Jan 2003
Location: That place I can't remember the name.
Posts: 4,614
Send a message via AIM to DJHotIce Send a message via Yahoo to DJHotIce
did you open the port on your router?

-DJHotIce
Bounce Multimedia - Professional Web Design
DJHotIce is offline   Reply With Quote
Old 20th October 2003, 03:51   #7
Grievance
Junior Member
 
Join Date: Oct 2003
Posts: 9
Probably not. Can you tell me how? I am only connecting and streaming with the 192.168.0.2 address. Now when I put 4.33.66.184 into the Shoutcast source it wont connect at all. I am using a netgeat wireless router. I went to port forwarding, added a custom service, made the starting port 8000, and the ending port 8000 and the server IP address 4.33.66.184. But now Im getting nothing. It only works with localhost or the 192.168.0.2.
Grievance is offline   Reply With Quote
Old 20th October 2003, 03:53   #8
FesterHead
Alumni
 
FesterHead's Avatar
 
Join Date: Sep 2001
Location: Maui, Hawaii
Posts: 14,103
your router doesn't support local loopback then machines on the same lan as the DNAS (you) need to use the lan ip of the DNAS to connect/listen.
Machines not on the same lan as the DNAS (the rest of the world) need to use the real, world-visible ip of the DNAS to connect/listen.

*************

http://4.33.66.184:8000/ -> Cannot find server or DNS Error

1. Is your DNAS (SHOUTcast server) on?

2. Any errors logged in the DNAS?

3. Did you follow any of the setup tutorials?

Please read some polite advice.

Check out http://www.radiotoolbox.com/cantheygetin and see if the reported information there helps.

FesterHead is offline   Reply With Quote
Old 20th October 2003, 04:09   #9
Grievance
Junior Member
 
Join Date: Oct 2003
Posts: 9
I have followed many of the setup tutorials. As of right now I am just stumped on the IP address issue. When I check my network settings the IP address is listed as 192.186.0.2. Checking online it is 4.33.66.184. I tried making the adjustments to the sc_serv file and to the shoutcast source and I get no connection. Do I have to change something in my router settings to 4.33.66.184? I actually did try, and I couldnt access the internet anymore so I had to reset my router. Sorry to cause such trouble but I really did read through a lot of the walkthroughs and got no help.
Grievance is offline   Reply With Quote
Old 20th October 2003, 04:40   #10
Grievance
Junior Member
 
Join Date: Oct 2003
Posts: 9
Right now my server is up and I have no errors.

Quote:
Event log:
<10/19/03@23:47:32> [SHOUTcast] DNAS/win32 v1.9.2 (Nov 25 2002) starting up...
<10/19/03@23:47:32> [main] loaded config from C:\Program Files\SHOUTcast\sc_serv.ini
<10/19/03@23:47:32> [main] initializing (usermax:32 portbase:8000)...
<10/19/03@23:47:32> [main] No ban file found (sc_serv.ban)
<10/19/03@23:47:32> [main] No rip file found (sc_serv.rip)
<10/19/03@23:47:32> [main] opening source socket
<10/19/03@23:47:32> [main] source thread starting
<10/19/03@23:47:32> [main] opening client socket
<10/19/03@23:47:32> [source] listening for connection on port 8001
<10/19/03@23:47:32> [main] Client Stream thread [0] starting
<10/19/03@23:47:32> [main] client main thread starting
<10/19/03@23:47:34> [source] connected from 192.168.0.2
<10/19/03@23:47:35> [source] icy-name:False Grievances ; icy-genre:A large variety of great music
<10/19/03@23:47:35> [source] icy-pub:1 ; icy-br:320 ; icy-url:http://4.33.66.184:8000
<10/19/03@23:47:35> [source] icy-irc:#shoutcast ; icy-icq:0 ; icy-aim:N/A
<10/19/03@23:47:35> [dest: 205.188.234.42] starting stream (UID: 0)[L: 1]{A: SHOUTcast Directory Tester}(P: 0)
<10/19/03@23:47:35> [dest: 205.188.234.42] connection closed (0 seconds) (UID: 0)[L: 0]{Bytes: 8192}(P: 0)
<10/19/03@23:47:38> [yp_add] yp.shoutcast.com added me successfully
You can check this link out now http://4.33.66.184:8000/ but Im pretty sure it wont work.

I think right now my computer is set on a default IP address... 192.128.0.2. Do I need to give it a new IP address?

I also used the link you gave me and put in my port number in the box and it said this:

4.33.66.184:8000 is Open
A server is running on this port!

It seems like everything is working fine just nobody can view the site.
Grievance is offline   Reply With Quote
Old 20th October 2003, 06:37   #11
Jay
Moderator Alumni
 
Jay's Avatar
 
Join Date: May 2000
Location: Next Door
Posts: 8,941
Seems to work for me.

Server Status: Server is currently up and public.
Stream Status: Stream is up at 128 kbps with 0 of 32 listeners (0 unique)
Listener Peak: 1
Average Listen Time: 2m 04s
Stream Title: False Grievances
Content Type: audio/mpeg
Stream Genre: Good stuff
Stream URL: www.shoutcast.com
Stream AIM: N/A
Stream IRC: #shoutcast
Current Song: Smile Empty Soul - Rain
Jay is offline   Reply With Quote
Old 20th October 2003, 11:40   #12
Grievance
Junior Member
 
Join Date: Oct 2003
Posts: 9
Awesome.. it wasnt working for me earlier.

Im at work now and the only problem I have left is that my winamp has to rebuffer about every 10-20 seconds. Do I need to lower the Kbps?
Grievance is offline   Reply With Quote
Old 20th October 2003, 16:47   #13
FesterHead
Alumni
 
FesterHead's Avatar
 
Join Date: Sep 2001
Location: Maui, Hawaii
Posts: 14,103
Check the DNASs bandwidth. You'll need quite a lot of bandwidth to serve 32 listeners at 320kbps.

Check out the Sticky post titled:
SHOUTcast: Important Info & Answers to FAQs. READ ME!

Scroll down a bit and look for the section titled:
1. DNAS Stuff -> Bandwidth -> DSLReports Bandwidth tester(Only be concerned with the UPLOAD bandwidth)
2. DNAS Stuff -> Bandwidth -> CasterClub's Listener Calculator
3. DNAS Stuff -> Bandwidth -> CasterClub's Bandwidth Calculator

Use 1 to find your upload.
Use 2 to determine the number of listeners you can support at your selected streaming bitrate.

Additionally, your listeners download needs to exceed your streaming bitrate.

Jay (KXRM) also has a Bandwidth Calculator.

FesterHead is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump