Old 9th September 2017, 21:58   #1
radublack
Junior Member
 
Join Date: Oct 2016
Posts: 8
DNAS is now available: 2.5.5.732

Please install this update as soon as possible, thank you.

Is not working after update when on
Stage 4 - Save Settings is not showing on page this option :

Save Settings

Successfully saved settings to the config file (sc_serv.conf).

Click 'Run Server' to run the server with the specified settings or 'Exit' to close this instance of the server (run without a configuration file to use the new settings).
radublack is offline   Reply With Quote
Old 9th September 2017, 23:24   #2
djSpinnerCee
Forum King
 
djSpinnerCee's Avatar
 
Join Date: Aug 2004
Location: Hollis, Queens/The Bronx, NYC
Posts: 3,555
once you change the config you should restart the dnas -- all settings do not reset in-band.

when you config as a win service -- the service wll not be started automatically -- it will run on reboot, but you will have to start the service through services.
djSpinnerCee is offline   Reply With Quote
Old 10th September 2017, 01:35   #3
Busby
Senior Member
 
Busby's Avatar
 
Join Date: Apr 2004
Location: Isle of Man UK
Posts: 159
Can anyone tell me if it's possible to do the update while the streams are live, then do a restart, or do I need to stop the streams, update, then start them again.

Stopping my streames means dumping all my listeners which isn't ideal..

Go easy on me...
https://1mix.co.uk
Busby is offline   Reply With Quote
Old 10th September 2017, 02:51   #4
dopelabs
Major Dude
 
dopelabs's Avatar
 
Join Date: Oct 2006
Location: Silicon Valley
Posts: 539
Send a message via AIM to dopelabs
yes to run the new version it requires a full DNAS restart... it must execute the new binary which contains all the new code. im not sure about windows, but i have replaced the sc_serv file with the new version while the DNAS has been running. then its just a matter of killing the process and re-launching it, which can happen pretty much instantly (your still going to dump the listeners)... but if you have been using a .pls file as the primary means of providing a tune in url for your listeners, and you have multiple servers in a single pls file, then the default behavior if the dnas they are listening to goes down, is to play the next item in the playlist. usually this would be a different server such as a relay, used for overflow and fallback or load balancing purposes... sometimes its just a different bitrate on the same server. either way most players will iterate through all the items in the playlist before either giving up, or continuing to iterate through the items in a loop.

code:
$ kill -9 <pid of sc_serv> && /path/to/sc_serv daemon /path/to/sc_serv.conf
dopelabs is offline   Reply With Quote
Old 10th September 2017, 04:43   #5
djSpinnerCee
Forum King
 
djSpinnerCee's Avatar
 
Join Date: Aug 2004
Location: Hollis, Queens/The Bronx, NYC
Posts: 3,555
dump the listeners if you need to update -- it's a one time thing -- so if they]re "real" listeners, they'll b back. imho
djSpinnerCee is offline   Reply With Quote
Old 11th September 2017, 08:40   #6
radublack
Junior Member
 
Join Date: Oct 2016
Posts: 8
I did it all to start server but is not show me CONTINUE icon !!

https://imgur.com/h4Wio0a
I use windows 10
radublack is offline   Reply With Quote
Old 11th September 2017, 09:26   #7
dopelabs
Major Dude
 
dopelabs's Avatar
 
Join Date: Oct 2006
Location: Silicon Valley
Posts: 539
Send a message via AIM to dopelabs
i think you might need rewriteconfigs=1 set in the config
dopelabs is offline   Reply With Quote
Old 11th September 2017, 15:10   #8
3rror
Junior Member
 
Join Date: Mar 2013
Posts: 9
When I update and restart 128K mp3 streams work, but 56k and slower fail to clients. For some reason changing the Windows shoutcast DSP source to another sample rate works initially but stops after the first connection. A linux source has the same problem. Are there any other changes needed besides restarting the DNAS? Running Windows 10 64bit.
3rror is offline   Reply With Quote
Old 11th September 2017, 15:23   #9
djSpinnerCee
Forum King
 
djSpinnerCee's Avatar
 
Join Date: Aug 2004
Location: Hollis, Queens/The Bronx, NYC
Posts: 3,555
@3rror: maybe a win64 issue?

http://forums.winamp.com/showthread.php?t=451687
djSpinnerCee is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump