Old 31st January 2012, 19:46   #1
chris.zeman
Junior Member
 
Join Date: Jan 2012
Posts: 16
Send "Now Playing" Info to SHOUTcast Directory

I have a number of streams that are listed in the SHOUTcast directory, but the current tracks aren't showing up the directory. They are, however, being displayed on the server and on listeners' players. Am I missing something simple?

Thank you,
Chris
chris.zeman is offline   Reply With Quote
Old 31st January 2012, 20:26   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
as i believe you're using the v2 DNAS, there is a bug in the current public build which causes the title not to be passed to the YP in all cases (usually if the stream is fed by a source using the v1 protocol). it's something fixed internally, just hasn't been released as there's still a few other things to be finished off / issues resolved before we release an update.

-daz
DrO is offline   Reply With Quote
Old 31st January 2012, 22:02   #3
chris.zeman
Junior Member
 
Join Date: Jan 2012
Posts: 16
Excellent! Thank you! You are correct. I am using the latest releases of sc_serv and sc_trans. I don't use Winamp to send my streams up, so I'm using curl to update the stream information.

Thank you,
Chris
chris.zeman is offline   Reply With Quote
Old 31st January 2012, 22:08   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
that'd be it then. you could try making curl send an xml title update instead of the v1 style plain text on the updinfo method as that should get the title updates working (as an xml update will fill in the v2 title information which is correctly passed onto the YP).

the format of the xml for just sending it like a v1 source but in v2 mode is the first example shown at http://wiki.winamp.com/wiki/SHOUTcas...lds_To_Support

-daz
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump