Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Reply
Thread Tools Search this Thread Display Modes
Old 30th November 2010, 17:23   #1
stopasking
Banned
 
Join Date: Jun 2008
Posts: 446
Old version of "Playlist Generator" crashes Winamp when I try to scan my library

OK I have looked all over this forum for solutions and here is a rundown of some info and what I have done (now I am completely out of ideas, any help is welcome)

- My winamp version is v5.56 (Jul 1 2009)

- My library is ~38000 songs. I keep them "clean" and well-tagged. All files are mp3.

- Winamp has internet access

- It crashes only at the stage 4/4, at seemingly random location, and if "more info" is clicked it mentions nde.dll

- I delete the 3 files it creates (cddbplm.pdb, cddbplm.idx, cddbplm.gcf) between each try, as instructed, (or it fails to initialize).

This happens:
It gets flawlessly to step 4/4 every time, then sometime in the scan comes the windows error that winamp crashed. After it first happened, I went over my library to make sure nothing had strange characters in filenames etc. Even ran that nifty little tool "mp3val" on my library. Scanned again. Crashed again.

Then I checked how far it came. it was 12000 something (don't remember now) and I looked in another tool, which can follow the path structures, what album song lied there. Turns out, it was the first song of an album. I removed this album from my library - scanned again. Crashed again. This time on 14000 something. I looked what song would be in this position and once again, it was the first song of an album. I figured the scan choked on theese albums, so for test I cleared my winamp, and put only theese two albums in, and scanned. Sad thing is that the scan actually passed when only thoose two albums were in. So it never were problems with files - it is a problem with Winamp.

So now I come here. I really want to use this feature can someone shed some light on this? At a glance, it would seem like Winamp "gets tired" after lots of songs have been scanned at once, and then crash, but I don't know how viable accusation that is :P

Ideas anyone?
stopasking is offline   Reply With Quote
Old 30th November 2010, 17:30   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
try 5.6 which has had the playlist generator re-worked (hopefully with bug fixes to it).

-daz
DrO is offline   Reply With Quote
Old 1st December 2010, 04:33   #3
stopasking
Banned
 
Join Date: Jun 2008
Posts: 446
OK. Can someone confirm that this issue is actually fixed in the latest winamp version? i'm not so overly keen on updating if it makes no difference..
stopasking is offline   Reply With Quote
Old 1st December 2010, 04:44   #4
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,867
Yes, it's fixed :-)
DJ Egg is offline   Reply With Quote
Old 1st December 2010, 05:00   #5
stopasking
Banned
 
Join Date: Jun 2008
Posts: 446
Alright! thanks both of you for helping me. Skimming the changelog, I guess this update is long overdue anyhow
stopasking is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump